Results 1 to 9 of 9

Thread: Desktop effects are not supported......

  1. #1
    ccline19 NNTP User

    Default Desktop effects are not supported......

    I am unable to enable desktop effects and receive the above message when I try. I have the following installed:

    OpenSuse 11.2
    Gnome 2.27.92
    Kernel 2.6.31
    radeonhd is the X.org X11 driver for AMD GPG (ATI) r5xx/r6xx chipsets

    I have a ATI 1950 PCIE video card installed and 3D is enabled.
    The output of rpm -qa --last "*compiz*" reads

    compizconfig-settings-manager-0.7.8-5.1 Tue 29 Sep 2009 04:22:43 AM EDT
    python-compizconfig-0.7.8-1.90 Tue 29 Sep 2009 04:22:04 AM EDT
    compiz-fusion-plugins-main-0.7.8-12.3 Tue 29 Sep 2009 04:20:58 AM EDT
    libcompizconfig-0.7.8-7.2 Tue 29 Sep 2009 04:20:55 AM EDT
    compiz-manager-0.0.1_git080201-58.1 Tue 29 Sep 2009 04:20:52 AM EDT
    compiz-0.7.8-40.1 Tue 29 Sep 2009 04:18:42 AM EDT
    compiz-gnome-0.7.8-40.1 Tue 29 Sep 2009 04:14:39 AM EDT
    compiz-branding-openSUSE-0.7.8-40.1 Tue 29 Sep 2009 03:48:37 AM EDT

    There is no xorg.conf file in the etc/X11 directory so I assume the radeon driver is auto-configuring. Any help would be appreciated. On a side note I have tried Opensuse 11.2 KDE and Ubuntu 9.10 and Desktop Effects have worked fine.

    Thanks.

  2. #2
    Christian Riechers NNTP User

    Default Re: Desktop effects are not supported......

    On 10/07/2009 01:36 PM, ccline19 wrote:
    >
    > I am unable to enable desktop effects and receive the above message when
    > I try. I have the following installed:
    >
    > OpenSuse 11.2
    > Gnome 2.27.92
    > Kernel 2.6.31
    > radeonhd is the X.org X11 driver for AMD GPG (ATI) r5xx/r6xx chipsets
    >
    > I have a ATI 1950 PCIE video card installed and 3D is enabled.
    > The output of rpm -qa --last "*compiz*" reads
    >
    > compizconfig-settings-manager-0.7.8-5.1 Tue 29 Sep 2009 04:22:43
    > AM EDT
    > python-compizconfig-0.7.8-1.90 Tue 29 Sep 2009 04:22:04
    > AM EDT
    > compiz-fusion-plugins-main-0.7.8-12.3 Tue 29 Sep 2009 04:20:58
    > AM EDT
    > libcompizconfig-0.7.8-7.2 Tue 29 Sep 2009 04:20:55
    > AM EDT
    > compiz-manager-0.0.1_git080201-58.1 Tue 29 Sep 2009 04:20:52
    > AM EDT
    > compiz-0.7.8-40.1 Tue 29 Sep 2009 04:18:42
    > AM EDT
    > compiz-gnome-0.7.8-40.1 Tue 29 Sep 2009 04:14:39
    > AM EDT
    > compiz-branding-openSUSE-0.7.8-40.1 Tue 29 Sep 2009 03:48:37
    > AM EDT
    >
    > There is no xorg.conf file in the etc/X11 directory so I assume the
    > radeon driver is auto-configuring. Any help would be appreciated. On a
    > side note I have tried Opensuse 11.2 KDE and Ubuntu 9.10 and Desktop
    > Effects have worked fine.
    >
    > Thanks.
    >
    >


    I'm not sure how you can run X without having a xorg.conf file. You may
    be in trouble the next time X will be started.

    I'd run the following steps to configure X for radeonhd:
    - log out of Gnome
    - change to a console by Ctrl-Alt-F1
    - login as root
    - change to runlevel 3
    # init 3
    - then:
    # sax2 -r -m 0=radeonhd
    This will create a new xorg.conf file. Make sure 3D is enabled.
    - Once the config is complete, change back to run-level 5.
    # init 5
    - log off from console
    - change back to X by Alt-F7
    - get back into Gnome and verify desktop effects.

    If that still doesn't get desktop effects going, you may try to add the
    openSuSE-11.1-Xgl repository:
    http://download.opensuse.org/reposit...openSUSE_11.1/
    Then upgrade the Compiz packages.

    --
    Christian

  3. #3
    Christian Riechers NNTP User

    Default Re: Desktop effects are not supported......

    On 10/07/2009 03:49 PM, Christian Riechers wrote:
    > On 10/07/2009 01:36 PM, ccline19 wrote:
    >>
    >> I am unable to enable desktop effects and receive the above message when
    >> I try. I have the following installed:
    >>
    >> OpenSuse 11.2
    >> Gnome 2.27.92
    >> Kernel 2.6.31
    >> radeonhd is the X.org X11 driver for AMD GPG (ATI) r5xx/r6xx chipsets
    >>

    >
    > If that still doesn't get desktop effects going, you may try to add the
    > openSuSE-11.1-Xgl repository:
    > http://download.opensuse.org/reposit...openSUSE_11.1/
    > Then upgrade the Compiz packages.
    >


    Correction:
    You're using a 11.2 Milestone, so don't mess with the 11.1 Xgl
    repository. Not sure if there are other repositories for this though.

    --
    Christian

  4. #4
    ccline19 NNTP User

    Default Re: Desktop effects are not supported......

    The problem was there wasn't any xorg.conf file created and yes, I have absolutely no idea how my desktop was running without it but it was. The xorg.config.install was there but no xorg.conf. As you suggested I created the xorg.conf file and now, desktop effects work.

  5. #5

    Default Re: Desktop effects are not supported......

    I've tried this and got my xorg.conf, but still no effects (I have radeon HD 4650). Now I can't even start simple-ccsm.
    The output of rpm -qa --last "*compiz*" reads:
    spiro@spirol-zgon:~/gnome-shell/source/gnome-shell/src> rpm -qa --last "*compiz*"
    compizconfig-settings-manager-0.7.8-7.1 Fri 13 Nov 2009 06:06:22 PM CET
    compiz-plugins-extra-0.8.4-1.1 Fri 13 Nov 2009 06:06:09 PM CET
    python-compizconfig-0.8.4-4.1 Fri 13 Nov 2009 06:05:55 PM CET
    compiz-plugins-main-0.8.4-1.1 Fri 13 Nov 2009 06:05:51 PM CET
    libcompizconfig-0.8.4-10.1 Fri 13 Nov 2009 06:05:42 PM CET
    compiz-manager-0.0.1_git080201-60.2 Fri 13 Nov 2009 06:05:37 PM CET
    compiz-0.8.4-145.1 Fri 13 Nov 2009 06:05:28 PM CET
    compiz-branding-openSUSE-0.8.4-145.1 Fri 13 Nov 2009 06:05:15 PM CET
    compiz-gnome-0.8.4-145.1 Fri 13 Nov 2009 06:05:13 PM CET

  6. #6

    Default Desktop effects are not supported......for existing users

    After I installed the NVIDIA drivers Desktop Effects still does not work for for existing users.
    But it works for a new user.
    So, there should be something wrong in the user configuration. Can someone tell me what? Thanks.

  7. #7

    Default Re: Desktop effects are not supported......

    Try deleting the compiz config folder in the user's homefolder.

  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Desktop effects are not supported......

    Try the following steps:

    1. Open konsole, type in su followed by the password.
    2. Type in: init 3

    For Radeon card:

    3. sax2 -r -m 0=fglrx

    For NVIDIA card:

    sax2 -r -m 0=nvidia

    4. Type in: init 5; exit


    Good Luck!
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  9. #9
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Desktop effects are not supported......

    BTW Did you run aticonfig after installing the ATI video driver?
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •