Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: All White Screen after Log In!

  1. #1

    Default All White Screen after Log In!

    Hello. After getting bored of the basic themes a trip to Gnome Look was a nice alternative.

    Even in Ubuntu I am not a pro at installing Tarballs. I remember reading in some threads that you dragged the package to the appearances box. The metacity package installed on my GnomeSuse.

    Okay I then wondered what had happened to the GTK and Metacity options that I had installed from the Software Installer. I wondered if they were in the Desktop Effects tab. I enabled advanced effects and then got a message saying something about my graphics adapter. I went ahead and enabled advanced effects and then the screen went all white.

    I can't see anything. I somehow rotate the screens and it's a cube. I still can't see anything. I want to disable advanced effects to revert back to my original settings. GRUB is viewable. It has the green background and I can see the log in names. It's just when I log into my account it then turns all white and I can't see again.


  2. #2

    Default Re: All White Screen after Log In!

    I may have an idea but am not too familiar with Suse 11.1 command lines.

    I take it I could use the LiveDisc and make an edit to turn off the Advanced Desktop Effects that I foolishly enabled.

    My Thinkpad has the X200M ATI on it which should be able to handle the Desktop effects. My guess is since I did not install the drivers package for it my display went kazooey.

    Any suggestions?

  3. #3

    Default Re: All White Screen after Log In!

    It's a punt, but if it's running, but not displaying, you can just type blind. Open it, then hit alt-f2, wait a couple of seconds, type gnome-terminal, hit return, wait a couple of seconds, then type

    metacity --replace&
    There are a few other ideas in this thread;

    Gnome Vs Kde - openSUSE Forums

  4. #4

    Default Re: All White Screen after Log In!

    Where do I type "blind" in at?

    I can't even log into Failsafe. I try entering my username and the password but it won't let me!

    I tried logging into my regular account and typing blind. Again I don't know what this will do since I can't see anything!

    Any more ideas?


    I also noticed in that link they mentioned CLI. What is that? As for the Failsafe mode I get all the way up to the prompt for Username and Password. I type them in correctly and it says they are incorrect.
    Last edited by emeraldgirl08; 20-Sep-2009 at 16:31. Reason: more detail

  5. #5

    Default Re: All White Screen after Log In!

    I don't mean type the word 'blind', I mean you can type things without seeing the feedback on the screen - as long as the system isn't frozen, it doesn't matter whether you can see what you're typing, as long as you're careful.

    If the cube is rotating, then it doesn't sound frozen. So load it up, log in, and hit alt-f2 (which means run), then type the things suggested in the previous post. Might work. (make sure you put a space between 'metacity' and the two hyphens)

    If you need to get to the Command Line Interface (CLI), at the boot menu, where it lets you choose 'openSUSE' or 'failsafe', press escape to drop to text mode. You can then move the cursor down to 'openSUSE', and press 'e' for edit. Move the cursor onto the line that says 'kernel', and press 'e' again. Now add the number '3' to the end of the line, with a space before it. Press return, then press 'b' for boot. That'll load suse in runlevel 3, which is CLI. You can reboot again by typing 'su', pressing return, enterring your root password, and typing 'reboot'.

    Why it's refusing your password I don't know. First things first, try the above trick with alt-f2, and see what happens. Type carefully.

  6. #6

    Default Re: All White Screen after Log In!

    Yeah. I kinda figured there was some elaborate way of doing this

    bbl going to try this out!

  7. #7

    Default Re: All White Screen after Log In!

    Okay I can see things now. The minimize, maximize, and close tabs are gone for everything.

    I also can't switch screens and can't get that gnome-terminal icon off the taskbar. I tried reinstalling Metacity b/c I'm guessing Metacity is for the min, max, and close windows right?

    The Metacity package finished downloading but never reinstalled. I just aborted and restarted the laptop.

    Same thing again. White screen.

    Opened up F2 and did the gnome-terminal command again.

    That's where I'm at now.

  8. #8

    Default Re: All White Screen after Log In!

    Unfortunately I'm not a Gnome SUSE user, so I don't really know what you should do here.

    Basically, there are two window managers used normally with gnome - metacity and compiz. Compiz is more advanced, and has whizzbang effects like the cube. Or it just crashes.

    metacity --replace& just switches it over to metacity. So you've got two options - find a way to get it to default to metacity, or change the settings in compiz / your graphics driver so it can work without crashing. You might find if you can install compiz config settings manager it'll help you adjust compiz - but the first thing I'd try to do is to undo whatever it was that caused this problem in the first place...

    Good luck!

  9. #9

    Default Re: All White Screen after Log In!

    Isn't there a command like sudo apt-get update that will fix the broken packages? or at least update it from that command?

    Ugh. I'm locked out of using terminal also! I brought up gnome terminal to issue a command and it won't let me do anything. I feel like I'm in some kind of safe mode or limited access mode.


    Thanks for your help! I'll just switch back over to another OS and work this out over time!

  10. #10
    Join Date
    Jun 2008
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Blog Entries

    Default Re: All White Screen after Log In!

    At root prompt do:
    xgl-switch --disable-xgl
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts