Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How to disable cube activation?

  1. #1
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default How to disable cube activation?

    Hi there. I'm on suse 11.1 kde 4.3. In desktop effects I have enabled Desktop cube and the only shortcut for activation displayed in settings is "Ctrl+Alt+Down" and it works ok. However desktop cube also activates when I move the mouse pointer to the right edge of the screen, I would like to disable this way of activation. I guess I have set up this activation through mouse somewhere, but don't remember where Does anyone know where this setup may be? Thanks.

  2. #2
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: How to disable cube activation?

    Hi,

    in 'configure desktop' -> 'Desktop' -> 'all effects' tab: there should be a tool button next to desktop cube -> 'basic' tab: change 'screen edge'

    Regards,
    Barry.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,824
    Blog Entries
    15

    Default Re: How to disable cube activation?

    Quote Originally Posted by arcull
    Hi there. I'm on suse 11.1 kde 4.3. In desktop effects I have enabled
    Desktop cube and the only shortcut for activation displayed in settings
    is "Ctrl+Alt+Down" and it works ok. However desktop cube also activates
    when I move the mouse pointer to the right edge of the screen, I would
    like to disable this way of activation. I guess I have set up this
    activation through mouse somewhere, but don't remember where
    Does anyone know where this setup may be? Thanks.
    Hi
    If you start simple-ccsm from a terminal (not sure where in the menu
    system on KDE it is) there is a tab called edges, right-click and scroll
    through the list to change.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 1:47, 2 users, load average: 0.19, 0.07, 0.12
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  4. #4
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: How to disable cube activation?

    in 'configure desktop' -> 'Desktop' -> 'all effects' tab: there should be a tool button next to desktop cube -> 'basic' tab: change 'screen edge'
    I can't see "screen edge" anywhere
    Hi
    If you start simple-ccsm from a terminal (not sure where in the menu
    system on KDE it is) there is a tab called edges, right-click and scroll
    through the list to change.
    it says some 'blah blah' like this program is not installed but if I do
    Code:
    simple-ccsm-kde
    I guess I get the settings you mean, but even If I disable all edges, the cube still activates with mouse grrr...Do I need to have installed something special to be able to deactivate this maybe? Thanks again for you help.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,824
    Blog Entries
    15

    Default Re: How to disable cube activation?

    Quote Originally Posted by arcull

    >
    > in 'configure desktop' -> 'Desktop' -> 'all effects' tab: there should
    > be a tool button next to desktop cube -> 'basic' tab: change 'screen
    > edge' I can't see "screen edge" anywhere
    > Hi
    > If you start simple-ccsm from a terminal (not sure where in the menu
    > system on KDE it is) there is a tab called edges, right-click and
    > scroll
    > through the list to change. it says some 'blah blah' like this
    > program is not installed but if I do


    Code:
    --------------------
    simple-ccsm-kde
    --------------------
    I guess I get the settings you mean, but even If I disable all edges,
    the cube still activates with mouse grrr...Do I need to have
    installed something special to be able to deactivate this maybe? Thanks
    again for you help.
    Hi
    On Gnome the compiz configuration information is in
    ~/.config/compiz/compizconfig-1 have a browse there and remember to
    copy the files somewhere as backups before making any changes.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 2:47, 2 users, load average: 0.18, 0.27, 0.91
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  6. #6
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: How to disable cube activation?

    Hi
    On Gnome the compiz configuration information is in
    ~/.config/compiz/compizconfig-1 have a browse there and remember to
    copy the files somewhere as backups before making any changes.
    there are 2 file available: config with content
    Code:
    [kde4_session]
    backend = ini
    profile =
    and Default.ini with content
    Code:
    [core]
    as_active_plugins = core;decoration;resize;regex;glx;dbus;workarounds;wm;place;png;animation;minimize;wobbly;fade;cube;rotate;move;switcher;scale;
    
    [animation]
    s0_open_effects = animation:Zoom;
    s0_close_effects = animation:Zoom;
    
    [rotate]
    but nothing seems to be setting some mouse edge activity. Any other idea maybe.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,824
    Blog Entries
    15

    Default Re: How to disable cube activation?

    Quote Originally Posted by arcull

    > Hi
    > On Gnome the compiz configuration information is in
    > ~/.config/compiz/compizconfig-1 have a browse there and remember to
    > copy the files somewhere as backups before making any changes. there
    > are 2 file available: config with content

    Code:
    --------------------
    [kde4_session]
    backend = ini
    profile =
    <snip>
    but nothing seems to be setting some mouse edge activity. Any other
    idea maybe.
    Hi
    I would have thought profile = Default.ini rather than blank? Else what
    about the ccsm command?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 3:19, 2 users, load average: 0.01, 0.04, 0.15
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,824
    Blog Entries
    15

    Default Re: How to disable cube activation?

    Quote Originally Posted by Malcolm
    Hi
    I would have thought profile = Default.ini rather than blank? Else what
    about the ccsm command?
    [/QUOTE]
    It should just be profile = Default (no ini)

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 3:34, 2 users, load average: 0.18, 0.07, 0.09
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  9. #9
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: How to disable cube activation?

    Hi
    I would have thought profile = Default.ini rather than blank? Else what
    about the ccsm command?
    Ok, I did change that in mentioned config file, logout from kde, login again, tried to simple-ccsm-kde
    again, but no change in Edges did have any positive effect.ccsm command doesn't work, it says ccsm can be found in "compizconfig-settings-manager", this may be because I didn't install any extra compiz package (should I have installed it maybe ?), just default kde effects. Any other clue maybe.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,824
    Blog Entries
    15

    Default Re: How to disable cube activation?

    Quote Originally Posted by arcull

    > Hi
    > I would have thought profile = Default.ini rather than blank? Else
    > what about the ccsm command? Ok, I did change that in mentioned
    > config file, logout from kde, login

    again, tried to simple-ccsm-kde
    again, but no change in Edges did have any positive effect.ccsm command
    doesn't work, it says ccsm can be found in
    "compizconfig-settings-manager", this may be because I didn't install
    any extra compiz package (should I have installed it maybe ?), just
    default kde effects. Any other clue maybe.
    Hi
    Hmmm, sure it's not some kwin effect running since that's the default
    on KDE4?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 8:43, 2 users, load average: 0.43, 0.51, 0.33
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •