Results 1 to 2 of 2

Thread: [11.2] alien

  1. #1
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default [11.2] alien

    I have to convert deb package to an rpm

    @software.opensuse.org/search
    I found the repository that contained alien program
    by one click I install it

    Code:
    Information for package alien:
    
    Repository: @System
    Name: alien
    Version: 8.78-1.9
    Arch: noarch
    Vendor: obs://build.opensuse.org/openSUSE:Factory
    Installed: Yes
    Status: up-to-date
    Installed Size: 238.0 KiB
    Summary: A Perl Script to Convert Packages
    Description:
    Experimental Perl script to convert software packages. The following
    formats are supported: deb (Debian), rpm (Red Hat), and tgz
    (Slackware).
    when I try to convert it give me an error
    Code:
    mySRCrepo> sudo alien -r prf.deb
    Control file couldn't be read! at
    /usr/lib/perl5/vendor_perl/5.10.0/Alien/Package/Deb.pm line 162
    --
    [opensuse:11.2 Milestone 8 | x86-64]
    WBR


  2. #2
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: [11.2] alien

    This is an alien bug. I would remove it and try an older version of alien.
    Klaatu Barada Nikto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •