Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Compiz + Gnome 2.26 Conflict (+ ATI probably)

  1. #1
    brimmasch NNTP User

    Default Compiz + Gnome 2.26 Conflict (+ ATI probably)

    So... I just upgraded to Gnome 2.26 but discovered that Compiz stopped working. Emerald still works, 3D acceleration still works, but Compiz stopped working. Emerald stopped working temporarily until I turned off desktop effects under "Desktop Effects" in "Look and Feel" in the Control Center. Until I turned off desktop effects, none of the windows had decorations and could not be moved. It was very bizarre. Let me explain bizarre for search engine users' benefit. I could not click and drag windows. Windows had to title bars, minimize, maximize or close buttons.

    I could not, however, get effects and emerald working at the same time. Right now I have emerald but no effects.

    The weirder thing is... "Desktop Effects" will no longer launch from the Control Center so I can't try to turn effects back on. I decided to download the CCSM (CompizConfig Settings Manager) and see if that would fix anything. It doesn't. If I enable stuff in there, it doesn't actually start working.

    I discovered after a little searching that if I ran:

    compiz --replace

    from the command line everything goes back to normal I could get effects to work again. This was weird to me because if I turn that stuff on in CCSM it should be running that some place, right?

    So... here's the question. Why can't I open "Desktop Effects" which I'm sure is a smaller version of CCSM packaged with OpenSuse 11.1?

    And another question... where is "compiz --replace" supposed to be ran?

    And another... is there a log file to see why "Desktop Effects" won't launch from the Control Center?

    This is all very bizarre.

    Do they really expect you to start "compiz --replace" manually every time you boot? There should be a service or something for that, right?

  2. #2
    brimmasch NNTP User

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Here's something else I noticed. Now that effects and emerald are working... CCSM doesn't govern how Compiz behaves. I can make changes there all day long and none of the window effects match the changes I make.

    Does this mean I have two compiz config files? Do I have two compiz installations? If I want compiz and emerald (installed from the "Compiz XGL" build services respository) do I have to uninstall any packages that came with 11.1's vanilla install?

    11.1 sure pisses me off sometimes. I've never had headaches with compiz+gnome+gldrivers like I've had until now.

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Hi,

    I'm a KDE user myself, never really bothered with Gnome. But I am somewhat rehearsed in getting compiz-fusion to work, so I'll try to help since no one else is stepping in. Let's check what packages you have installed. Could you please open up a terminal and provide the output of:

    Code:
    rpm -qa --last "*compiz*"
    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Compiz also broke when I upgraded to gnome 2.26. Get the version of compiz from the X11(colon)XGL repository. All will be fine.

  5. #5
    brimmasch NNTP User

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Quote Originally Posted by ijbreakey View Post
    Hi,

    I'm a KDE user myself, never really bothered with Gnome. But I am somewhat rehearsed in getting compiz-fusion to work, so I'll try to help since no one else is stepping in. Let's check what packages you have installed. Could you please open up a terminal and provide the output of:

    Code:
    rpm -qa --last "*compiz*"
    Take Care,

    Ian
    compiz-0.8.2-163.1 Tue 06 Oct 2009 08:28:32 AM MDT
    libcompizconfig-backend-gconf-0.8.2-2.4 Mon 05 Oct 2009 03:51:08 PM MDT
    compizconfig-settings-manager-0.8.2-105.1 Mon 05 Oct 2009 03:51:06 PM MDT
    python-compizconfig-0.8.2-3.4 Mon 05 Oct 2009 03:51:02 PM MDT
    libcompizconfig-0.8.2-10.1 Mon 05 Oct 2009 03:51:01 PM MDT
    compiz-manager-0.0.1_git080201-58.1 Mon 05 Oct 2009 03:51:01 PM MDT
    compiz-plugins-unsupported-0.8.2-100.1 Mon 05 Oct 2009 03:50:38 PM MDT
    compiz-gnome-0.8.2-163.1 Mon 05 Oct 2009 03:50:36 PM MDT
    compiz-emerald-themes-0.6.0-2.1 Mon 05 Oct 2009 03:43:20 PM MDT
    compiz-kde-0.8.2-163.1 Mon 05 Oct 2009 03:43:16 PM MDT
    compiz-emerald-0.8.2-2.4 Mon 05 Oct 2009 03:43:11 PM MDT
    compiz-branding-openSUSE-0.8.2-163.1 Mon 05 Oct 2009 03:43:06 PM MDT
    compiz-fusion-plugins-main-0.7.8-4.13 Tue 11 Aug 2009 10:22:14 AM MDT
    compiz-plugins-extra-0.8.2-102.2 Tue 11 Aug 2009 09:51:42 AM MDT
    compiz-plugins-main-0.8.2-100.1 Tue 11 Aug 2009 09:51:26 AM MDT


    (and thank you for stepping in to help)

  6. #6
    brimmasch NNTP User

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Quote Originally Posted by JJMT View Post
    Compiz also broke when I upgraded to gnome 2.26. Get the version of compiz from the X11(colon)XGL repository. All will be fine.
    I'm pretty sure that's the version I have. I'll try forcing an install just to be certain.

  7. #7
    brimmasch NNTP User

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Okay... one more thing I've just noticed. Not EVERYTHING starts working when I run "compiz --replace" from the command line. Just the Desktop Cube I think. I'm still missing window effects such as transparency when you drag and the opening, closing, minimizing and maximizing effects.

  8. #8

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Yes. Again, for me, when compiz came back after the upgrade to 2.26 and the reinstall of compiz, I didn't evn had the cube, although compiz was running. I had to run Compizconfig Settings Managerand re-enable all the effects.

  9. #9
    brimmasch NNTP User

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Quote Originally Posted by JJMT View Post
    Yes. Again, for me, when compiz came back after the upgrade to 2.26 and the reinstall of compiz, I didn't evn had the cube, although compiz was running. I had to run Compizconfig Settings Managerand re-enable all the effects.
    See... the thing is... They are enabled in CCSM. It doesn't matter though. CCSM isn't turning them on. It says they are enabled in CCSM but they're not. They don't work. CCSM doesn't seem to be governing the configuration of compiz.

  10. #10

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Did you try renaming the ~/.config/compiz directory?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •