Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Compiz + Gnome 2.26 Conflict (+ ATI probably)

  1. #11
    brimmasch NNTP User

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Quote Originally Posted by JJMT View Post
    Did you try renaming the ~/.config/compiz directory?
    Yes.

    I ended up fixing the problem though. I uninstalled everything from

    rpm -qa "*compiz*" and manually installed everything from the CompizGL repo by downloading in manually, ignoring dependencies and installing with zypper from the command line.

    That fixed it and I'm guessing it's because either I have dependencies cached wrong or there's an package with the wrong dependencies installed. One of those packages was apparently a difference build of .8.2 that wasn't compatible with the other vesrions of .8.2.

    Oh, well. It's fixed.

    Solution...

    Remove EVERY package with the pattern "compiz" in it. Download the packages manually from the CompizGL Build Service Repo and install with zypper via command line.

    What a headache.

  2. #12
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz + Gnome 2.26 Conflict (+ ATI probably)

    Sorry, I've had a busy day today with school and rugby. The problem was apparent from your package listing. You had

    Code:
    compiz-0.8.2-163.1 Tue 06 Oct 2009 08:28:32 AM MDT
    libcompizconfig-backend-gconf-0.8.2-2.4 Mon 05 Oct 2009 03:51:08 PM MDT
    compizconfig-settings-manager-0.8.2-105.1 Mon 05 Oct 2009 03:51:06 PM MDT
    python-compizconfig-0.8.2-3.4 Mon 05 Oct 2009 03:51:02 PM MDT
    libcompizconfig-0.8.2-10.1 Mon 05 Oct 2009 03:51:01 PM MDT
    compiz-manager-0.0.1_git080201-58.1 Mon 05 Oct 2009 03:51:01 PM MDT
    compiz-plugins-unsupported-0.8.2-100.1 Mon 05 Oct 2009 03:50:38 PM MDT
    compiz-gnome-0.8.2-163.1 Mon 05 Oct 2009 03:50:36 PM MDT
    compiz-emerald-themes-0.6.0-2.1 Mon 05 Oct 2009 03:43:20 PM MDT
    compiz-kde-0.8.2-163.1 Mon 05 Oct 2009 03:43:16 PM MDT
    compiz-emerald-0.8.2-2.4 Mon 05 Oct 2009 03:43:11 PM MDT
    compiz-branding-openSUSE-0.8.2-163.1 Mon 05 Oct 2009 03:43:06 PM MDT
    compiz-fusion-plugins-main-0.7.8-4.13 Tue 11 Aug 2009 10:22:14 AM MDT
    compiz-plugins-extra-0.8.2-102.2 Tue 11 Aug 2009 09:51:42 AM MDT
    compiz-plugins-main-0.8.2-100.1 Tue 11 Aug 2009 09:51:26 AM MDT
    You had the main plugins at 0.7.8 while the rest were 0.8.2. You did the right thing, but there's where the problem was.

    You could have just removed the current packages and repository and did the one-click from here:

    Compiz Fusion - openSUSE

    For future reference if anyone else has the problem.

    Glad you got it working though

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •