Results 1 to 10 of 10

Thread: KDE4 / compiz-0.8.2: Missing window decorations

  1. #1

    Question KDE4 / compiz-0.8.2: Missing window decorations

    Hello,

    since I have already spent some time with googling and trying I decided to ask in the forum...

    When I activate compiz, my window decorations are gone.

    System: Thinkpad T30, radeon mobility 7500
    radeon drivers (since fglxr do not run on my HW) are up and running, even 3D works nicely (glxgears, compiz effects)
    compiz/window decorations enabled
    neither emerald nor kde4-window-decorations work. - I even tried to start these programs manually with the --replace switch - nothing happens

    Can somebody please tell me what to do / where to look / what to check -- I'm stuck with this...

    Thanks in advance!

    Reinhard.

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    Hi,

    please verify that you have emerald installed. Go to Yast Software Management and search for emerald. If it's installed then you should be good, if not then install it.

    Next open up the CompizConfig Settings Manager (CCSM) and find the Window Decoration plugin. Make sure there's a check next to it then click into it. Next to the Command option erase what's in there and type

    Code:
    emerald --replace
    Then activate compiz-fusion.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    Ian,

    thanks for your quick reply!

    I did as you suggested and there were no decorations. In fact, emerald IS installed, nevertheless there are no window decorations.

    I restarted compiz --restart ccp and I found the following lines repeatedly in my command shell:

    compiz (core) - Warn: No GLXFBConfig for depth 32
    compiz (core) - Info: Couldn't bind redirected window 0x20000fa to texture

    Since I run my screen on 1400x1050x16 this message makes certain sense, although I see no reason why window decorations are restricted to 32 bit displays...

    When I switched to 32 bit (actually 24 bit), my desktop and its contents turned white as soon as I started compiz - aside from the fact that glxgears is roughly 10 times slower than on 16 bit...

    Still thankful for further advices

    Reinhard.

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    How did you install compiz? There's a chance your install could be screwed up. Please open up a terminal and provide the output of:

    Code:
    rpm -qa --last "*compiz*"
    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    rpm -qa --last "*compiz*"
    compizconfig-settings-manager-0.8.2-6.1 Sun 04 Oct 2009 01:38:36 AM CEST
    compiz-plugins-extra-0.8.2-102.1 Sun 04 Oct 2009 01:35:37 AM CEST
    python-compizconfig-0.8.2-3.1 Sun 04 Oct 2009 01:35:25 AM CEST
    libcompizconfig-0.8.2-9.1 Sun 04 Oct 2009 01:33:50 AM CEST
    compiz-emerald-0.8.2-2.1 Sun 04 Oct 2009 01:33:16 AM CEST
    compiz-plugins-main-0.8.2-100.17 Sun 04 Oct 2009 01:30:41 AM CEST
    compiz-manager-0.0.1_git080201-58.1 Sun 04 Oct 2009 01:30:27 AM CEST
    compiz-0.8.2-162.1 Sat 03 Oct 2009 01:18:31 PM CEST
    compiz-branding-openSUSE-0.8.2-162.1 Sat 03 Oct 2009 01:18:25 PM CEST
    compiz-kde-0.8.2-162.1 Sat 03 Oct 2009 01:18:20 PM CEST
    compiz-kde4-0.8.2-162.1 Sat 03 Oct 2009 01:18:13 PM CEST
    compiz-emerald-themes-0.6.0-2.1 Sat 03 Oct 2009 01:18:02 PM CEST

    There is a script checking for compiz compatibility and everything was ok: Setup - Compiz Wiki
    I use the 1-click installation from Compiz Fusion - openSUSE

    Cheers,

    Reinhard.

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    Which version of KDE4 are you using? If you're using anything other than KDE 4.2 did you follow the steps in the post it refers to under the one-click-installer?

    I just use the native KDE4 desktop effects and I'm using 11.2 milestone 8, but I'm installing compiz-fusion right now to check which packages should be installed.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    Alright, well I checked the packages and you have an extra package. You have compiz-kde and compiz-kde4. Delete compiz-kde and try loading compiz-fusion again.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  8. #8

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    ok, first things first:

    I use KDE 4.3 from the factory repo. Yes, I excluded the 4.2 repo during installation - didn't want more troubles I already had

    Now I removed the compiz-kde package. I didn't test KDE3 but I expect compiz not to work there. Anyhow, KDE4-compiz is still not functional, the problem remains the same.

    Cheers,

    Reinhard.

  9. #9
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    Hmmm. Works fine here. Try reinstalling the emerald packages. And if that doesn't work, try reinstalling all of compiz-fusion. Other than that I'm out of ideas. Sorry.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  10. #10

    Default Re: KDE4 / compiz-0.8.2: Missing window decorations

    Ian,

    thank you for your support!

    After playing around with 'install this' and 'install that' I gave it up - actually I don't feel like spending more time with that right now. Maybe openSUSE 11.2 serves me better...

    Cheers,

    Reinhard.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •