Results 1 to 8 of 8

Thread: Fonts too large on laptop

  1. #1
    Johan_Ekh NNTP User

    Default Fonts too large on laptop

    Hi all,
    I use an external monitor to my opensuse 11.1 laptop that has the
    same resolution as my laptop screen. Works fine. However, when I use my laptop screen the fonts are too large in applications and menus.

    I want everything to look exactly the same as on my large external
    monitor (that has the same resolution!). What should I do?

    Best regards,
    Johan

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Fonts too large on laptop

    I wonder whether your external monitor is configured correctly? Maybe post contents of /etc/X11/xorg.conf file. The physical display dimensions are contained in the "Monitor" sections. For example, my display:

    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 331 207
    HorizSync 40-60
    Identifier "Monitor[0]"
    ModelName "THINKPAD TFT"
    Option "PreferredMode" "1280x800"
    VendorName "IBM"
    VertRefresh 50-65
    UseModes "Modes[0]"
    EndSection
    If I alter the display size dimensions, I can affect the default font sizes.

  3. #3
    Johan_Ekh NNTP User

    Default Re: Fonts too large on laptop

    Hi, see my xorg.conf below.
    How do I know what to set "DisplaySize" to?



    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 305 230
    HorizSync 30-85
    Identifier "Monitor[0]"
    ModelName "1920X1200@60HZ"
    Option "DPMS"
    Option "PreferredMode" "1920x1200"
    VendorName "--> LCD"
    VertRefresh 50-60
    UseModes "Modes[0]"
    EndSection

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Fonts too large on laptop

    If you select your monitor via control centre (not sure which desktop you're using), then these parameters are usually set for you based on model chosen. However, if that doesn't work for you, then you may need to adjust xorg.conf via editor (as root). Make sure you only alter display size for external monitor.

    kdesu kwrite /etc/X11/xorg.conf (KDE)

    gnomesu gedit /etc/X11/xorg.conf (Gnome)

    or via a terminal editor like pico (which you may need to install first)

    su (to become root)
    pico /etc/X11/xorg.conf

    DisplaySize 305 230
    These values are: horizontal size (mm) vertical size (mm). You should be able to get these values either by measuring directly or from spec sheet etc.

  5. #5
    Johan_Ekh NNTP User

    Default Re: Fonts too large on laptop

    I've changed the DisplaySize but it have no effect. However, if I
    put my laptop in the dock and boot it with the lid open, I get the correct behavior on both the laptop screen and the external screen, i.e. font size are of the same size on both screens, relative to the size of the screen itself.

    Thus, when the external screen is plugged in, the laptop screen behaves correctly but when the external screen is not connected the laptop screen makes the fonts larger.

    It is only the fonts in the applications not fonts renders by the browser or font in WindowMaker menus.

    Any ideas?

    Best regards
    Johan

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Fonts too large on laptop

    Are you using Gnome desktop by chance? The font sizes get adjusted based on the attached display(s) reported DPI values. Obviously the external monitor is determining the system value (when connected) in your case.

    With KDE4 (my desktop choice), you can force DPI with

    Control Centre > Appearance > Fonts

    Select 'Force Fonts DPI' (96 DPI or 120 DPI)

    Not sure what the Gnome equivalent is though. This thread suggests it might be

    System, Preferences, Appearance, Details, Resolution - top left

    (But I can't vouch for this).

    This thread may also be of interest to you. (Refer Display Size/DPI section.)

  7. #7
    Johan_Ekh NNTP User

    Default Re: Fonts too large on laptop

    Thank you! I'm a long time KDE user but I am gradually shifting to WindowMaker and/or XFCE due to their speed. However, the problem with the fonts that I have is the same on all three systems so it appears to be a more general setting. I took a quick look at the thread that you suggested and it seems to be right on the spot. I will check it more carefully and report back.

    Thanks for helping me!

    //Johan

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Fonts too large on laptop

    If memory serves, the system chooses the wrong DPI setting because the primary monitor is set to external, and it should be the laptop's. I'm not sure this applies to your problem, however.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •