Results 1 to 4 of 4

Thread: Firefox showing some images with weird colors

  1. #1

    Default Firefox showing some images with weird colors

    Hi everyone.
    I'm using a recent install (yesterday) of Opensuse 11.1 with everything updated, and the gnome 2.26 desktop.
    At some point of installing things which I really can't recall, Firefox started to show some images in strange "neon-like" colors, or sort of solarized, if you want.

    I have two examples here. This is how an image looks now:

    and this is how it should look:


    Interestingly, the correct image appears in a website with its own background (see the astronomy picture of the day), but when I click the image, the browser loads the image alone, and then the weird colors appear. Saving the image will show the correct colors in an image browser, and loading the file from disk again on firefox will show bad colors.
    More curiously, I can open the link to the "correct" miniature image and it shows fine on Firefox, but the full-sized image doesn't.
    Also, the colors of certain icons in the tabs and bookmarks of Firefox also have the same problem.
    For example, the icons in the add-ons window:


    Other web pages have the same problem even having their own backgrounds, although the code is what counts in that case.

    As another example, my gmail page shows some of the mail-marking stars in strong neon colors.
    The only application I've found with this problem is Firefox.
    I have used Opensuse 11.1 for several months in this computer before with the last unique install and I never had the same problem with it.
    I tried reinstalling firefox and uninstalling the opensuse branding for it, rebooting, but it's still the same.

    All this is in a Dell 1535 with an ATI Mobility Radeon HD 3400 card, using the ATI fglrx driver, kernel 2.6.27.29-0.1.1, x86_64.
    Firefox version is 3.5.3 with the default theme, and no color managing addons.

    Any ideas or similar experiences? Thanks.
    Last edited by radioboy; 21-Oct-2009 at 14:05. Reason: Added add-ons window screenshot

  2. #2

    Default Re: Firefox showing some images with weird colors

    Update: I installed a new theme for firefox and now the *new icons* of the addons window show ok, but the images in the browser and in the preview of the themes inside the addons window still have the weird look.
    Thanks.

  3. #3

    Default Re: Firefox showing some images with weird colors

    Solved!
    I've found the solution in another thread:

    Firefox 3.5.2 strangeness - Page 3 - openSUSE Forums

  4. #4
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Firefox showing some images with weird colors

    Quote Originally Posted by radioboy View Post
    Solved!
    I've found the solution in another thread:

    Firefox 3.5.2 strangeness - Page 3 - openSUSE Forums

    Great job
    Glad you solved it by being resourceful and searching the forums.
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •