Hi there,

I don't know if this problem has been introduced with one of the last upgrades, so maybe the "M8" is not accurate.

Using ifup with user control via cinternet/qinternet/kinternet has always been my main method for configuring any kind of network interfaces (although always playing around with NetworkManager or WICD for testing purposes).

Today I noticed that I am no longer able to configure ethernet interfaces (presumably this will also apply to wireless interfaces) on my openSUSE 11.2 installations (in fact I have two ATM, i586 and x86_64, although both running in VBox, so I cannot Test my Wireless PCIe with that).

- Yes, I am allowed to connect to smpppd

Code:
polkit-auth --explicit-detail 
org.opensuse.smpppd.connect
  Authorized:  Yes
  Scope:       Indefinitely
  Obtained:    Thu Sep  10 12:53:44 2009 by auth as root (uid 0)
- Yes, the interface eth0 is configured to allow non-root users to control it via smpppd and one of the frontends

Code:
 grep USERCONTROL /etc/sysconfig/network/ifcfg-eth0 
USERCONTROL='yes'
- Yes, smpppd is up and running

Code:
 /usr/sbin/rcsmpppd status
Checking for SMPPPD:                                                                         running
ps aux|grep smpppd|grep -v grep
root      8793  0.3  0.1   5216  1232 ?        Ss   17:36   0:04 smpppd
- No, there are no hints in the changelog except the one considering that PolicyKit is now used instead of group policies (dialout that was in older versions)

Code:
 rpm -q --changelog smpppd |head -n 25
* Do Aug 20 2009 aj(at)suse.de
- Use libiw-devel instead of wireless-tools in BuildRequires.

* Fr Nov 28 2008 lnussel(at)suse.de
- add support for netconfig to fix static configured DNS servers
  (bnc#449518)

* Fr Sep 19 2008 lnussel(at)suse.de
- also check explicit PolicyKit authorizations

* Di Sep 16 2008 lnussel(at)suse.de
- add support for IPv6

* Do Sep 11 2008 lnussel(at)suse.de
- use PolicyKit instead of dialout group to check access
- support plain chat instead of wvdial, making wvdial optional

* Fr Apr 25 2008 lnussel(at)suse.de
- use latest svn snapshot which includes all previous patches
- prevent endless autoreconnect (bnc#383744)
- support more connection states for wireless interfaces (bnc#383745)

* Mo Feb 04 2008 lnussel(at)suse.de
- let pppd decide which dummy IPs to use for DoD (bnc#345845)
Still, I don't get any output when searching for manageable interfaces with cinternet, with the --verbose switch I only get:

Code:
 cinternet -I --verbose
trying to connect local smpppd
Even as root there is no output, so missing permissions can be excluded.

Code:
 su - -c "cinternet -I --verbose"
Passwort: 
trying to connect local smpppd
The really odd thing, the moment I configure a "dialin"-connection (let's say DSL), the respective interface is shown.

Code:
 cinternet -I --verbose
trying to connect local smpppd
01 i dsl0
 su - -c "cinternet -I --verbose"
Passwort: 
trying to connect local smpppd
01 i dsl0
Can anybody try to reproduce this?

a) install smpppd

b) Switch to traditional method

c) configure your network interface ethX or wlanX with

Code:
[x] Enable Device Control for Non-root User Via KInternet
d) run the cinternet-command shown above

If this is a reproducible behavior (I can at least reproduce it on two installations) I will file a bug report.