Results 1 to 4 of 4

Thread: Avidemux Dependency Problem

  1. #1
    Join Date
    Oct 2008
    Location
    Brisbane
    Posts
    310

    Default Avidemux Dependency Problem

    I have been trying to install Avidemux on OS 11. I am having a dependency problem in that "nothing provides libx264.so.66 needed by avidemux-2.4.4-0.pm.1.i586" I tried to install libx264 through packman and managed to get libx264-57,-60,-65,-67,-72 and -75 + devel, but no -66. I have tried to find an rpm for 66 with no luck. Any ideas, tips, solutions?
    It is dangerous to be right when the government is wrong.

  2. #2

    Default Re: Avidemux Dependency Problem

    Try installing avidemux24 from packman and it should be ok

    Have A Great Day
    Windows will enslave
    Linux will set you free

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Avidemux Dependency Problem

    Quote Originally Posted by Dwarfer99 View Post
    I have been trying to install Avidemux on OS 11. I am having a dependency problem in that "nothing provides libx264.so.66 needed by avidemux-2.4.4-0.pm.1.i586" I tried to install libx264 through packman and managed to get libx264-57,-60,-65,-67,-72 and -75 + devel, but no -66. I have tried to find an rpm for 66 with no luck. Any ideas, tips, solutions?
    I think you will find libx264.so.66 has been removed from Packman, I noticed it recently as an orphaned package in my system. Hang on I'll check my log:

    I had this happen:

    2009-10-04 10:28:26|remove |libx264-66|0.0svn20090921-0.pm.1.1|i586|root@suse-kernelcruncher
    2009-10-04 10:28:27|remove |libx264-76|0.0svn20090923-0.pm.2.1|i586|root@suse-kernelcruncher


    Then:
    2009-10-04 10:29:22|install|libx264-67|0.0svn20090922-0.pm.1.1|i586|root@suse-kernelcruncher|packman_1|fc3c7222a2620f4e1a904b03472d045fde8481b5

    2009-10-04 10:29:24|install|libx264-72|0.0svn20090922-0.pm.1.1|i586|root@suse-kernelcruncher|packman_1|3ff51b45c1e70a0ef45adf9e400ae78efdfc30fc

    Try giving Packman a higher priority than all other repo's and do unconditional update in there.
    Look for orphaned packages too afterward. The will be Red and with no provider.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Avidemux Dependency Problem

    According to the packager at Packman the old version has been replaced by tne new version avidemux24 and the libx264.so.66 is obsolete. I installed the new version and it works perfectly.


    Have A Great Day
    Windows will enslave
    Linux will set you free

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •