Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Missing /usr/bin/fglrx-kernel-build.sh script

  1. #1

    Default Missing /usr/bin/fglrx-kernel-build.sh script

    Hi,

    I am trying to configure my ATI HD 4650 graphics card using the hard way for my opensuse 11.1, KDE4.3. Kernel - 2.6.31-44-pae . I have generated the rpm package successfully but when I go to run level 3 and try to install that rpm file it gives me error:

    Code:
    Preparing...                ##################################################
    fglrx_7_4_0_SUSE111         ##################################################
    
    *************************************************************
    Package "kernel-source" needs to be installed by YaST2 first!
    *************************************************************
    
    
    **************************************************************
    Building/installation of fglrx kernel module failed! Try again
    by calling "/usr/bin/fglrx-kernel-build.sh" manually.
    **************************************************************
    
    
    *************************************************************
    Please read "/usr/share/doc/packages/fglrx/README.SuSE" for
    configuration details when using SaX2.
    *************************************************************
    So tried executing the script "/usr/bin/fglrx-kernel-build.sh" but it is not on my system...
    Code:
    # ls -l /usr/bin/fglrx-kernel-build.sh
    ls: cannot access /usr/bin/fglrx-kernel-build.sh: No such file or directory
    I tried searching Yast and web to find from where I can get this script but could not..

    Can anyone please let me know from where I can get this script?
    Thanks in advance


    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  2. #2
    Join Date
    May 2009
    Location
    Nieuwegein, Netherlands
    Posts
    27

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    Hello,

    As you can see from the messages on your screen, you will have to install the package kernel-source first using yast! After you installed the source, installation of the fglrx driver should work. It needs the kernel-source to be able to compile the fglrx kernel-module during the installation.

    Good luck!

    Admoel

  3. #3

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    Quote Originally Posted by admoel View Post
    Hello,

    As you can see from the messages on your screen, you will have to install the package kernel-source first using yast! After you installed the source, installation of the fglrx driver should work. It needs the kernel-source to be able to compile the fglrx kernel-module during the installation.

    Good luck!

    Admoel
    oh I should I have mentioned that.. Kernel-source for 2.6.31 is already installed on my system
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  4. #4

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    IIRC no ati drivers support 2.6.31 ?? Even the 9.10 ?
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  5. #5

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    Quote Originally Posted by BenderBendingRodriguez View Post
    IIRC no ati drivers support 2.6.31 ?? Even the 9.10 ?
    WOW!!! So are there any plans to support kernel 2.6.31 and above anytime soon??

    Is there any place where I an get the exact status on this...

    In the meanwhile is there any workaround??
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  6. #6

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    Well from what i read from the release notes they just added support for openSUSE 11.1

    After 1 year being available

    And i thought nvidia drivers are bad

    Oh, by the way, the 9.10 Beta supports the 2.6.31 kernel.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  7. #7

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    BUT i couldn't find these drivers anywhere. I've read that they are in ubuntu's karmic repository.

    Try here:

    http://ftp.uni-kl.de/pub/linux/ubunt...lrx-installer/
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  8. #8

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    The proper version is the 660 ubuntu2

    Try that, you will ned xorg driver and fglrx installer and fglrx-kernel-source.

    Good luck!!

    P.S. Sorry i can't help you but i am using nVidia graphic card and have no experience when dealing with ati.

    P.S.2 Looks like that fglrx installer is not needed, i don't know play with those files .
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  9. #9

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    Quote Originally Posted by BenderBendingRodriguez View Post
    The proper version is the 660 ubuntu2

    Try that, you will ned xorg driver and fglrx installer and fglrx-kernel-source.

    Good luck!!

    P.S. Sorry i can't help you but i am using nVidia graphic card and have no experience when dealing with ati.

    P.S.2 Looks like that fglrx installer is not needed, i don't know play with those files .
    Thanks BenderBendingRodriguez for taking out time This is a lot of information and I will have to go through this on the weekend I think...

    Thanks again ....
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  10. #10

    Default Re: Missing /usr/bin/fglrx-kernel-build.sh script

    You're most welcome BUT to keep things simple i'd recommend using the 2.6.27 kernel and 9.9 ati drivers version since they support openSUSE 11.1 by now

    I guess openSUSE 11.2 will be supported in about a year
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •