Results 1 to 9 of 9

Thread: samba slow to connect when firewall enabled

  1. #1

    Question samba slow to connect when firewall enabled

    I have been racking my brain with this one for some time now. I have a samba share setup and when users using windows try and map a drive to it, it works but takes almost 2 min before it connects. If I disable the firewall it takes 4 sec to map the drive.

    I have ports 137, 138, 139 and 445 open for samba. Also these particular pcs use novell client, not sure if that has something to do with it??? The pcs are using the ipaddress and not the hostname to map.

    Anyone have any ideas?

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba slow to connect when firewall enabled

    Can you describe how you allowed the ports and whether you allowed TCP and/or UDP?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3

    Default Re: samba slow to connect when firewall enabled

    Sure. Here are the specific rules I have setup for just samba. Also I am using iptables as my firewall.

    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 137:139 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 445 -j ACCEPT

    -A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 137:139 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 445 -j ACCEPT

    It works and lets you in on these ports but way to slow.

    Also all the other ports I have open in the firewall work as well and there is no slowness. Samba is the only one giving me problems.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba slow to connect when firewall enabled

    Have you tried the SuSEfirewall2 options for Samba?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5

    Default Re: samba slow to connect when firewall enabled

    Yea same result. Is there any known issues when using novell client on windows based pcs and samba. Searched the internet and cant find anything but seems to only happen to the pcs using novell clients.

    Very odd....

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba slow to connect when firewall enabled

    Yes -- strange -- unfortunately I haven't encountered Novell Client. Have you tried the Novell forums?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7

    Default Re: samba slow to connect when firewall enabled

    Just tested a pc without the novell client and one with it. The one without the novell client was able to connect withing 4 sec and the one with the client took almost 2 min. So it is the novell client.

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba slow to connect when firewall enabled

    Novell forums then I think
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  9. #9

    Default Re: samba slow to connect when firewall enabled

    Thanks you guys! Went over to the novell forums and found out that port 524 needed to be open for the novell client.

    Slow mapping to samba share when novell client installed - NOVELL FORUMS

    Now its works just fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •