Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: Getting XRDP working?

  1. #31

    Question Re: Getting XRDP working?

    I have installed xrdp and dependencies (rdesktop, xorg-x11-server-dmx and xorg-x11-server-rdp) from Nomad repo in openSUSE 11.2(KDE)

    I am able to do connect to openSUSE from a remote Windows machine(mstsc) using a new session.

    I want to connect to an existing session on openSUSE from windows.

    For this i installed x11vnc.

    A post in ubuntu forum mentions of modifying startwm.sh.
    ( XRDP working with GNOME - howto (HACK) - Ubuntu Forums )

    Modified startwm.sh contains the following:

    #!/bin/bash
    x11vnc -display :0 -localhost &
    sleep 5
    vncviewer localhost:0 -fullscreen


    I am still not able to connect to an existing session.

    Anybody has got this working? Am i missing something?
    Thanks in advance.

    PS: My apologies if this post is redundant.

  2. #32

    Default Re: Getting XRDP working?

    Step 1:Install x11vnc
    in a terminal as root enter
    Code:
    zypper in x11vnc
    Step 2:Set the vnc password
    in a terminal enter
    Code:
    vncpasswd
    Step 3:Add a script to your kde autostart folder
    in a terminal enter
    Code:
    echo "#! /bin/sh" >~/.kde4/Autostart/x11vnc
    echo "x11vnc -rfbauth ~/.vnc/passwd -bg -rfbport 5900 -forever -noxdamage &" >>~/.kde4/Autostart/x11vnc
    chmod +x ~/.kde4/Autostart/x11vnc
    Note 1:Adjust path to match your KDE Autostart folder
    Note 2:-rfbport is used to set the TCP port x11vnc connects to your session through.
    Use any open port examples
    5900 default vnc port
    3389 RDP XRDP port
    5631 pcAnywhere port
    Just make sure the port is open and for outside connections if behind a router forwarded to the correct pc
    if you want on-screen notification and confirmation that someone has logged on to your KDE session, install "tk" - Graphical User Interface Toolkit for Tcl if it is not already installed
    as root enter in a terminal
    Code:
    zypper in tk
    then do the following instead of Step 3 above
    for a popup on the host computer to allow or disallow a connection and display a tray icon notification of a connection to the host
    in a terminal enter
    Code:
    echo "#! /bin/sh" >~/.kde4/Autostart/x11vnc
    echo "x11vnc -rfbauth ~/.vnc/passwd -bg -accept "popup" -gone "popup" -rfbport 5900 -gui tray=minimal,iconfont=14x17 -forever -noxdamage &" >>~/.kde4/Autostart/x11vnc
    chmod +x ~/.kde4/Autostart/x11vnc
    or
    for just a tray icon notification of a connection to the host
    in a terminal enter
    Code:
    echo "#! /bin/sh" >~/.kde4/Autostart/x11vnc
    echo "x11vnc -rfbauth ~/.vnc/passwd -bg -rfbport 5900 -gui tray=minimal,iconfont=14x17 -forever -noxdamage &" >>~/.kde4/Autostart/x11vnc
    chmod +x ~/.kde4/Autostart/x11vnc
    Tested with openSuse 11.0,11.1 using KDE 3.5,KDE 4.3

  3. #33

    Question Re: Getting XRDP working?

    @tom_enos

    Thank You so much for the quick response.

    The above solution helps me to login to a existing session from windows using vnc client.

    Suppose i access a locked machine remotely, this leaves the server machine unlocked. All the operations are visible on the server machine monitor.

    Is it possible to keep the server machine locked?

    Also, is it possible to make xrdp use x11vnc?

    The default startwm.sh in xdrp has the foll:

    Code:
    #!/bin/bash
    #
    # startwm.sh for SuSE Linux
    #
    
    . /etc/sysconfig/windowmanager
    
    test -z "$DEFAULT_WM" && DEFAULT_WM=twm
    WINDOWMANAGER="`type -p ${DEFAULT_WM##*/}`"
    unset DEFAULT_WM
    
    exec /etc/X11/xdm/Xsession $WINDOWMANAGER
    
    exit 1

  4. #34

    Default Re: Getting XRDP working?

    Quote Originally Posted by shri1234 View Post
    Also, is it possible to make xrdp use x11vnc?
    I have not tried so I do not know.

    Quote Originally Posted by shri1234 View Post
    Is it possible to keep the server machine locked?
    No, you have to unlock the session, but if the monitor supports DPMS you can keep it in or put it in that state when a client connects by adding these options to your x11vnc start up script

    Code:
    -forcedpms             If the system supports the DPMS (Display Power
                           Management Signaling) extension, then try to keep the
                           monitor in a powered off state.  This is to prevent
                           nosey people at the physical display from viewing what
                           is on the screen.  Be sure to lock the screen before
                           disconnecting.
    
                           This method is far from bullet proof, e.g. suppose
                           someone attaches a non-DPMS monitor, or loads the
                           machine so that there is a gap of time before x11vnc
                           restores the powered off state?  On many machines if
                           he floods it with keyboard and mouse input he can see
                           flashes of what is on the screen before the DPMS off
                           state is reestablished.  For this to work securely
                           there would need to be support in the X server to do
                           this exactly rather than approximately with DPMS.
    
    -clientdpms            As -forcedpms but only when VNC clients are connected.
    and also use these options to lock the host keyboard and mouse

    Code:
    -grabkbd               When VNC viewers are connected, attempt to the grab
                           the keyboard so a (non-malicious) user sitting at the
                           physical display is not able to enter keystrokes.
                           This method uses XGrabKeyboard(3X11) and so it is
                           not secure and does not rule out the person at the
                           physical display injecting keystrokes by flooding the
                           server with them, grabbing the keyboard himself, etc.
                           Some degree of cooperation from the person at the
                           display is assumed.  This is intended for remote
                           help-desk or educational usage modes.
    -grabptr               As -grabkbd, but for the mouse pointer using
                           XGrabPointer(3X11).  Unfortunately due to the way the X
                           server works, the mouse can still be moved around by the
                           user at the physical display, but he will not be able to
                           change window focus with it.  Also some window managers
                           that call XGrabServer(3X11) for resizes, etc, will
                           act on the local user's input.  Again, some degree of
                           cooperation from the person at the display is assumed.

  5. #35

    Default Re: Getting XRDP working?

    Thank You again

  6. #36
    Join Date
    Jul 2008
    Location
    Estonia
    Posts
    100

    Default Re: Getting XRDP working?

    I have xrdp running, but when I connect to it with krdc, I always get IceWM session. How do I change it?

    As thre's "DefaultWindowManager=startwm.sh" in sesman.ini, I set /etc/xrdp/startwm.sh to:
    Code:
    #!/bin/sh
    startxfce4
    exit 0
    But it does not change anything

    When looking at xrdp-sesman.log, I see there this line: "starting Xdmx session..." - do I need to change Xdmx configuration instead?

  7. #37
    Join Date
    Jul 2008
    Location
    Estonia
    Posts
    100

    Default Re: Getting XRDP working?

    Hmm, looks like ~/.xinitrc executes the desired Window Manager. But I'd like to not use xrdp's window manager as default. Any other way for setting window manager for xrdp?

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •