Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: Getting XRDP working?

  1. #11

    Default Re: Getting XRDP working?

    Quote Originally Posted by swerdna View Post
    here's a thought: I have on my install the file /etc/pam.d/xrdp-sesman.
    Thank you for the suggestion, swerdna.

    Yes, I do have this file and it is as you quoted.

    Oh dear . . .
    I guess, I'm going have to stick with Windows 2003 for a while longer?
    I'll try again in a year or so, and see what I find then?

    Regards, Martin

  2. #12
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,729
    Blog Entries
    2

    Default Re: Getting XRDP working?

    Quote Originally Posted by martinprowe View Post
    Thank you for the suggestion, swerdna.

    Yes, I do have this file and it is as you quoted.

    Oh dear . . .
    I guess, I'm going have to stick with Windows 2003 for a while longer?
    I'll try again in a year or so, and see what I find then?

    Regards, Martin
    Can you run this command and post back here the results:
    Code:
    rpm -qa | egrep "xrdp|rdesktop|xorg-x11-server"
    And which desktops are installed in your installation (Gnome? KDE? Both? some others?)
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #13

    Default Re: Getting XRDP working?

    Quote Originally Posted by swerdna View Post
    Can you run this command and post back here the results:
    Code:
    rpm -qa | egrep "xrdp|rdesktop|xorg-x11-server"
    And which desktops are installed in your installation (Gnome? KDE? Both? some others?)
    Hi swerdna,
    Yes, Of course. Glad to be doing anything that may resolve this...

    Code:
    supermicro:/home/mprowe # rpm -qa | egrep "xrdp|rdesktop|xorg-x11-server"
    rdesktop-1.6.0-46.1
    xorg-x11-server-7.4-17.6.1
    xorg-x11-server-extra-7.4-17.6.1
    xorg-x11-server-rdp-7.3.99-9.1
    xorg-x11-server-dmx-7.3.99-42.1
    xrdp-0.4.1-16.7.1
    supermicro:/home/mprowe #
    
    I hope this provides some clues? Opps... As far as I know, only the KDE desktop is installed.

    Best regards, Martin

  4. #14
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,729
    Blog Entries
    2

    Default Re: Getting XRDP working?

    These of yours are advanced versions:
    xorg-x11-server-rdp-7.3.99-9.1
    xorg-x11-server-dmx-7.3.99-42.1

    I have these versions:
    xorg-x11-server-rdp-7.3.99-7.1
    xorg-x11-server-dmx-7.3.99-24.1

    Where did you get yours? And which version of openSUSE are you running, 11.1?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #15

    Default Re: Getting XRDP working?

    Quote Originally Posted by swerdna View Post
    These of yours are advanced versions:
    xorg-x11-server-rdp-7.3.99-9.1
    xorg-x11-server-dmx-7.3.99-42.1

    I have these versions:
    xorg-x11-server-rdp-7.3.99-7.1
    xorg-x11-server-dmx-7.3.99-24.1

    Where did you get yours? And which version of openSUSE are you running, 11.1?
    From the link half-way down the Nomad page:
    Index of /repositories/home:/dreveman:/nomad/openSUSE_11.1 - I think!!

    I only have a telnet connection to the delinquent box for the next 8 hours. If it is important that I confirm the source, is there a cmd line that will give me that info?

    I am running 11.1.

    Lastly (in this over) is the difference between the two sets of numbers (7.3.99-9.1 & 7.3.99-7.1) that significant?
    In a long struggle getting hostapd (wireless access point) working, I though I was told by Akoellh that the digits to the left of the "-" is the code version and that to the right is the package version. Please correct me if I've got it all mixed up.

    Regards, Martin

  6. #16
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,729
    Blog Entries
    2

    Default Re: Getting XRDP working?

    Quote Originally Posted by martinprowe View Post
    From the link half-way down the Nomad page:
    Index of /repositories/home:/dreveman:/nomad/openSUSE_11.1 - I think!!

    I only have a telnet connection to the delinquent box for the next 8 hours. If it is important that I confirm the source, is there a cmd line that will give me that info?

    I am running 11.1.

    Lastly (in this over) is the difference between the two sets of numbers (7.3.99-9.1 & 7.3.99-7.1) that significant?
    In a long struggle getting hostapd (wireless access point) working, I though I was told by Akoellh that the digits to the left of the "-" is the code version and that to the right is the package version. Please correct me if I've got it all mixed up.

    Regards, Martin
    Your RPMs are not in that Repository but mine are -- I just did a thorough search of it. You've got the wrong RPMs. The difference between the 9.1 and 7.1 might be significant -- you'll only know by trying it again with the RPMs that are known to work. You should attach the dreveman repo in Yast --> Software --> Software Repositories. Then uninstall the RPMs that you have previously installed and reinstall them according to the split up I laid out in my tutorial. I tested that list to-day and it is still current.

    Whether that will solve your problem or not -- I can't say. But it's quite suspicious that you are using newer RPMs than the RPMs in the dreveman repo for openSUSE 11.1. Maybe they came from the milestone 11.2 repo (to be so new)? But hey, try it and see -- they work for me.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #17
    Christian Riechers NNTP User

    Default Re: Getting XRDP working?

    On 10/05/2009 09:56 AM, martinprowe wrote:
    >
    > Christian Riechers;2047045 Wrote:
    >> On 10/03/2009 08:56 PM,
    >>
    >> Remote root login is disabled per default in SuSE. Try with a different
    >> user than root first.

    >
    > Hi Christian,
    > Hmmmm... I don't think that that is always the case? I have used xrdp
    > as root in the past.
    > But anyway, yes I have tried other users (both local and LDAP) which is
    > why I was sticking to root to avoid any permissions problems.


    You're correct, RDP allows root login by default. I was referring to
    telnet, which is usually not allowed for root.

    >
    > I have also tried to understand which groups do and do not have xrdp
    > (remote) access. So far without success. What is the consequence of the
    > two entries
    >
    > Code:
    > --------------------
    > TerminalServerUsers=tsusers
    > TerminalServerAdmins=tsadminin
    > --------------------
    >
    > in sesman.ini?
    >


    There's a manpage for sesman.ini. Have a look there. This is just taken
    from the man page:

    TerminalServerUsers=tsusers
    Only the users belonging to the group tsusers are allowed
    to login on terminal server.
    If unset or set to an invalid or non-existent group,
    login for all users is enabled.

    On my system the group tsusers doesn't exist, so anyone with a valid
    local account can login via RDP.

    I can't suggest much more than what swerdna did earlier, i.e.
    re-installing the RPM's. Also make sure to remove or rename any
    customized config files before installing the RPM's again. Then follow
    the steps from the tutorial. It worked for me too, without the need for
    any more configuration tweaks.
    I can post my config files, if you think this is useful.

    --
    Christian

  8. #18

    Default Re: Getting XRDP working?

    Hi Christian and swerdna,

    Often "no news is good news". Not in this case.
    As suggested, I have tried uninstall/reinstalls - with no luck. I then tried complete rebuilds on several hardware platforms. Also to no avail!
    What is worse, is that there does not seem to be any repeatability in any of the failure patterns!!

    So, after several months work, I'm giving up. It is just toooo difficult for me to make any progress. I'll leave this field to you experts.

    Thanks for all your help. Maybe, I'll see you on the other side of 11.2?

    Regards,
    Martin

  9. #19

    Default Re: Getting XRDP working?

    Just a very quick last question (if you are still monitoring this): can you confirm that you opened the firewall for xrdp or that you have the network connection on the internal zone? I only ask since I had no trouble with xrdp apart from trying to establish a Failsafe Terminal connection from the session type list. However KDE4 sessions worked fine.

  10. #20
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,729
    Blog Entries
    2

    Default Re: Getting XRDP working?

    Quote Originally Posted by martinprowe View Post
    Hi Christian and swerdna,

    Often "no news is good news". Not in this case.
    As suggested, I have tried uninstall/reinstalls - with no luck. I then tried complete rebuilds on several hardware platforms. Also to no avail!
    What is worse, is that there does not seem to be any repeatability in any of the failure patterns!!

    So, after several months work, I'm giving up. It is just toooo difficult for me to make any progress. I'll leave this field to you experts.

    Thanks for all your help. Maybe, I'll see you on the other side of 11.2?

    Regards,
    Martin
    It's a pity that it won't work for you. Since you started this thread I've rechecked twice to see if the method still works, with fresh installs of KDE and Gnome on a spare partition. Worked both times for me.

    But it does stop working if I add both Desktop Environments (KDE and Gnome) concurrently and try to switch from one to the other.

    Xrdp in openSUSE as crafted for the "Nomad" project has some wrinkles to be got out yet, so maybe versions 11.2 or 11.3 will see it performing properly.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •