Results 1 to 3 of 3

Thread: Testing Mono

  1. #1

    Default Testing Mono

    I need some apps to be cross-platform, so I thought I'd take a look at mono. Using VS2008, I built a basic CLR/C++ app. One window with a label, a text field, and a button. Compiled and ran fine on Win. When I try to run it on SUSE, I get the following error:
    System.DllNotFoundException: msvcm90d.dll

    According to the mono website, C++ WinForms apps should run fine under mono. What am I doing wrong?

    jcf

  2. #2

    Default Re: Testing Mono

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Did you look for the DLL mentioned? My system does not have that present
    per a query of all my RPM-installed files.

    Good luck.




    jfrickson wrote:
    > I need some apps to be cross-platform, so I thought I'd take a look at
    > mono. Using VS2008, I built a basic CLR/C++ app. One window with a
    > label, a text field, and a button. Compiled and ran fine on Win. When I
    > try to run it on SUSE, I get the following error:
    > System.DllNotFoundException: msvcm90d.dll
    >
    > According to the mono website, C++ WinForms apps should run fine under
    > mono. What am I doing wrong?
    >
    > jcf
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKw2cPAAoJEF+XTK08PnB59mAQALZYbSDbde7asthMJpHKvB0V
    +7zY2WY6xRC532QkVqFbDmimelVRozXvzSiFhTo7oGHUTmT4ccqA50BxUEJVOrW5
    R0lzfgoZiZ4eyONpLStqvpOXKD4510u+OLfPcRW1RKcA0ujoQvBQybnkZiLWLnDI
    QAuaiD4jYAx+E3u3upgweB1tbnhqKniYkKrjmP6TjMZL3FxEWjNDpNqMVImBZ7o1
    9/d/O3JPBqSaSv+OYrBb76xusy299qoYx1Rj6hc2Cqhba4GyvwjFHY4eqdFB0Mco
    dyO2vOxdIiUBhZldPGeUKqy6VkkulauCrWb5PP/huZw5sQxfKkXPTDv+U3jnn5yk
    PkQdMdd9MSbjijgvHtAmUz6vF9wbYyCzxtb50zkLy3MG0JXxOqK7hLFP1GQKKmXP
    MaIM0SwGDOxJdxkcL5g0f/oOGzVG8ZMIcAfKi6tOZTrvoSvpuBhQixzQhrU0vxdn
    UwT1Rkd3Djw/CPPEE25Kbsdj/EaFw9jkBufJ/pYfn0o665nkA1ZcuVTAhMIW2mNs
    ffqqlSXH5ioTefIRWSPaNj6N3s5/jTJeBKzTTtaRgdU5ajggukKGmMlZrGfCSH0C
    VB6223kBzVtBFgIVlyaRIE7Mb3Y+AsdsoY534wVpw0XktNAVx2qpbRSxpYb4g/A7
    d5Q5enWuVZ9QMQzaBI59
    =rS8A
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: Testing Mono

    Yes, ran 'locate -i msvcm90d' and found nothing.

    Quote Originally Posted by ab@novell.com View Post
    Did you look for the DLL mentioned? My system does not have that present
    per a query of all my RPM-installed files.

    Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •