Results 1 to 7 of 7

Thread: Is the mail sleeping at 3:00 AM?

  1. #1
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Question Is the mail sleeping at 3:00 AM?

    Hello all!

    I've made some backup scripts and configured cron to run them at 3:00.

    Those scripts produce some output which is meant to be sent by mail indicating whether the scripts ran normally or with errors.

    I've tested it on the afternoon (set cron to run them at 16:00 and received the correspondent mails).

    Then I've set cron to run them at 03:00 (AM), logged off from KDE and went home! Today, when I checked my mailbox I had no mail from cron, but checking the logs I can see that the scripts did run!

    Any idea?

    Best regards,
    Jorge

  2. #2
    Camalen NNTP User

    Default Re: Is the mail sleeping at 3:00 AM?

    jorgeraimundo wrote:

    > Then I've set cron to run them at 03:00 (AM), logged off from KDE and
    > went home! Today, when I checked my mailbox I had no mail from cron, but
    > checking the logs I can see that the scripts did run!
    >
    > Any idea?


    Check the Postfix log (/var/log/mail) to see if the message was sent but not
    delivered (for any unforeseen reason).

    Greetings,

    --
    Camalen

  3. #3
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: Is the mail sleeping at 3:00 AM?

    Hi Camalen!

    Thanks for your reply.

    I have the following on the log:
    Code:
    Sep 30 03:00:04 linux-foxg postfix/smtp[14944]: 13B52334E21C: to=<my_mail@my_domain.pt>, orig_to=<root>, relay=mail.mydomain.pt[MY.IP.ADD.RES]:25, delay=2.7, delays=0.01/0/2.3/0.41, dsn=5.0.0, status=bounced (host mail.my_domain.pt[MY.IP.ADD.RES] said: 550-"JunkMail rejected - (SERVER01.lan) [LO.CAL.IP.ADD] is in an RBL, see 550 http://www.spamhaus.org/query/bl?ip=LO.CAL.IP.ADD" (in reply to RCPT TO command))
    Sep 30 03:00:04 linux-foxg postfix/cleanup[15020]: C1682334E26C: message-id=<20090930020004.C1682334E26C@MV-SERVER01.lan>
    Sep 30 03:00:04 linux-foxg postfix/bounce[15047]: 13B52334E21C: sender non-delivery notification: C1682334E26C
    And alter:
    Code:
    Sep 30 03:00:06 linux-foxg postfix/smtp[14944]: C35FF334E21C: to=<my_mail@my_domain.pt>, orig_to=<root@SERVER01.lan>, relay=mail.my_domain.pt[MY.IP.ADD.RES]:25, delay=2, delays=0/0/2/0, dsn=4.0.0, status=deferred (host mail.my_domain.pt[MY.IP.ADD.RES] refused to talk to me: 451-The server has reached its limit for processing requests from your host.  451 Please try again later.)
    Seems like the mail server doesn't like my local server IP address...

    But the funny thing is that I changed cron to run the same thing this morning for testing purposes and it worked!!!

    P.S.: I've changed on YAST the System -> /etc/sysconfig Editor -> System -> Cron -> SEND_MAIL_ON_NO_ERROR to "yes" and I'm receiving mails every hour from the hourly tasks. Let's see how it behaves this night...

  4. #4
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: Is the mail sleeping at 3:00 AM?

    Ok.

    Seems like I found something.

    Following the mail server response I went to http://www.spamhaus.org/query/bl?ip=LO.CAL.IP.ADD and found that the address wan in PBL (Policy Block List). Than I found this saying:
    PBL listings do not prevent you sending email unless your email program is not authenticating properly when it connects to your ISP or company's mail server. This can happen if you have forgotten to turn on 'Authentication' or if you have switched 'Authentication' off by mistake.

    If you are using a normal email program such as Outlook, Entourage, Thunderbird or Apple Mail and you are being blocked by a Spamhaus PBL listing when you try to send email, the reason is simply that YOU NEED TO TURN ON 'SMTP AUTHENTICATION' in your email program's account settings. That will solve the problem for you.
    In deed I didn't fill the authentication information on Yast's MTA (Mail Transfer Agent). Do you think that'll do the trick?

    Best regards,
    Jorge

  5. #5
    Camalen NNTP User

    Default Re: Is the mail sleeping at 3:00 AM?

    jorgeraimundo wrote:

    > I have the following on the log:
    >
    > Code:
    > --------------------
    >
    > Sep 30 03:00:04 linux-foxg postfix/smtp[14944]: 13B52334E21C:
    > to=<my_mail@my_domain.pt>, orig_to=<root>,
    > relay=mail.mydomain.pt[MY.IP.ADD.RES]:25, delay=2.7,
    > delays=0.01/0/2.3/0.41, dsn=5.0.0, status=bounced (host
    > mail.my_domain.pt[MY.IP.ADD.RES] said: 550-"JunkMail rejected -
    > (SERVER01.lan) [LO.CAL.IP.ADD] is in an RBL, see 550
    > http://www.spamhaus.org/query/bl?ip=LO.CAL.IP.ADD" (in reply to RCPT TO
    > command)) Sep 30 03:00:04 linux-foxg postfix/cleanup[15020]:
    > C1682334E26C: message-id=<20090930020004.C1682334E26C@MV-SERVER01.lan>
    > Sep 30 03:00:04 linux-foxg postfix/bounce[15047]: 13B52334E21C: sender
    > non-delivery notification: C1682334E26C
    > --------------------
    >
    >
    > And alter:
    >
    > Code:
    > --------------------
    > Sep 30 03:00:06 linux-foxg postfix/smtp[14944]: C35FF334E21C:
    > to=<my_mail@my_domain.pt>, orig_to=<root@SERVER01.lan>,
    > relay=mail.my_domain.pt[MY.IP.ADD.RES]:25, delay=2, delays=0/0/2/0,
    > dsn=4.0.0, status=deferred (host mail.my_domain.pt[MY.IP.ADD.RES]
    > refused to talk to me: 451-The server has reached its limit for
    > processing requests from your host. 451 Please try again later.)
    > --------------------
    >
    >
    > Seems like the mail server doesn't like my local server IP address...


    Yes.

    Sadly, it is a very common policy for big ISP/hosting providers to reject
    e-mails directly using rbls :-(

    > But the funny thing is that I changed cron to run the same thing this
    > morning for testing purposes and it worked!!!


    Could be possible. If you are on DSL and running a dynamic IP, your IP was
    changed and the new one was not in any RBL.

    > P.S.: I've changed on YAST the System -> /etc/sysconfig Editor ->
    > System -> Cron -> SEND_MAIL_ON_NO_ERROR to "yes" and I'm receiving mails
    > every hour from the hourly tasks. Let's see how it behaves this night...


    You'll have to find a way to prevent your remote mail server rejects your
    mails :-/

    Greetings,

    --
    Camalen

  6. #6
    Camalen NNTP User

    Default Re: Is the mail sleeping at 3:00 AM?

    jorgeraimundo wrote:

    > Seems like I found something.
    >
    > Following the mail server response I went to
    > http://www.spamhaus.org/query/bl?ip=LO.CAL.IP.ADD and found that the
    > address wan in PBL (Policy Block List). Than I found 'this'
    > (http://www.spamhaus.org/faq/answers....haus%20PBL#183)
    > saying:
    >> PBL listings do not prevent you sending email unless your email program
    >> is not authenticating properly when it connects to your ISP or company's
    >> mail server. This can happen if you have forgotten to turn on
    >> 'Authentication' or if you have switched 'Authentication' off by
    >> mistake.
    >>
    >> If you are using a normal email program such as Outlook, Entourage,
    >> Thunderbird or Apple Mail and you are being blocked by a Spamhaus PBL
    >> listing when you try to send email, the reason is simply that YOU NEED
    >> TO TURN ON 'SMTP AUTHENTICATION' in your email program's account
    >> settings. That will solve the problem for you.

    >
    > In deed I didn't fill the authentication information on Yast's MTA
    > (Mail Transfer Agent). Do you think that'll do the trick?


    Testing may not hurt, but I think it will not work as it was rejecting you
    by your IP and not because of an authenticating issue... but, who knows?
    Just give it a try :-)

    Greetings,

    --
    Camalen

  7. #7
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: Is the mail sleeping at 3:00 AM?

    Ok! Finally it's working!

    It seems the problem was the authentication in deed!

    In Yast's MTA module I filled the "Outgoing mail server" and correspondent authentication and it worked...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •