Results 1 to 3 of 3

Thread: Creative Sound Blaster configuration problems

  1. #1
    Join Date
    Aug 2008
    Location
    East England
    Posts
    50

    Default Creative Sound Blaster configuration problems

    Hi

    I've recently slotted in an old sound card, a Creative Sound Blaster Live! SB0060 PCI card. I'm trying, somewhat desperately to install this (especially as I'll probably be without internet for a week!) and having no luck.

    Main problem is that, no matter what name I try to configure (through YaST) I get an error message saying that it failed.

    An error occurred during the installation of

    (Whichever name I try it under)

    The kernel module snd-emu10k1 for sound support
    could not be loaded. This can be caused by incorrect
    module parameters, including invalid IO or IRQ parameters.
    Apart from that, none of the listed cards are actually this one, although from what I've found online this seems to be the needed module.

    I wonder if moving the card to another bus could help? Seems unlikely really.

    Thoughts?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,136
    Blog Entries
    40

    Default Re: Creative Sound Blaster configuration problems

    Ensure you have the package alsa-firmware installed, and then test. Also note the guidance reference the mixer in case it is applicable: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums

    If no success there, then I recommend before you start deep into troubleshooting you read our "stickie" : NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums

    and also brush up on openSUSE concepts: Concepts - openSUSE ... the concepts are important. ... without a rough understanding of that, the reason why you are asked to do things will often be totally lost on you.

    Now the general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

    Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a detailed recommendation. (but try the alsa-firmware installation/reboot first)

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

  3. #3
    Join Date
    Aug 2008
    Location
    East England
    Posts
    50

    Default Re: Creative Sound Blaster configuration problems

    Thank you, oldcpu, your advice was as comprehensive and clear as always.

    However, having come part way through it I decided to open up the machine again and swap the sound card with the other PCI card, because it simply wasn't being found. Well, now it works! Both cards do, so it wasn't the bus but the position. I think I shall look again through the concepts page and see if there's a decent reason for that.

    Again, thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •