I keep having problems with mono-zeroconf when updating via zypper:

Code:
Problem: mono-zeroconf-provider-avahi-0.8.0-3.1.noarch requires mono(Mono.Zeroconf) = 3.0.0.80, but this requirement cannot be provided
  deleted providers: mono-zeroconf-0.8.0-3.1.noarch[@System]
 Solution 1: do not keep mono-zeroconf-provider-avahi-0.8.0-3.1.noarch installed
 Solution 2: do not install mono-zeroconf-0.9.0-2.1.noarch
 Solution 3: Ignore some dependencies of mono-zeroconf-provider-avahi
Here are the repositories I use:

Code:
andri@virgil:~$ zypper lr
#  | Alias                                                                     | Name                                    | Enabled | Refresh
---+---------------------------------------------------------------------------+-----------------------------------------+---------+--------
1  | Education                                                                 | Education                               | Yes     | Yes    
2  | http://download.opensuse.org/repositories/GNOME:/Community/openSUSE_11.0/ | openSUSE BuildService - GNOME:Community | Yes     | Yes    
3  | http://download.nvidia.com/opensuse/11.0                                  | NVIDIA Repository                       | Yes     | Yes    
4  | openSUSE:11.0:NonFree                                                     | openSUSE:11.0:NonFree                   | Yes     | Yes    
5  | openSUSE-11.0-Updates                                                     | openSUSE-11.0-Updates                   | Yes     | Yes    
6  | standard                                                                  | standard                                | Yes     | Yes    
7  | Perl                                                                      | Perl                                    | Yes     | Yes    
8  | Packman Repository                                                        | Packman Repository                      | Yes     | Yes    
9  | http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_11.0/    | openSUSE BuildService - GNOME:STABLE    | Yes     | Yes    
10 | http://download.opensuse.org/distribution/11.0/repo/oss/                  | Main Repository (OSS)                   | Yes     | Yes    
11 | http://download.opensuse.org/distribution/11.0/repo/non-oss/              | Main Repository (NON-OSS)               | Yes     | Yes    
12 | Science                                                                   | Science                                 | Yes     | Yes    
13 | Banshee                                                                   | Banshee                                 | Yes     | Yes    
14 | Application:Geo                                                           | Application:Geo                         | Yes     | Yes    
15 | OpenOffice                                                                | OpenOffice                              | Yes     | Yes    
16 | Mozilla                                                                   | Mozilla                                 | No      | No     
17 | devel                                                                     | devel                                   | No      | No
The problem it seems to propose involves a drastic downgrade of banshee (v. 1.4.3-3.1). Does anyone have any better ideas?

I'm running 32-bit openSuse 11.0 with Gnome 2.22.1 on a Dell Latitude D830.

Thanks!
- Andri