Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: sk1 not working??

  1. #1

    Unhappy sk1 not working??

    i am a noob on open suse,im running open suse 11.1.
    i recently installed sk1,the dependancies were installed,i think
    but it still doesnt work?how can i get this program to work?
    are there missing dependancies?any help would be appreciated!!

    Rick

  2. #2

    Default Re: sk1 not working??

    nobody answer this problem and I have the same problem with Opensuse 13.2

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: sk1 not working??

    So where did you install from??

    sk1 is a python program so is the python up to date Got all the needed libs?

    start it from a command line what errors do you get.

    Need lots more info say its broke is not enough

  4. #4

    Default Re: sk1 not working??

    I uninstalled and installed again still not working. I don't have any idea about what I have to do.

  5. #5

    Default Re: sk1 not working??

    Code:
    lindx:~ # sk1
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/usr/lib64/python2.7/site-packages/sk1/__init__.py", line 21, in <module>
        app.main.main()
      File "/usr/lib64/python2.7/site-packages/sk1/app/main.py", line 146, in main
        app.init_ui()
      File "/usr/lib64/python2.7/site-packages/sk1/app/__init__.py", line 205, in init_ui
        __import__(name)
      File "/usr/lib64/python2.7/site-packages/sk1/app/scripts/export_raster.py", line 46, in <module>
        from app.UI.sketchdlg import SKModal
      File "/usr/lib64/python2.7/site-packages/sk1/app/UI/sketchdlg.py", line 58, in <module>
        from Tkinter import Toplevel, IntVar, Frame, Checkbutton, Label
    ImportError: No module named Tkinter

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: sk1 not working??

    You still did not say where you installed it from. Tested here no problem from the repo but I'm still on 13.1 So I suspect a miss match of the python versions or required packages or you are installing from someplace other then the normal repos.

  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: sk1 not working??

    On Wed, 04 Feb 2015 04:36:01 +0000, Dexter22 wrote:

    > nobody answer this problem and I have the same problem with Opensuse
    > 13.2


    It seems you have a lot of these kinds of problems, probably resulting
    from the long list of repos you have. I would start by cleaning up the
    repo list and get stuff back to the standard 4 - OSS, non-oss, update,
    packman.

    Until you get that straightened out, I expect you'll continue to have
    these kinds of problems.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8

    Default Re: sk1 not working??

    I have this info from my PC, I was deleting some repos

    Code:
    lindx:~ # rpm -qi sk1
    Name        : sk1
    Version     : 0.9.1pre_rev730
    Release     : 27.1.8
    Architecture: x86_64
    Install Date: Wed Feb  4 10:47:27 2015
    Group       : Productivity/Graphics/Vector Editors
    Size        : 6499092
    License     : GPL-2.0 and LGPL-2.0+
    Signature   : RSA/SHA256, Fri Oct 10 07:53:49 2014, Key ID b88b2fd43dbdc284
    Source RPM  : sk1-0.9.1pre_rev730-27.1.8.src.rpm
    Build Date  : Fri Oct 10 07:53:23 2014
    Build Host  : build16
    Relocations : (not relocatable)
    Packager    : http://bugs.opensuse.org
    Vendor      : openSUSE
    URL         : http://www.sk1project.org/
    Summary     : Python-Based Vector Drawing Program
    Description :
    The program sK1 is an open source vector graphics editor similar to
    CorelDRAW, Adobe Illustrator, or Freehand. First of all sK1 is oriented
    for PostScript processing. It features CMYK colorspace support, CMYK
    support in Postscript, a Cairo-based engine, color managment, universal
    CDR importer (7-X3 versions), and a modern Ttk based (former Tile
    widgets) user interface.
    Distribution: openSUSE 13.2

  9. #9

    Default Re: sk1 not working??

    Quote Originally Posted by Dexter22 View Post
    Code:
    ImportError: No module named Tkinter
    Check that the package "python-tk" is installed and that it matches your python version:
    Code:
    rpm -qi python python-tk

  10. #10

    Default Re: sk1 not working??

    Code:
    lindx:~ # rpm -qi python python-tk
    Name        : python
    Version     : 2.7.8
    Release     : 1.1
    Architecture: x86_64
    Install Date: Sat Nov  1 19:53:58 2014
    Group       : Development/Languages/Python
    Size        : 1382206
    License     : Python-2.0
    Signature   : RSA/SHA256, Wed Oct  8 12:01:15 2014, Key ID b88b2fd43dbdc284
    Source RPM  : python-2.7.8-1.1.src.rpm
    Build Date  : Wed Oct  8 12:00:54 2014
    Build Host  : cloud126
    Relocations : (not relocatable)
    Packager    : http://bugs.opensuse.org
    Vendor      : openSUSE
    URL         : http://www.python.org/
    Summary     : Python Interpreter
    Description :
    Python is an interpreted, object-oriented programming language, and is
    often compared to Tcl, Perl, Scheme, or Java.  You can find an overview
    of Python in the documentation and tutorials included in the python-doc
    (HTML) or python-doc-pdf (PDF) packages.
    
    
    If you want to install third party modules using distutils, you need to
    install python-devel package.
    Distribution: openSUSE 13.2
    package python-tk is not installed

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •