Results 1 to 2 of 2

Thread: Unable to bind apache2 to port 80

  1. #1
    IT-M0nk3y NNTP User

    Default Unable to bind apache2 to port 80

    Hi all, I'm getting some problems with apache2, when I tried to edit the config in Yast2 I got an error telling me that it "cannot adjust 'apache2' service."

    Having tried to start apache from XTerm I got this error:

    /etc/init.d/apache2 start
    Starting httpd2 (prefork) (98)Address already in use: make_sock: could not bind to address
    no listening sockets available, shutting down
    Unable to open logs
    startproc: exit status of parent of /usr/sbin/httpd2-prefork: 1 failed

    So, I tried the obvious, I looked for something else running on port 80

    I did a netstat and nothing was listening on port 80

    I ran lsof -i | grep :http and got no results

    I tried ps ax | grep httpd and got pts/1 S+ 0:00 grep httpd

    So my question is, how else can I find out what is stopping apache from running?


  2. #2
    Join Date
    Aug 2008
    Temporarily, planet Earth

    Default Re: Unable to bind apache2 to port 80

    As root, use the command
    fuser 80/tcp
    to find the PID of the process with the open port. If this produces no output, the command
    netstat -ant | grep :80
    will show more information about the socket.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts