Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Bootup graphics problem

  1. #1

    Default Bootup graphics problem

    Hello

    I have configured my VIA C3 system to bootup SUSE Linux 11.1 at runlevel 3 - text only mode. After installation, when I restart I see a graphics failed note on screen. I see text on screen at startup and everything looks fine. but eventually screen becomes garbled.

    Could it be that the os is attempting to go into graphic/gui mode? How can I start to troubleshoot this issue?

    I have successfully installed SUSE 9.3 on this system (in text mode) and did not experience this problem.

    I am setting up a software based telephone system (Asterisk) so don't need a GUI.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Bootup graphics problem

    Try booting with "splash=verbose". This disables the graphics during bootsplash.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    platinum NNTP User

    Default Re: Bootup graphics problem

    during boot up at the first screen (probably green) press the down
    arrow and type 3 then press enter

    in a bit it will offer you a log in prompt....log in as the user you
    set up..

    does "eventually screen becomes garbled" still occur?

    if so, i guess you probably installed both X and some desktop which
    you really didn't need..

    when you installed, at this point in the install process:

    http://en.opensuse.org/INSTALL_Local...ktop_selection

    which did you choose?

    --
    platinum

  4. #4

    Default Re: Bootup graphics problem

    I thought I chose Other - Minimal Server Selection (text mode)

    But I did go into detailed selection and maybe I selected some graphical componet. I will restart setup and re-check.

  5. #5

    Default Re: Bootup graphics problem

    Quote Originally Posted by Knurpht View Post
    Try booting with "splash=verbose". This disables the graphics during bootsplash.
    Hello

    Thanks for the suggestion. I am a bit of a linux beginner - how do I set the splash=verbose option?

  6. #6

    Default Re: Bootup graphics problem

    You have two options. The temporary way is, at the boot menu, hit escape to drop to text mode. Move the 'cursor' over the option for the normal opensuse boot, then press 'e' for edit. There will be a kernel line. Find that line, and press 'e' again. It will look something like this;

    Code:
    kernel /boot/vmlinuz-2.6.31-8-desktop root=/dev/sdc2 resume=/dev/disk/by-id/usb-Hitachi_HTS543232L9A300_081031FB0443-0:0-part7 splash=silent quiet showopts
    Change splash=silent to splash=verbose. Hit return, then press 'b' to boot.

    Alternatively, you can make the same change permanently, from a root terminal, to your /boot/grub/menu.lst file. Being aware that you very much should have a backup of said file lying around, because if you break it, your system may become unbootable - albeit normally quite easily fixed too.

  7. #7

    Default Re: Bootup graphics problem

    I wotked out that it was not a problem with linux going into graphic mode. The bootup was totally in text mode. But it does get to a point where the screen just becomes garbeld. I guess it is crashing? I wonder if I should report as a bug?

    If I use my old SUSE 9.3 DVD it installs without problem.

    Hardware is an EPIA VIA C3 based system. Maybe there are issues with support for VIA. Or some specific startup config is required?

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Bootup graphics problem

    Ignore the refs to Mint

    Boot your cd and you arrive here:
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    Pause the timer by moving your cursor down and type as shown here (the 0 is a zero)
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    You should see scrolling text like this
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    Then a login like this:
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    Login is: root
    hit enter a couple of times
    Now type: sax2 -r -m 0=vesa

    Now type: startx
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Bootup graphics problem

    I think you may have misread the thread caf; he's trying to set up a GUIless server.

    [Unless you're just trying to see how it gets along with a liveCD, which might well make sense... Nevermind...]

    [Welcome back, anyway!]

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Bootup graphics problem

    Quote Originally Posted by Confuseling View Post
    I think you may have misread the thread caf; he's trying to set up a GUIless server.

    Unless you're just trying to see how it errors...?

    [Welcome back, anyway!]
    Serves me right for skip reading. Thanks for the welcome.

    I take it this is a DVD then.
    Should be straight forward in text mode.
    Has a media check been done?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •