Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Packman for Factory available

  1. #1
    Join Date
    Jun 2008
    Location
    Slovakia
    Posts
    25

    Default Packman for Factory available

    Quote:
    "It has often been requested in the past, and we're finally building Packman packages for openSUSE Factory (the openSUSE development tree)."

    /dev/loki: Packman for Factory

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Packman for Factory available

    Quote Originally Posted by ra100 View Post
    Quote:
    "It has often been requested in the past, and we're finally building Packman packages for openSUSE Factory (the openSUSE development tree)."

    /dev/loki: Packman for Factory
    Thanks for the link to yaloki's blog.

    We had a discussion on this in the URL below that I quote, and my original assessment was wrong, and my view had to be corrected (as having a factory for Packman packaged apps is relatively new): Packman Repo problems with 11.2 M7 - openSUSE Forums

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Packman for Factory available

    Pretty sweet if you're keen to get on the testing treadmill.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Feb 2009
    Location
    Baton Rouge, LA, US
    Posts
    152

    Default Re: Packman for Factory available

    Thanks to Pascal Bleser and anyone else involved in this work. Very much appreciated.

    I was able to add in Yast2 using these url's:

    ftp://packman.links2linux.org/pub/packman/suse/factory/

    ftp://packman.links2linux.org/pub/packman/suse/11.2

    I enabled the 11.2 one for now as I'm currently using the 11.2 OSS and NON-OSS repos. It seems to work just fine:

    Code:
    # zypper -v ref && zypper -v dup
    Verbosity: 1                                 
    Initializing Target                          
    Specified repositories:                      
    Checking whether to refresh metadata for Default-Update-Repository
    Retrieving: repomd.xml [done]                                     
    Repository 'Default-Update-Repository' is up to date.             
    Checking whether to refresh metadata for KDE-Desktop-Factory      
    Retrieving: repomd.xml [done]                                     
    Repository 'KDE-Desktop-Factory' is up to date.                   
    Checking whether to refresh metadata for KDE4-Community-Factory   
    Retrieving: repomd.xml [done]                                     
    Repository 'KDE4-Community-Factory' is up to date.                
    Checking whether to refresh metadata for KDE4-Playground-Factory  
    Retrieving: repomd.xml [done]                                     
    Repository 'KDE4-Playground-Factory' is up to date.               
    Checking whether to refresh metadata for Mozilla-Factory          
    Retrieving: repomd.xml [done]                                     
    Repository 'Mozilla-Factory' is up to date.                       
    Checking whether to refresh metadata for OpenOffice-EXTRAS-Factory
    Retrieving: repomd.xml [done]                                     
    Repository 'OpenOffice-EXTRAS-Factory' is up to date.             
    Checking whether to refresh metadata for OpenOffice-UNSTABLE-Factory
    Retrieving: repomd.xml [done]                                       
    Repository 'OpenOffice-UNSTABLE-Factory' is up to date.             
    Checking whether to refresh metadata for Packman-openSUSE-11.2      
    Retrieving: repomd.xml [done (0 B/s)]                               
    Repository 'Packman-openSUSE-11.2' is up to date.                   
    Checking whether to refresh metadata for Videolan-11.2              
    Retrieving: repomd.xml [done]                                       
    Repository 'Videolan-11.2' is up to date.                           
    Checking whether to refresh metadata for http-download.opensuse.org-72837608
    Retrieving: repomd.xml [done]                                               
    Repository 'http-download.opensuse.org-72837608' is up to date.             
    Skipping disabled repository 'openSUSE 11.2-0'                              
    Skipping disabled repository 'Packman-openSUSE-Factory'                     
    Skipping disabled repository 'openSUSE-11.2-Debug'                          
    Checking whether to refresh metadata for openSUSE-11.2-Non-Oss              
    Retrieving: content [done]                                                  
    Retrieving: media [done]                                                    
    Repository 'openSUSE-11.2-Non-Oss' is up to date.                           
    Checking whether to refresh metadata for openSUSE-11.2-Oss                  
    Retrieving: content [done (41.3 KiB/s)]                                     
    Retrieving: media [done]                                                    
    Repository 'openSUSE-11.2-Oss' is up to date.                               
    Skipping disabled repository 'openSUSE-11.2-Source'                         
    All repositories have been refreshed.                                       
    Verbosity: 1                                                                
    Initializing Target                                                         
    Checking whether to refresh metadata for Default-Update-Repository          
    Checking whether to refresh metadata for KDE-Desktop-Factory                
    Checking whether to refresh metadata for KDE4-Community-Factory             
    Checking whether to refresh metadata for KDE4-Playground-Factory            
    Checking whether to refresh metadata for Mozilla-Factory                    
    Checking whether to refresh metadata for OpenOffice-EXTRAS-Factory          
    Checking whether to refresh metadata for OpenOffice-UNSTABLE-Factory        
    Checking whether to refresh metadata for Packman-openSUSE-11.2              
    Checking whether to refresh metadata for Videolan-11.2                      
    Checking whether to refresh metadata for http-download.opensuse.org-72837608
    Checking whether to refresh metadata for openSUSE-11.2-Non-Oss              
    Checking whether to refresh metadata for openSUSE-11.2-Oss                  
    Loading repository data...                                                  
    Reading installed packages...                                               
    Computing distribution upgrade...                                           
    Force resolution: No                                                        
    Computing upgrade...                                                        
    
    The following NEW packages are going to be installed:
      libmodplug0      0.8.7-1.12                        
      libxine1-codecs  1.1.16.3-2.pm.6.2                 
    
    
    The following packages are going to be upgraded:
      lame                3.98.2-1.pm.2.1 -> 3.98.2-1.pm.2.3    
      libmp3lame0         3.98.2-1.pm.2.1 -> 3.98.2-1.pm.2.3    
      libxine1            1.1.16.1-4.52 -> 1.1.16.3-2.pm.6.2    
      libxine1-gnome-vfs  1.1.16.1-4.52 -> 1.1.16.3-2.pm.6.2    
      libxine1-pulse      1.1.16.1-4.52 -> 1.1.16.3-2.pm.6.2    
      libxvidcore4        1.2.2-1.pm.1.1 -> 1.2.2-1.pm.1.3      
      smplayer            0.6.8-0.pm.1 -> 0.6.8-0.pm.2.1        
      wxWidgets           2.8.10.1-1.pm.1.2 -> 2.8.10.1-1.pm.6.1
    
    
    The following packages are going to be downgraded:
      libfaac0        1.28-1.pm.1.2 -> 1.28-1.pm.1.1           
      libfaad2        2.7-1.pm.1.4 -> 2.7-1.pm.1.2             
      libgpod4        0.7.2-100.pm.100.2 -> 0.7.2-6.8          
      libquicktime0   1.1.3-100.pm.102.12 -> 1.1.3-100.pm.102.3
      usb_modeswitch  1.0.2-1.pm.3 -> 0.9.6-2.22               
    
    
    The following packages are going to be reinstalled:
      MPlayer             1.0rc2_r29116-2.pm.29.1            
      ffmpeg              0.5.20006svn-20090924.pm.20090925.1
      liba52-0            0.7.4-3.pm.6.1                     
      libamrnb3           7.0.0.2-0.pm.5.1
      libamrwb3           7.0.0.3-0.pm.5.1
      libavcodec52        0.5.20006svn-20090924.pm.20090925.1
      libavdevice52       0.5.20006svn-20090924.pm.20090925.1
      libavformat52       0.5.20006svn-20090924.pm.20090925.1
      libavutil50         0.5.20006svn-20090924.pm.20090925.1
      libdca0             0.0.5-1.pm.2.1
      libdvdread3         0.9.7-5.pm.5.1
      libmad0             0.15.1b-1.pm.3.1
      libmp4v2            1.6.1-1.pm.1.2
      libopencore-amrnb0  0.1.2-0.pm.1.1
      libopencore-amrwb0  0.1.2-0.pm.1.1
      libpostproc51       0.5.20006svn-20090924.pm.20090925.1
      libspeex1           1.1.99.99-1.pm.1.1
      libswscale0         0.5.20006svn-20090924.pm.20090925.1
      libtheora0-32bit    1.1.beta2-0.pm.9.1
      libtwolame0         0.3.12-0.pm.3.1
      libx264-67          0.0svn20090923-0.pm.2.1
      libx264-72          0.0svn20090923-0.pm.2.1
      libx264-75          0.0svn20090923-0.pm.2.1
      libx264-76          0.0svn20090923-0.pm.2.1
      mjpegtools          1.9.0.0-1.pm.2.1
      sox                 14.3.0-99.pm.99.1
      vobcopy             1.2.0-1.pm.1.1
    
    
    The following packages are going to change vendor:
      libgpod4            0.7.2-100.pm.100.2 -> 0.7.2-6.8     http://packman.links2linux.de -> obs://build.opensuse.org/KDE
      libxine1            1.1.16.1-4.52 -> 1.1.16.3-2.pm.6.2  openSUSE -> http://packman.links2linux.de
      libxine1-gnome-vfs  1.1.16.1-4.52 -> 1.1.16.3-2.pm.6.2  openSUSE -> http://packman.links2linux.de
      libxine1-pulse      1.1.16.1-4.52 -> 1.1.16.3-2.pm.6.2  openSUSE -> http://packman.links2linux.de
      usb_modeswitch      1.0.2-1.pm.3 -> 0.9.6-2.22          http://packman.links2linux.de -> openSUSE
    
    
    8 packages to upgrade, 5 to downgrade, 2 new, 27 to reinstall, 5  to change vendor.
    Overall download size: 30.4 MiB. After the operation, additional 2.7 MiB will be used.
    Continue? [y/n/?] (y):
    It's updating now with x86_64 packages. I'll reboot and try some things to see if everything is working but it sure seems to be working.
    Last edited by dwightpaige79; 25-Sep-2009 at 07:52. Reason: Misspelled Pascal's name.
    Thanks,
    Dwight Paige

  5. #5
    Join Date
    May 2008
    Location
    Belgium
    Posts
    42

    Exclamation Re: Packman for Factory available

    Please make sure to use a mirror !

    All the traffic on links2linux.org is to the expense of the very kind person who is hosting all our resources (except the build hosts), so definitely use one of the mirror servers (see link above). The factory subdirectory is mirrored everywhere anyway.

    And the 11.2 repository is currently just a symlink to factory.

  6. #6
    Join Date
    May 2008
    Location
    Belgium
    Posts
    42

    Default Re: Packman for Factory available

    Note that we don't provide all the packages we do for releases, but at least we have MPlayer, smplayer, handbrake, xine, gstreamer, etc...

    If you're missing something you believe should definitely be provided for factory, please let us know, but understand that we don't have infinite build resources.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,328
    Blog Entries
    15

    Default Re: Packman for Factory available

    Quote Originally Posted by pbleser
    Note that we don't provide all the packages we do for releases, but at
    least we have MPlayer, smplayer, handbrake, xine, gstreamer, etc...

    If you're missing something you believe should definitely be provided
    for factory, please let us know, but understand that we don't have
    infinite build resources.
    Hi
    Is it possible to get the latest gecko-media-player and gnome-mplayer
    added for the chromium-browser users as well as other users wanting to
    see the apple trailers...

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 4 days 21:37, 2 users, load average: 0.22, 0.25, 0.27
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Packman for Factory available

    There is some craki'n work going on at the moment in development. When 11.2 goes Gold it's going to be a bostin job.
    I'm proud to be involved. And Packman is a life saver.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Packman for Factory available

    Quote Originally Posted by pbleser View Post
    Note that we don't provide all the packages we do for releases, but at least we have MPlayer, smplayer, handbrake, xine, gstreamer, etc...

    If you're missing something you believe should definitely be provided for factory, please let us know, but understand that we don't have infinite build resources.
    Please, new users, note this is memorable: this is the former SuSE-guru speaking !!! Pascal has been providing packages to us for years, during versions 8, 9 and 10.

    @pbleser: Great to see your writings on the forums, keep the good work going ! And thankx for all the work you've been doing
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Feb 2009
    Location
    Baton Rouge, LA, US
    Posts
    152

    Default Re: Packman for Factory available

    I have updated my repos to use a mirror for Packman Factory. And it does indeed work.

    Thanks again pbleser.
    Thanks,
    Dwight Paige

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •