Results 1 to 5 of 5

Thread: M7 + Nvidia + KDE

  1. #1
    Join Date
    Sep 2009
    Location
    UK
    Posts
    310

    Default M7 + Nvidia + KDE

    Has anyone had the old black window bug?
    With M7 and Nvidia 190 beta ( which is the
    only one I could get to run ) and KDE I get the old
    black window problem when there are half a
    dozen windows open ..... I haven't seen that
    one in a long time :-)

    Is there anything I can do or do I just wait
    for everyone to release final versions ?

    Ta

    M

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: M7 + Nvidia + KDE

    First: there's no 'old black window bug', i.e. there's thousands of them, which one do you mean.

    Please provide more info, like:
    NVIDIA card ?
    32/64bit ?
    Compiz/Kwin ?

    I manage dozens of computers with dozens of different NVIDIA cards, running 11.0, 11.1 and Factory, none of them shows this problem.

    You too may have old plasma-settings in your .kde4 dir. See is this helps:
    Logout
    At login screen hit Crtl-Alt-F1
    Login with username and password, then do:
    rm ~/.kde4/share/config/plasma*
    Hit Ctrl-Alt-F7 to return to login screen. Login with username and password and you will have the standard desktop. Now you can reapply themes, widgets etc. Nine out of ten times this solves plasma-crashes (afaics that's what's happening.\

    Good luck.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Sep 2009
    Location
    UK
    Posts
    310

    Default Re: M7 + Nvidia + KDE

    Plasma isn't crashing. The 'old bug' I was refering to is
    when the Nvidia card runs out of memory. Fedora used to suffer from it a lot. If you open lots of windows then they start opening with black windows. Close a few and they will open OK. As far as I understand the card should play nicely and borrow some of the system memory when it runs out itself. Since my original post I have found a thread on the Nvidia forums and it seems the 190 beta is causing all sorts of fun. I will wander off and follow those threads

    Ta

    M

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: M7 + Nvidia + KDE

    On my main machine I have an average of about 30 windows open when working, a 25 file kate-session included, 4 to 5 users logged in as well. I've tried to force behaviour on main machine as well as laptop, no results. So I'm afraid I cannot help you.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Korneuburg, Austria
    Posts
    177

    Default Re: M7 + Nvidia + KDE

    I also have some problems with my nvidia card, sometimes the screen just goes black. I'll wait for M8 and hope that the bugs might get fixed...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •