Results 1 to 6 of 6

Thread: Just can't get nVidia MCP51 sound to work properly

  1. #1

    Default Just can't get nVidia MCP51 sound to work properly

    I installed 11.1 soon after it was released last year. Initially sound didn't work. I followed the SDB:AudioTroubleshooting - openSUSE page and added the line
    Code:
    options snd-hda-intel model=dell-3stack
    to my /etc/modprobe.d/sound file, and boom, worked like a charm.

    Everything was fine until I upgraded to the 2.6.27.29-0.1-default kernel. Now, it's the weirdest thing. There's no sound until I restart alsa. As soon as I do that, everything seems to work, however, the volume slowly fades out over a period of 30-35 seconds, then nothing. No matter what I try makes any difference. I've tried everything in SDB:AudioTroubleshooting - openSUSE several times to no avail. I've scoured the Internet and can't find anything even remotely similar to my problem.

    If anyone can help, I would greatly appreciate it.

    Here is my system info:

    http://www.alsa-project.org/db/?f=db...47c57eaec7023d

    # rpm -qa | grep alsa
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-oss-32bit-1.0.17-1.37
    alsa-tools-1.0.18-1.16
    alsa-plugins-1.0.18-6.13
    alsa-firmware-1.0.17-1.42
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.12.1
    alsa-driver-kmp-default-1.0.21.20090921_2.6.27.29_0.1-3.1

    # rpm -qa | grep pulse
    alsa-plugins-pulse-1.0.18-6.13
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    vlc-aout-pulse-0.9.8a-1.4
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1

    # rpm -q libasound2
    libasound2-1.0.18-8.12.1

    # uname -a
    Linux golden 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

    # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # wRyD.d0Gzwbsa7K3:MCP51 High Definition Audio
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-3stack

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Just can't get nVidia MCP51 sound to work properly

    Quote Originally Posted by drewmat View Post
    I installed 11.1 soon after it was released last year. Initially sound didn't work. I followed the SDB:AudioTroubleshooting - openSUSE page and added the line
    Code:
    options snd-hda-intel model=dell-3stack
    to my /etc/modprobe.d/sound file, and boom, worked like a charm.

    Everything was fine until I upgraded to the 2.6.27.29-0.1-default kernel. Now, it's the weirdest thing. There's no sound until I restart alsa. As soon as I do that, everything seems to work, however, the volume slowly fades out over a period of 30-35 seconds, then nothing. ...

    http://www.alsa-project.org/db/?f=db...47c57eaec7023d

    # rpm -qa | grep alsa
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-oss-32bit-1.0.17-1.37
    alsa-tools-1.0.18-1.16
    alsa-plugins-1.0.18-6.13
    alsa-firmware-1.0.17-1.42
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.12.1
    alsa-driver-kmp-default-1.0.21.20090921_2.6.27.29_0.1-3.1
    These alsa updates do NOT look correct to me. When updating from the OBS directory, one is supposed to use six zypper commands to install alsa-driver-kmp-default and also update some of the alsa apps. Clearly you have not done that. I recommend you FIX that first. There is guidance here. Please read it again. Note you must send SIX zypper commands. If you do not understand that from reading the guide, please explain to me where the guide should be improved: Alsa-update - openSUSE

    Then restart your PC and test.

    Also, the line you added to the /etc/modprobe.d/sound file, should IMHO be the 1st line, and not the last line.

    I don't know if that will solve your problem, but at least it will provide a more solid baseline.

  3. #3

    Default Re: Just can't get nVidia MCP51 sound to work properly

    I must not have looked at the alsa update page closely enough to realize there were six commands. I should be updated now.

    I also moved the "model" line to the start of /etc/modprobe.d/sound, rebooted and am getting the same result.

    Suggestions on what to try next? Thnx.

    http://www.alsa-project.org/db/?f=c9...75b68dab1ef6a1

    # rpm -qa | grep alsa
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-oss-32bit-1.0.17-1.37
    alsa-driver-kmp-default-1.0.21.20090923_2.6.27.29_0.1-1.1
    alsa-tools-1.0.18-1.16
    alsa-plugins-1.0.18-6.13
    alsa-firmware-1.0.17-1.42
    alsa-docs-1.0.18-8.12.1
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.12.1

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Just can't get nVidia MCP51 sound to work properly

    Quote Originally Posted by drewmat View Post
    Suggestions on what to try next? Thnx.

    http://www.alsa-project.org/db/?f=c9...75b68dab1ef6a1

    # rpm -qa | grep alsa
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-oss-32bit-1.0.17-1.37
    alsa-driver-kmp-default-1.0.21.20090923_2.6.27.29_0.1-1.1
    alsa-tools-1.0.18-1.16
    alsa-plugins-1.0.18-6.13
    alsa-firmware-1.0.17-1.42
    alsa-docs-1.0.18-8.12.1
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.12.1
    Suggestions? Yes, remove alsa-driver-kmp-default, restart your PC, and test.

    If that does not work, then you try a model option, selecting one from this list (one at a time):
    Code:
    	STAC9227/9228/9229/927x
    	  ref		Reference board
    	  3stack	D965 3stack
    	  5stack	D965 5stack + SPDIF
    	  dell-3stack	Dell Dimension E520
    	  dell-bios	Fixes with Dell BIOS setup
    You have already tried "dell-3stack". So if that did not work, replace "dell-3stack" with "dell-bios" and such that your /etc/modprobe.d/sound file looks like this:
    Code:
    options snd-hda-intel model=dell-bios 
    options snd slots=snd-hda-intel
    # wRyD.d0Gzwbsa7K3:MCP51 High Definition Audio
    alias snd-card-0 snd-hda-intel
    then restart your sound driver with su -c 'rcalsasound restart' and enter root password when prompted for a password, and then test your audio.

    If that does not work, then try updating your alsa per the guidance here: Note you MUST send six zypper commands: Alsa-update - openSUSE

    You MUST restart your PC after updating alsa. And please try to be careful when updating.

  5. #5

    Default Re: Just can't get nVidia MCP51 sound to work properly

    It works!!!

    I changed the model in the /etc/modprobe.d/sound file to "ref" and now it seems to be working.

    Code:
    # cat /etc/modprobe.d/sound
    options snd-hda-intel model=ref
    options snd slots=snd-hda-intel
    # wRyD.d0Gzwbsa7K3:MCP51 High Definition Audio
    alias snd-card-0 snd-hda-intel
    I'm guessing it was a combination of updating alsa (properly this time) then finding the right model to use.

    Thanks oldcpu for you help!

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Just can't get nVidia MCP51 sound to work properly

    Quote Originally Posted by drewmat View Post
    It works!!!
    Super ! Congratulations!

    Note, next time there is a kernel update, you may need to update alsa again. If your sound breaks after then next kernel update, and you are stumped how to update, just post here asking for help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •