Results 1 to 10 of 10

Thread: no sound on hp dv6-1250el

  1. #1

    Default no sound on hp dv6-1250el

    Hi, I have no sound on a HP Pavilion dv6-1250el laptop running OpenSUSE 11.1 with kde 3.5.10

    Running:
    Code:
    # cat /proc/asound/card0/codec#0 | grep Codec
    Codec: IDT 92HD75B3X5
    
    #lspci
    Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03) 01:00.1 
    Audio device: ATI Technologies Inc RV730XT Audio device [Radeon HD 4670]
    Output of alsa-info.sh is located at http://www.alsa-project.org/db/?f=ca...26f16393514f12

    Do you need other output command?? can you help me??

    thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: no sound on hp dv6-1250el

    Quote Originally Posted by gepeppe View Post
    Hi, I have no sound on a HP Pavilion dv6-1250el laptop running OpenSUSE 11.1 with kde 3.5.10

    Running:
    Code:
    # cat /proc/asound/card0/codec#0 | grep Codec
    Codec: IDT 92HD75B3X5
    
    #lspci
    Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03) 01:00.1 
    Audio device: ATI Technologies Inc RV730XT Audio device [Radeon HD 4670]
    OK, I note a 32-bit openSUSE-11.1 with the 2.6.27.29-0.1-pae kernel and the latest 1.0.21 version of alsa. I see your HP DV6 has the IDT 92HD75B3X5 hardware audio codec.

    For the HP DV6 with an IDT 92HD75B3X5 hardware audio codec, please add this line to the START of the file /etc/modprobe.d/sound :
    Code:
    options snd-hda-intel model=hp-m4 enable_msi=1
    then restart your PC and test your sound.

    You can edit the /etc/modprobe.d/sound file
    • in gnome by typing: gnomesu gedit /etc/modprobe.d/sound #and enter root password when prompted
    • in kde by typing: kdesu 'kwrite /etc/modprobe.d/sound' #and enter root password when prompted.


    I note this worked for some other HP DV6 users

    Quote Originally Posted by gepeppe View Post
    Do you need other output command?? can you help me??
    If the above does not work, please provide the output of:
    rpm -qa | grep alsa
    rpm -q libasound2
    cat /etc/modprobe.d/sound

  3. #3

    Default Re: no sound on hp dv6-1250el

    no..it doesn't work so:

    Code:
    # rpm -qa | grep alsa
    alsa-oss-1.0.17-25.11
    alsa-utils-1.0.21-13.3
    alsa-firmware-1.0.20-2.1
    alsa-1.0.21-43.1
    alsa-driver-kmp-pae-1.0.21.20090922_2.6.27.7_9.1-2.1
    alsa-plugins-1.0.21-17.2
    alsa-plugins-pulse-1.0.21-17.2
    Code:
    # rpm -q libasound2
    libasound2-1.0.18-8.12.1
    Code:
    cat /etc/modprobe.d/sound
    options snd-hda-intel model=hp-m4 enable_msi=1
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: no sound on hp dv6-1250el

    Quote Originally Posted by gepeppe View Post
    no..it doesn't work so:

    Code:
    # rpm -qa | grep alsa
    alsa-oss-1.0.17-25.11
    alsa-utils-1.0.21-13.3
    alsa-firmware-1.0.20-2.1
    alsa-1.0.21-43.1
    alsa-driver-kmp-pae-1.0.21.20090922_2.6.27.7_9.1-2.1
    alsa-plugins-1.0.21-17.2
    alsa-plugins-pulse-1.0.21-17.2
    Code:
    # rpm -q libasound2
    libasound2-1.0.18-8.12.1
    No worries. Lets update alsa.

    Leave that setting (in the /etc/modprobe.d/sound file) in place, and then for your 2.6.27.29-0.1-pae kernel, send the following six commands (from a terminal with root permissions with your pc connected to the internet) in sequence:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa alsa-docs libasound2
    Code:
     zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-pae
    Code:
    zypper rr multimedia
    restart your PC and test your sound.

    If that does not work, then leave that in place and then update your alsa to the daily snapshots by sending (from a terminal with root permissions with pc connected to the internet) the following six zypper commands:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/snapshot/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-pae
    Code:
    zypper rr multimedia
    you may be told some are already installed. Continue sending that and subsequent commands anyway. Then restart your PC and test the sound.

    Reference:
    1. http://en.opensuse.org/Alsa-update#openSUSE-11.1
    2. http://en.opensuse.org/Alsa-update-s..._openSUSE-11.1

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: no sound on hp dv6-1250el

    Don't forget when testing your sound to move your master, PCM and speaker settings up to 95%. When testing for sound, do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

  6. #6

    Default Re: no sound on hp dv6-1250el

    thanks to everybody!!!!!!!! It works!!!!!!! yessssss


  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: no sound on hp dv6-1250el

    Quote Originally Posted by gepeppe View Post
    It works!!!!!!! yessssss

    Great ! Congratulations !

  8. #8

    Default Re: no sound on hp dv6-1250el

    mmm I can hear sound in avi and mp3, so it's ok!!

    I can see youtube video on firefox, but I can't hear its sound!! why??

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: no sound on hp dv6-1250el

    Quote Originally Posted by gepeppe View Post
    mmm I can hear sound in avi and mp3, so it's ok!!

    I can see youtube video on firefox, but I can't hear its sound!! why??
    Typically, to see videos with firefox, one needs the application flash-player and either the application mplayerplug-in (which is being depreciated) or the application gecko-mediaplayer. Please ensure you have flash-player installed, and have either mplayerplug-in or gecko-mediaplayer.

    Now, I also note your openSUSE-11.1 is a 32-bit version. Sometimes 32-bit openSUSE-11.1 users, even though they have the applications I noted installed, still have a problem with audio. This could be the problem you are experiencing. In which case, the solution that works sometimes is to remove the application libflashsupport (but keep flash-player). Restart firefox, and test.

  10. #10

    Default Re: no sound on hp dv6-1250el

    ok, it works!! thank a lot!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •