Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to install staredit in my suse 11.1

  1. #1

    Default How to install staredit in my suse 11.1

    Hi, I am a fresh for suse. I just used several days ago.

    I have downloaded stardict-3.0.1-1.fc8.i386.rpm, when I install
    it by Yast2, it said that
    error: Failed dependencies:
    GConf2 is needed by stardict-3.0.1-1.fc8.i386
    libenchant.so.1 is needed by stardict-3.0.1-1.fc8.i386
    libespeak.so.1 is needed by stardict-3.0.1-1.fc8.i386
    libgucharmap.so.6 is needed by stardict-3.0.1-1.fc8.i386
    libsigc++20 >= 2.0.17 is needed by stardict-3.0.1-1.fc8.i386
    libsigc-2.0.so.0 is needed by stardict-3.0.1-1.fc8.i386

    However, I checked them in Yast2. Yast2 told me that I have installed GConf2,lib....

    Why? Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to install staredit in my suse 11.1

    Please do this, open a terminal and become su and do:

    Code:
    zypper in stardict
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: How to install staredit in my suse 11.1

    another problem happens:
    Problem: nothing provides libgucharmap.so.6 needed by stardict-3.0.1-1.fc8.i386
    Solution 1: do not ask to install a solvable providing stardict = 3.0.1-1.fc8

    what this means? how can i get libgucharmap.so.6.

    Thanks very much.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to install staredit in my suse 11.1

    Please post result of this from a terminal

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to install staredit in my suse 11.1

    Where is this from: .fc8.i386

    Did you do exactly as I asked?

    Let's see the zypper info anyway
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: How to install staredit in my suse 11.1

    it is like this

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-----------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    2 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    3 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    4 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    5 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    6 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |

  7. #7

    Default Re: How to install staredit in my suse 11.1

    Weidong@zhf:~/Desktop> su
    Password:
    zhf:/home/Weidong/Desktop # zypper in stardict-3.0.1-1.fc8.i386.rpm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides libgucharmap.so.6 needed by stardict-3.0.1-1.fc8.i386
    Solution 1: do not ask to install a solvable providing stardict = 3.0.1-1.fc8

    Choose the above solution using '1' or cancel using 'c' [1/C]: c
    zhf:/home/Weidong/Desktop # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-----------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    2 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    3 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    4 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    5 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    6 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |

  8. #8

    Default Re: How to install staredit in my suse 11.1

    I download stardict from its official website.
    It has only .rpm and .deb format

  9. #9

    Default Re: How to install staredit in my suse 11.1

    Webpin

    Why on earth does anybody want to install a package from Fedora 8 on openSUSE 11.1 which is readily available even from the OSS repo?

  10. #10

    Default Re: How to install staredit in my suse 11.1

    I am sorry for this stupid problem. I am really a fresh for Suse
    and Linux.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •