Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Mic produces ugly noices on Skype [OpenSuse 11.1]

  1. #1

    Unhappy Mic produces ugly noices on Skype [OpenSuse 11.1]

    Hello, folks!
    I am using Gnome under OpenSuse 11.1. I got some weird problems with my sound-card. The audio output is working fine, but the microphone cause me a lot of troubles with skype (it works fine with Ekiga). I have tried the following options in gnome-sound-properties input device to the following:
    1. AlsaMixer
    Result: ugly noises in Skype 2.1.0.47- I could here the other parity, but my mic or more correctly the alsamixer produces ugly noises. The Ekiga is working fine.

    2. PulseAudio
    Result: The mic is not working at all. The Ekiga client does not work either.

    So the configuration of my audio is as follows:

    Code:
    cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xfdffc000 irq 16
    Code:
     rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    java-1_6_0-sun-alsa-1.6.0.u15-0.1.1
    alsa-plugins-1.0.18-6.12
    alsa-plugins-pulse-1.0.18-6.12
    alsa-devel-1.0.18-8.12.1
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.12.1
    Code:
    rpm -qa | grep pulse
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    vlc-aout-pulse-1.0.2-1.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.12
    libpulse0-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-module-gconf-0.9.14-2.2.1
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    Code:
    rpm -q libasound2
    libasound2-1.0.18-8.12.1
    Code:
    uname -a
    Linux HostName90 2.6.27.29-0.1-pae #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux
    Code:
    cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel
    # u1Nb.W0ulqSHyX31:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    #options snd-hda-intel enable=1 index=0
    #alias snd-card-0 snd-hda-intel
    #alias sound-slot-0 snd-hda-intel
    Code:
    cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel
    # u1Nb.W0ulqSHyX31:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    Any idea how to solve the problem? Do you need more information?
    I don't know whether it is relevant but the KRecord gives me the following error message (with any of the sound-card configurations):
    Code:
    can't open soundcard: No such file or directory
    The gnome-sound-recorder works fine.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    OK, I note a Dell Precision WorkStation T3400 running a 32-bit openSUSE-11.1 with the latest SuSE-GmbH/Novell packaged 2.6.27.29-0.1-pae kernel, with 1.0.17/1.0.18 of alsa and an AD1984 hardware audio codec.

    I note these mixer settings relevant to your mic. It appears you have two input source controls, one called "input-source-0" and one called "input-source-1". While you have them both set to "Front Mic", your PC has the Capture on "Input-Source-1" selected OFF. Could that be part of your problem ?
    !!Amixer output
    !!-------------

    !!-------Mixer controls for card 0 [Intel]

    Card hw:0 'Intel'/'HDA Intel at 0xfdffc000 irq 16'
    Mixer name : 'Analog Devices AD1984'
    Simple mixer control 'Front Mic',0
    Front Left: Playback 23 [74%] [0.00dB] [on]
    Front Right: Playback 23 [74%] [0.00dB] [on]
    Simple mixer control 'Front Mic Boost',0
    Front Left: 2 [67%]
    Front Right: 2 [67%]
    Simple mixer control 'Line-In Boost',0
    Front Left: 2 [67%]
    Front Right: 2 [67%]
    Simple mixer control 'Capture',0
    Front Left: Capture 34 [63%] [-7.50dB] [on]
    Front Right: Capture 34 [63%] [-7.50dB] [on]
    Simple mixer control 'Capture',1
    Front Left: Capture 39 [72%] [0.00dB] [off]
    Front Right: Capture 39 [72%] [0.00dB] [off]
    Simple mixer control 'Digital',0
    Front Left: Capture 90 [75%] [15.00dB]
    Front Right: Capture 90 [75%] [15.00dB]
    Simple mixer control 'Input Source',0
    Items: 'Front Mic' 'Line-In' 'Mix'
    Item0: 'Front Mic'
    Simple mixer control 'Input Source',1
    Items: 'Front Mic' 'Line-In' 'Mix'
    Item0: 'Front Mic'

    As you likely already surmised, a way to reduce distortion is to reduce the capture and boost levels as low as practical, such that the mic recording can still be heard, but that the distortion is lower.

    I note there were some updates for the AD1984 in 1.0.20 and 1.0.21 of alsa, although it does not appear to me that those are releveant to your problem (although its not clear to me). Search results - AlsaProject

    I do not use Skype nor Ekiga. I do recommend you do NOT use krecord as your mic test. Rather I recommend you use arecord. There is guidance here: Microphone - openSUSE In particular, please note the recommended command for testing:
    arecord -vv -fdat foo.wav
    where "foo.wav" is an arbitrary file name that you can make up, then play back the file to see if there was a recording.

    I hope that helps.

  3. #3

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    Thanks for the reply - I set Input 1 to be the Line-In (input levels to minimum).
    and I also try again to play with the mic and mic boost levels - in asound everything was OK, but I still get ugly constant noises in Skype (the noise is the same as the one comming from an old TV set when it is unable to catch any TV signal).
    At least this time the alsamixer and pulseaudio are working correctly in asound.
    It seems, that there is something wrong with Skype....
    Could you help me how to install the updates of alsamixer?

    Thanks

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    Quote Originally Posted by modjoa View Post
    Could you help me how to install the updates of alsamixer?
    I'm not aware of any updates specific to alsamixer. It was not my intention to give that impression.

    Rather I note your PC's hardware audio codec is an AD1984, and I note there were some updates for the AD1984 in 1.0.20 and 1.0.21 of alsa, although it does not appear to me that those are releveant to your problem (although its not clear to me). Search results - AlsaProject - for AD1984

    To update alsa there is guidance here: Alsa-update - openSUSE Note one MUST send six zypper commands.

    If that does not work, there are also daily snapshots with installation guidance here: Alsa-update-snapshot - openSUSE Again, one MUST send six zypper commands.

    Note users who deviate from that guide typically break their sound, so if you decide to update to the latest alsa, please exercise caution. Also note if you update to the latest update, if there is a kernel update it may break your sound, forcing a further update.

    And finally, my guess is updating will not help, although I concede this is not perfectly clearl to me.

  5. #5

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    ok, thanks -
    in such a case, for now I am not going to perform the updates. If somebody has an idea or I found any solution - I will write to this topic. Regards.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    Quote Originally Posted by oldcpu View Post
    OK, I note a Dell Precision WorkStation T3400 running a 32-bit openSUSE-11.1 with the latest SuSE-GmbH/Novell packaged 2.6.27.29-0.1-pae kernel, with 1.0.17/1.0.18 of alsa and an AD1984 hardware audio codec.
    I looked into this a bit further.

    I compared the documentation for alsa-1.0.18, 1.0.19 and 1.0.21.

    For 1.0.18 I looked at the alsa-configuration.txt file (which has the model options) and for 1.0.19 and 1.0.21 I looked at the alsa-HD-models.txt file (which has the model options).

    For 1.0.18 of alsa, I noted this for the AD1984 (which your Dell T3400 has):
    Code:
    	AD1984
    	  N/A
    and from 1.0.19 and 1.0.21 of alsa:
    Code:
    	AD1984
    	======
    	  basic		default configuration
    	  thinkpad	Lenovo Thinkpad T61/X61
    	  dell		Dell T3400
    so it appears something specific has been added to alsa 1.0.19 the Dell T3400, which is your PC.

    Hence if I can be forgiven ... I am going to change my recommendation, and recommend you update alsa.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    deleted - inaccurate post

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    Quote Originally Posted by oldcpu View Post
    OK, I note a Dell Precision WorkStation T3400 running a 32-bit openSUSE-11.1 with the latest SuSE-GmbH/Novell packaged 2.6.27.29-0.1-pae kernel, with 1.0.17/1.0.18 of alsa and an AD1984 hardware audio codec.
    Let me try again. I made a mistake in the above post (which I subsequently deleted).

    I looked into this a bit further.

    I compared the documentation for alsa-1.0.18, 1.0.19 and 1.0.21.

    In all cases for 1.0.18 thru to 1.0.21 of alsa I noted these model options:
    Code:
    	AD1984
    	======
    	  basic		default configuration
    	  thinkpad	Lenovo Thinkpad T61/X61
    	  dell		Dell T3400
    so it appears it is possible to force a model option for the Dell T3400, which is your PC.

    Hence, if we make an assumption (that could be wrong) that alsa did not properly configure your PC upon boot, we could force the model option "dell" in your /etc/modprobe.d/sound file.

    Please change that file to:
    Code:
    options snd-hda-intel model=dell
    options snd slots=snd-hda-intel
    # u1Nb.W0ulqSHyX31:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    then reboot your PC and test.

  9. #9

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    Thanks for the detail description, but unfortunately the solution does not solve my problem .
    This is the configuration after the update and reboot:

    Code:
    rpm -q libasound2
    libasound2-1.0.21-43.1
    rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    alsa-devel-1.0.21-43.1
    java-1_6_0-sun-alsa-1.6.0.u15-0.1.1
    alsa-docs-1.0.18-8.12.1
    alsa-plugins-1.0.18-6.12
    alsa-1.0.21-43.1
    alsa-plugins-pulse-1.0.18-6.12
    alsa-utils-1.0.18-6.4
    Code:
     rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    alsa-devel-1.0.21-43.1
    java-1_6_0-sun-alsa-1.6.0.u15-0.1.1
    alsa-docs-1.0.18-8.12.1
    alsa-plugins-1.0.18-6.12
    alsa-1.0.21-43.1
    alsa-plugins-pulse-1.0.18-6.12
    alsa-utils-1.0.18-6.4
    cat /etc/modprobe.d/sound
    options snd-hda-intel model=dell
    options snd slots=snd-hda-intel
    # u1Nb.W0ulqSHyX31:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Mic produces ugly noices on Skype [OpenSuse 11.1]

    Quote Originally Posted by modjoa View Post
    Thanks for the detail description, but unfortunately the solution does not solve my problem .
    This is the configuration after the update and reboot:

    Code:
    rpm -q libasound2
    libasound2-1.0.21-43.1
    Code:
     rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    alsa-devel-1.0.21-43.1
    java-1_6_0-sun-alsa-1.6.0.u15-0.1.1
    alsa-docs-1.0.18-8.12.1
    alsa-plugins-1.0.18-6.12
    alsa-1.0.21-43.1
    alsa-plugins-pulse-1.0.18-6.12
    alsa-utils-1.0.18-6.4
    Hmmm ... It appears you updated based on my deleted post. Unfortunately, you did not update correctly.

    I recommend you either roll back to the alsa version that comes with 11.1, or update properly. To update properly the guidance is here: Alsa-update - openSUSE

    You must send six zypper commands. It appears you only sent the 1st 3 as you did NOT install alsa-driver-kmp-pae associated with your 2.6.27.29-0.1-pae kernel.

    For the last 3 commands, you need to do that by copying and pasting (per the above URL):
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-pae
    Code:
    zypper rr multimedia
    Then restart your PC and test your sound.

    Note if you did not remove the multimedia repository, per the instructions, then the above 3 commands will fail.

    Since you were not able to follow the instructions in the guide correctly, can you please tell me what is wrong with the guide. Why did you only send 3 commands when the guide says one must send 6 commands. What is wrong with the guide such that point is missed. You are not the 1st to make this mistake and I want to know how to improve that guide so that users stop making this same mistake.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •