Results 1 to 5 of 5

Thread: Firefox launches twice from shortcut

  1. #1

    Default Firefox launches twice from shortcut

    Running OpenSuse 10.3 KDE.Recently upgraded firefox to 3.5

    Now, when I click on a shortcut or button to launch Firefox it tries to open twice. The first instance opens OK then the bouncing icon continues but eventually gives up.

    Command in the shortcut is: firefox %u
    Advanced options: "Enable launch feedback"

    If I launch Firefox from the command line - launches OK no problems. (Although when I close Firefox I get a load of "failed" messages).

    Also, since upgrade, clicking links in Thunderbird no longer opens the link in Firefox. This is probably not related - or is it?

    Any ideas?

    Thanks
    Last edited by Avoca; 24-Sep-2009 at 01:15. Reason: Add text

  2. #2
    platinum NNTP User

    Default Re: Firefox launches twice from shortcut

    > Any ideas?

    clicking twice in Windows causes an application launch
    clicking once in Linux causes an application launch
    clicking twice in Linux cause TWO application launches..

    think of all the clicking you save with Linux!!
    and, who ever decided that one click should do NOTHING?

    on the other hand, if you can't break the Windows[tm] habit, you can
    change the default to mimic the wasteful, double click Redmond
    way...but, i actually don't remember how to change it..

    --
    platinum

  3. #3
    Camalen NNTP User

    Default Re: Firefox launches twice from shortcut

    Avoca wrote:

    > Running OpenSuse 10.3 KDE.Recently upgraded firefox to 3.5
    >
    > Now, when I click on a shortcut or button to launch Firefox it tries to
    > open twice. The first instance opens OK then the bouncing icon continues
    > but eventually gives up.
    >
    > Command in the shortcut is: firefox %u
    > Advanced options: "Enable launch feedback"
    >
    > If I launch Firefox from the command line - launches OK no problems.
    > (Although when I close Firefox I get a load of "failed" messages).


    That is a known issue, also commented here in the forums:

    http://forums.opensuse.org/applicati...fox-3-5-a.html

    I'm also in opensuse 10.3 and solved that "bouncing" issue by disabling
    the "Enable launch feedback" in the menu. That's all.

    > Also, since upgrade, clicking links in Thunderbird no longer opens the
    > link in Firefox. This is probably not related - or is it?


    Dunno, but almost sure you could tweak that by selecting the default browser
    under KDE control center or just by configuring "about:config" under
    Thunderbird,

    Greetings,

    --
    Camalen

  4. #4

    Default Re: Firefox launches twice from shortcut

    Thank you.

    I see now that it's not Firefox launching twice - it's just that the launch feedback does not know when to stop!

    Now, just to get those links working...

  5. #5
    marpag NNTP User

    Default Re: Firefox launches twice from shortcut

    This happens to many applications. Firefox and Thunderbird are but two. The fix is to edit the lauch icon properties by right clicking on the icon, clicking on "advanced" and disabling the "enable launch feedback" button. Many applications provide no launch feed back to KDE, including Firefox and Thunderbird. But, KDE will continue to display the bouncing icon until it times out because it is waiting for launch feedback that never comes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •