Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Black Screen no Command Prompt

  1. #1
    rashid1985 NNTP User

    Default Black Screen no Command Prompt

    Recently I have run into a problem.
    I made a change that has crippled my system and do not know how to reverse the effect.

    I made a copy of a file bash.bashrc and named it bash.bashrc.local

    when I restarted my konsole all I got was a blank line.
    my prompt did not show user@desktop $ anymore and any thing that I type goes through without any reaction from the command line.

    typing ls results in cursor moving to next line and nothing happens.

    After I rebooted the machine and tried to log in the screen goes black and I see a cursor.

    I've tried GNOME, KDE3, KDE4, IceWM, and all failesafe modes with the same results. Loggin into the command line will allow me to log in and then I get no command prompt and no response from the pc.

    I know it's working becuase my virtual windows machine on it is running and I can remote into it.

    Anybody have any how I can get back in and delete the bash.bashrc.local file when nothing seems to be working?

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Black Screen no Command Prompt

    If it is related to deleting a file, then you can use console with out any graphical mode.
    Do you know the location of the file. cd to that folder and delete it.

    Just an example:
    rm /home/test/bash.bashrc.local
    Note: backup, backup and backup before deleting or doing any thing.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  3. #3
    rashid1985 NNTP User

    Default Re: Black Screen no Command Prompt

    I tried getting to console mode from the login screen.
    It asked for my user name and then the password and logged me in. However, I did not get a command prompt. Whatever I type has no effect.

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Black Screen no Command Prompt

    Type 3 at the boot screen while stopping the timer by arrow key(up/down).
    And login to command based mode and try there.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  5. #5
    platinum NNTP User

    Default Re: Black Screen no Command Prompt

    -boot
    -at first screen select Fail Safe, press enter
    -when the command line comes
    --type root hit enter
    --type [root's password] hit enter
    -type cd /etc hit enter
    -type mv bash.bashrc.local bashrc.bashrc local.bad-idea hit enter
    -type exit hit enter
    -type startx hit enter
    -log in as yourself

    -start over this time by creating an EMPTY file named
    bash.bashrc.local and then fill it with whatever the directions you
    are following says to...

    mine begins like this:


    # /etc/bash.bashrc.local for openSUSE Linux
    #
    # PLEASE DO NOT CHANGE /etc/bash.bashrc There are chances
    # that your changes will be lost during system upgrades.
    # Instead use /etc/bash.bashrc.local for your local settings,
    # favorite global aliases, VISUAL and EDITOR variables, etc ...
    #
    # below alias list developed over time

    alias lsd='ls -hal | less'
    alias x='exit'
    alias m='mc'
    alias s='su -'
    alias a='atop'
    alias t='top'
    alias mv='mv -i'
    alias cp='cp -i'
    alias rm='rm -i'
    alias rmdir='rmdir -i'

    enjoy
    --
    platinum

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,145

    Default Re: Black Screen no Command Prompt

    On Wed, 23 Sep 2009 18:46:01 +0000, rashid1985 wrote:

    > Recently I have run into a problem.
    > I made a change that has crippled my system and do not know how to
    > reverse the effect.
    >
    > I made a copy of a file bash.bashrc and named it bash.bashrc.local
    >
    > when I restarted my konsole all I got was a blank line. my prompt did
    > not show user@desktop $ anymore and any thing that I type goes through
    > without any reaction from the command line.
    >
    > typing ls results in cursor moving to next line and nothing happens.
    >
    > After I rebooted the machine and tried to log in the screen goes black
    > and I see a cursor.
    >
    > I've tried GNOME, KDE3, KDE4, IceWM, and all failesafe modes with the
    > same results. Loggin into the command line will allow me to log in and
    > then I get no command prompt and no response from the pc.
    >
    > I know it's working becuase my virtual windows machine on it is running
    > and I can remote into it.
    >
    > Anybody have any how I can get back in and delete the bash.bashrc.local
    > file when nothing seems to be working?


    In addition to the other suggestions, I might even boot into single user
    mode since the bash.bashrc script is probably run by the root user login
    as well. IIRC, single user mode will bypass that.

    Jim

    --
    Jim Henderson
    openSUSE Forums Moderator

  7. #7
    platinum NNTP User

    Default Re: Black Screen no Command Prompt



    > -type mv bash.bashrc.local bashrc.bashrc local.bad-idea hit enter


    ERROR in that line!! it should be

    -type mv bash.bashrc.local bashrc.bashrc.local.bad-idea hit enter

    --
    platinum
    no matter who you get advice from: THINK and do not blindly follow!!

  8. #8
    rashid1985 NNTP User

    Default Re: Black Screen no Command Prompt

    Thanks all seems to be working so far. I will update as soon as possible.

  9. #9
    rashid1985 NNTP User

    Default Re: Black Screen no Command Prompt

    Quote Originally Posted by platinum View Post
    -boot
    -at first screen select Fail Safe, press enter
    -when the command line comes
    --type root hit enter
    --type [root's password] hit enter
    -type cd /etc hit enter
    -type mv bash.bashrc.local bashrc.bashrc local.bad-idea hit enter
    -type exit hit enter
    -type startx hit enter
    -log in as yourself
    -boot | ok
    -at first screen select failsafe, press enter | ok
    --type root hit enter | ok
    --type [root's password] hit enter | ok
    System Message:
    You have new mail
    Have a lot of fun!
    # From here on is what happens
    cd /etc
    #no response returns to the beginning of the line
    mv bash.bashrc.local bashrc.bashrc local.bad-idea
    #no response returns to the beginning of the line
    exit
    #no response returns to the beginning of the line
    startx
    #no response returns to the beginning of the line

    BTW I have Xen - OpenSUSE 11
    My operating system selection has 4 choices

    Xen - OpenSUSE 11
    OpenSUSE 11
    Xen - OpenSUSE 11 Failsafe
    Floppy Disk

    #on the bottom I have two lines
    Boot Options (different for each selection)
    More Oprtions (different for each selection)

    where do I select single user mode or type 3?
    I need something that'll boot me to a working command line so I can move or delete the file.

  10. #10
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,145

    Default Re: Black Screen no Command Prompt

    On Thu, 24 Sep 2009 00:26:01 +0000, rashid1985 wrote:

    > where do I select single user mode or type 3


    In the grub menu, move the cursor down to the line with the options and
    put in "s" or "single" to get to single user mode; put "3" on the line to
    go to runlevel 3 (console only).

    Single user mode will ask just for the root password; you can't login as
    another user.

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •