Results 1 to 9 of 9

Thread: Can't install new software ( error ).

  1. #1

    Thumbs down Can't install new software ( error ).

    What I'm doing wrong ?

    Here's an example:
    Code:
    linux-m3s7:~ # zypper install emerald
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW packages are going to be installed:
      compiz-emerald libwnck libwnck-1-22
    
    
    Overall download size: 449.0 K. After the operation, additional 1.5 M will be used.
    Continue? [YES/no]: y
    Retrieving package libwnck-2.24.1-1.16.i586 (1/3), 80.0 K (269.0 K unpacked)
    Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)
    
    Abort, retry, ignore? [A/r/i]: r
    Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)
    UPDATE :: Apearantly, software sources contained my installation DVD - removed & everything works just fine.

  2. #2
    platinum NNTP User

    Default Re: Can't install new software ( error ).

    > Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)

    seems the only repository you have enabled is the CD...which is not in
    the drive..

    were you connected to the internet when you got that output? i ask
    because i would have expected it to find the program you searched for
    online..do you have the "standard four" repos enabled?

    read about those in post #5 in the most excellent new-guy info digest,
    here: http://tinyurl.com/6jwtg9

    in there you will also find several links you will need to read...like
    the one to openSUSE concepts which will fill you in on adding software..

    by the way: -welcome-

    --
    platinum

  3. #3

    Default Re: Can't install new software ( error ).

    Quote Originally Posted by platinum View Post
    > Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)

    seems the only repository you have enabled is the CD...which is not in
    the drive..

    were you connected to the internet when you got that output? i ask
    because i would have expected it to find the program you searched for
    online..do you have the "standard four" repos enabled?

    read about those in post #5 in the most excellent new-guy info digest,
    here: NEWBIES - Suse-11.1 Pre-installation PLEASE READ - openSUSE Forums

    in there you will also find several links you will need to read...like
    the one to openSUSE concepts which will fill you in on adding software..

    by the way: -welcome-

    --
    platinum
    Actually, I had a few more repositories enabled, tough, as far as I understand, due to priority settings, it didn't went any further than my DVD ( which obviously was laying on my desk ).
    Problem solved by disabling it ( I prefer installing software from repositories, instead of an 'unknown' DVD ).

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Can't install new software ( error ).

    an 'unknown' DVD
    Worrying! How is it so?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Can't install new software ( error ).

    Well if you have net connection then you should be able to access packages, but why are you using command line to install packages?
    For new users its advised not to use commandline unless its 100% needed, use tools such as YAST which are easy to find and use.

  6. #6

    Default Re: Can't install new software ( error ).

    Quote Originally Posted by caf4926 View Post
    Worrying! How is it so?
    I don't remember myself burning it, so .. for me, it's an 'unknown' DVD. Indeed, why would I be worried about it - installation went smoothly and everything works like a charm ( way too easier than it was on Fedora )

  7. #7

    Default Re: Can't install new software ( error ).

    Quote Originally Posted by TaraIkeda View Post
    Well if you have net connection then you should be able to access packages, but why are you using command line to install packages?
    For new users its advised not to use commandline unless its 100% needed, use tools such as YAST which are easy to find and use.
    Let's clear it up .. I've been using Linux, especially, Ubuntu, for the past 2 years. Personally, it's easier to install software from command line, rather than using a GUI based package management software.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Can't install new software ( error ).

    Get familiar with:
    Zypper/Usage/11.1 - openSUSE
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Can't install new software ( error ).

    Quote Originally Posted by caf4926 View Post
    Get familiar with:
    Zypper/Usage/11.1 - openSUSE
    Thank you - that's probably all I need for now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •