Results 1 to 10 of 10

Thread: Solving PackageKit error

  1. #1

    Default Solving PackageKit error

    Running suse 11.1 (Linux 2.6.27.29-0.1-trace x86_64) with 4.3.1 (KDE 4.3.1) "release 165"

    When running zypper dup or using Yast (package -> All Packages -> update if newer) to do updates I get

    "Problem: nothing provides PackageKit >= 0.5.1 needed by kupdateapplet-packagekit
    -0.9.0-3.1.x86_64
    Solution 1: keep kupdateapplet-packagekit-0.8.42-2.4.x86_64"

    Have had Firefox crash on me a lot lately and log me out. Not encountered any other problems updating since switching to KDE 4.3
    *think* this has something to do with the repos? Usually good at figuring this stuff out on my own but having trouble with this one.

    Have tried:
    zypper ref
    zypper up (worked to update most packages but still get error above)
    rpm -vv --rebuilddb




    My zypper lr output
    # | Alias | Name | Enabled | Refresh
    ---+-----------------------------------------------------------------------------+-----------------------------------------------------------------------------+---------+------
    --
    1 | COMMUNITY_KDE_4.2_Suse_11.1 | COMMUNITY KDE 4.2 Suse 11.1 | No | Yes

    2 | DESKTOP_KDE_4.2_Suse_11.1 | DESKTOP KDE 4.2 Suse 11.1 | No | Yes

    3 | KDE_4.2_Extra_Apps_#1_4.3_disabled | KDE 4.2 Extra Apps #1 4.3 disabled | No | No

    4 | KDE_4.2_Factory_4.3_Disabled | KDE 4.2 Factory #4.3 Disabled | No | No

    5 | KDE_4.3_COmmunity | KDE 4.3 COmmunity | Yes | Yes

    6 | KDE_4.3_Factory_Desktop | KDE 4.3 Factory Desktop | Yes | Yes

    7 | Main Update Repository | Main Update Repository | Yes | Yes

    8 | NVIDIA Repository | NVIDIA Repository | Yes | Yes
    9 | devel:tools:building | devel:tools:building | Yes | Yes
    10 | factory_desktop_#4.3_Disabled | factory desktop #4.3 Disabled | No | No
    11 | home:thomas-schraitle | home:thomas-schraitle | No | Yes
    12 | Index of /repositories/home:/Monex:/stable/openSUSE_11.1 | Index of /repositories/home:/Monex:/stable/openSUSE_11.1 | Yes | Yes
    13 | iplist_1 | iplist | Yes | Yes
    14 | mozilla | mozilla | Yes | Yes
    15 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
    16 | openSUSE:11.1 | openSUSE:11.1 | Yes | Yes
    17 | qt | qt | No | No

    Any help is Much appreciated.
    18 | qt45 | qt45 | No | No
    19 | repo | Packman Repository | Yes | Yes
    20 | repo-debug | openSUSE-11.1-Debug | No | Yes
    21 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
    22 | repo-source | openSUSE-11.1-Source | No | Yes
    23 | repo-update | openSUSE-11.1-Update | Yes | Yes
    24 | repo_1 | VideoLan Repository | No | No
    25 | repo_2 | openSUSE BuildService - Drivers for webcams | Yes | Yes

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Solving PackageKit error

    All those repos!!:

    Lets get sense from it and open a terminal and post:
    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Solving PackageKit error

    Here are the results.

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-----------------------------------------------------------------------------+-----------------------------------------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------------------------+--------
    1 | COMMUNITY_KDE_4.2_Suse_11.1 | COMMUNITY KDE 4.2 Suse 11.1 | No | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42 |
    2 | DESKTOP_KDE_4.2_Suse_11.1 | DESKTOP KDE 4.2 Suse 11.1 | No | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
    3 | KDE_4.2_Extra_Apps_#1_4.3_disabled | KDE 4.2 Extra Apps #1 4.3 disabled | No | No | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.1/ |
    4 | KDE_4.2_Factory_4.3_Disabled | KDE 4.2 Factory #4.3 Disabled | No | No | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    5 | KDE_4.3_COmmunity | KDE 4.3 COmmunity | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop |
    6 | KDE_4.3_Factory_Desktop | KDE 4.3 Factory Desktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    7 | Main Update Repository | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    8 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    9 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
    10 | factory_desktop_#4.3_Disabled | factory desktop #4.3 Disabled | No | No | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop |
    11 | home:thomas-schraitle | home:thomas-schraitle | No | Yes | 99 | rpm-md | Index of /repositories/home:/thomas-schraitle/openSUSE_11.1 |
    12 | Index of /repositories/home:/Monex:/stable/openSUSE_11.1 | Index of /repositories/home:/Monex:/stable/openSUSE_11.1 | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/Monex:/stable/openSUSE_11.1 |
    13 | iplist_1 | iplist | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/uljanow/openSUSE_11.1 |
    14 | mozilla | mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    15 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0,/dev/sr1 |
    16 | openSUSE:11.1 | openSUSE:11.1 | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/oss |
    17 | qt | qt | No | No | 99 | rpm-md | Index of /repositories/KDE:/Qt/openSUSE_11.1 |
    18 | qt45 | qt45 | No | No | 99 | rpm-md | Index of /repositories/KDE:/Qt45/openSUSE_11.1 |
    19 | repo | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    20 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    21 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/non-oss |
    22 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    23 | repo-update | openSUSE-11.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    24 | repo_1 | VideoLan Repository | No | No | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    25 | repo_2 | openSUSE BuildService - Drivers for webcams | Yes | Yes | 99 | rpm-md | Index of /repositories/drivers:/webcam/openSUSE_11.1 |
    26 | zoneminder | zoneminder | No | Yes | 99 | rpm-md | Index of /pub/suse/repositories/11.1 |

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Solving PackageKit error

    Before I make recommendation with the repos. May I ask: What version of kde do you want 4.2 or 4.3?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Solving PackageKit error

    Keep the following: For kde4.3
    As it looks like that is what you wanted. Remove all the others.

    5 | KDE_4.3_COmmunity | KDE 4.3 COmmunity | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop |
    6 | KDE_4.3_Factory_Desktop | KDE 4.3 Factory Desktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    7 | Main Update Repository | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    8 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    14 | mozilla | mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    16 | openSUSE:11.1 | openSUSE:11.1 | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/oss |
    19 | repo | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    21 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/non-oss |
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Solving PackageKit error

    Once you have the above, run a system wide unconditional update. You'll have some conflicts to work through. if you can't figure it out, use the expert button to save it to file and then post it here.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Solving PackageKit error

    Thank You for the help. Greatly appreciated. Will run through first chance I get.

  8. #8

    Default Re: Solving PackageKit error

    Started updating on Monday via yast. Did an update unconditionally. Left only the previous listed repos for kde 4.3 enabled. Disabled and removed refresh on all the rest. Yast tells me I have 4.75 GB to download. It was hanging saying the package wasn't found and would have to do a retry to get it to download. ( not sure what is causing the network problems only running yast and occasionally Hulu while waiting, no other resources taking up network. )
    First time the update exited and thought it was done (was almost completed last time I checked) . Went to do a second update to see how to manually fix the errors I had on the first try and Yast has the 4.75 to download again. So am trying again.

    Had some errors that I'm not sure on the first time. Say 98% was downloaded. Got Bad checksum on :
    (* Should I just accept these the second time around ? )
    PythonQT
    QT4-qtscript
    Libqt kde
    lib QT webkit

    Got package not found:
    KGPG
    kdf
    kdessh
    kde4-printer
    kcalc
    ark

    Skipped them after retrying a few times in hopes of manually finding the problem and downloading the correct version before restarting.

    Am I doing this correctly ? or is there a better way that you would suggest.
    Thank you for your help

  9. #9

    Default Re: Solving PackageKit error

    Did some more research, sorry about the previous post.

    I ran through the update a second time using yast and update unconditionally. At 50% have got 9 bad checksum messages for libQT4.5.

    Did a little searching around the forum and I think the fix is to add this repo
    Index of /repositories/KDE:/Qt/openSUSE_Factory

    There are 2 more listed in yast for QT4 repos on my computer
    Index of /repositories/KDE:/Qt45/openSUSE_11.1
    &
    Index of /repositories/KDE:/Qt/openSUSE_11.1

    Which one will fix the bad checksum errors?
    What priority is best 99 or 120 for it?

  10. #10

    Default Re: Solving PackageKit error

    Been looking into this some more.
    enabled the repo:
    Index of /repositories/KDE:/Qt45/openSUSE_11.1

    and got the following errors when clicking on unconditional update
    #### YaST2 conflicts list - generated 2009-09-29 19:49:55 ####

    amarok-libvisual-1.4.10-103.pm.107.18.x86_64 requires amarok = 1.4.10-103.pm.107.18, but this requirement cannot be provided
    uninstallable providers: amarok-1.4.10-103.pm.107.18.i586[repo]
    amarok-1.4.10-103.pm.107.18.x86_64[repo]
    [ ] do not install amarok-libvisual-1.4.10-103.pm.107.18.x86_64

    [x] do not install amarok-2.1.1-35.1.x86_64

    [ ] Ignore some dependencies of amarok-libvisual



    qt4-qtscript-0.1.0-6.11.x86_64 requires libqt4 = 4.5.2, but this requirement cannot be provided

    [ ] Following actions will be done:
    do not install qt4-qtscript-0.1.0-6.11.x86_64
    downgrade of qt4-qtscript-0.1.0-6.11.x86_64 to qt4-qtscript-0.1.0-4.68.x86_64
    [ ] Following actions will be done:
    do not install libqt4-4.5.2+4.5.20090929-1.1.x86_64
    do not install libqt4-x11-4.5.2+4.5.20090929-1.1.x86_64
    do not install libqca2-2.0.2-8.56.x86_64
    do not install libqt4-sql-4.5.2+4.5.20090929-1.1.x86_64
    do not install libqt4-qt3support-4.5.2+4.5.20090929-1.1.x86_64
    do not install libQtWebKit4-4.5.2+4.5.20090929-2.1.x86_64
    do not install libqt4-sql-sqlite-4.5.2+4.5.20090929-1.1.x86_64
    do not install libqt4-sql-mysql-4.5.2+4.5.20090929-2.1.x86_64
    [ ] Ignore some dependencies of qt4-qtscript

    #### YaST2 conflicts list END ###

    Been very happy with suse and really don't want to frag my system. Did once before and it was a great learning experience. Was very impressed on how easy it was to recover/update from the command line, something that is somewhat lacking in XP.

    Thank you for your help where should I go from here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •