Results 1 to 7 of 7

Thread: openSUSE 11.1 and XOrg

  1. #1

    Default openSUSE 11.1 and XOrg

    Hey guys,

    Running openSUSE 11.1 and latest XOrg with a nVidia GeForce FX 5900xt (one click install). I'm having random freezes, only mouse movement. Any help?

    xorg.conf file:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Mon Mar  2 12:45:55 PST 2009
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-09-20T05:41:29-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen         "Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option         "Clone" "off"
        Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/Speedo"
        FontPath        "/usr/share/fonts/PEX"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "USB-compliant keyboard"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
        Identifier         "Modes[0]"
        ModeLine     "1400x1050" 121 1400 1488 1632 1864 1050 1053 1057 1089 +hsync -vsync
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor[0]"
        VendorName     "WDE"
        ModelName      "L2046NV"
        UseModes       "Modes[0]"
        DisplaySize     408    306
        HorizSync       30.0 - 82.0
        VertRefresh     43.0 - 76.0
        Option         "CalcAlgorithm" "XServerPool"
        Option         "DPMS"
        Option         "PreferredMode" "1400x1050"
    EndSection
    
    Section "Device"
        Identifier     "Device[0]"
        Driver         "nvidia"
        VendorName     "NVidia"
        BoardName      "GeForce FX 5900XT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Device[0]"
        Monitor        "Monitor[0]"
        DefaultDepth    24
        Option         "RenderAccel" "True"
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       15
            Modes      "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 11.1 and XOrg

    What spec have you: RAM etc...
    Did you disable Beagle or delete it?
    What desktop: kde or gnome?

    Have you run top in a terminal to see what might be causing issues. Your xorg looks OK, I think.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: openSUSE 11.1 and XOrg

    CPU: AMD Athlon XP 2500
    RAM: 1GB DDR400
    VGA: 5900XT

    Beagle not disabled.

    Gnome

    Havent touched the xorg.conf.

    X and gnome-terminal are running at the top, seems as though this computer freezes when a lot of apps are running, it just happened as I was typing up a response earlier, and I was running RhythmBox, FF, and couple terminal windows. What do ya think?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 11.1 and XOrg

    I would disable beagle and desktop effects.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: openSUSE 11.1 and XOrg

    Hmm...I'll disable beagle, not sure if I want to do the desktop effects just yet, I'm really starting to like it, lol.

    Is this a hardware limitation or an xorg/gnome issue? I've had this problem when I tried setting my desktop effects to low too.

  6. #6

    Default Re: openSUSE 11.1 and XOrg

    Heres the output for "top" right now (after I removed Beagle):

    Code:
    top - 23:51:36 up 26 min,  2 users,  load average: 0.17, 0.15, 0.13
    Tasks: 123 total,   3 running, 120 sleeping,   0 stopped,   0 zombie
    Cpu(s):  1.2%us,  0.3%sy,  0.0%ni, 97.6%id,  0.9%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:   1032920k total,   630692k used,   402228k free,    24296k buffers
    Swap:  2104472k total,        0k used,  2104472k free,   344428k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
     2187 root      20   0 91516  40m  10m R  0.7  4.0   0:31.00 X                  
     4431 rhys      20   0  238m  65m  23m S  0.2  6.5   0:33.76 firefox            
        1 root      20   0  1008  360  308 S  0.0  0.0   0:01.28 init               
        2 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kthreadd           
        3 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 migration/0        
        4 root      15  -5     0    0    0 S  0.0  0.0   0:00.04 ksoftirqd/0        
        5 root      15  -5     0    0    0 S  0.0  0.0   0:00.26 events/0           
        6 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 khelper            
        7 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kintegrityd/0      
        8 root      15  -5     0    0    0 S  0.0  0.0   0:00.08 kblockd/0          
        9 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid             
       10 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kacpi_notify       
       11 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 cqueue             
       12 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kseriod            
       13 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kondemand/0        
       14 root      20   0     0    0    0 S  0.0  0.0   0:00.04 pdflush            
       15 root      20   0     0    0    0 S  0.0  0.0   0:00.00 pdflush

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 11.1 and XOrg

    That looks OK. See how you get on. Good move on lowering the effects. I'm a kde user. I'm not aware of any significant differences between the two in respect of effects.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •