Results 1 to 7 of 7

Thread: The Pipe Symbol "|" in XRDP?

  1. #1

    Default The Pipe Symbol "|" in XRDP?

    Hi,

    I have read many threads about the problems with keyboard mapping in XRDP. So while I patiently wait for it to be corrected, can anyone suggest a way to "compose" a pipe or backslash character while in an XRDP session?

    The sort of thing I mean is to use the ALT+124 key sequence in Windows apps. which composes the pipe symbol? The only way I can do it at the moment is to open OpenOffice Writer, Insert Special Character and Cut/Paste the pipe symbol as needed.

    Regards,

  2. #2

    Default Re: The Pipe Symbol "|" in XRDP?

    Just a small "prod" to move thing forward...

    In an attempt to work around this problem, I have been trying to substitute the pipe symbol with a command - along these lines ...

    cat /var/log/warn `echo -e "\x7c"` grep ifup
    (running a cmd to output a pipe symbol from its unicode representation)
    as an alternative to ...

    cat /var/log/warn | grep ifup

    So far, without success! Can anyone suggest what I am doing wrong or an alternative strategy?

    Best regards, Martin

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: The Pipe Symbol "|" in XRDP?

    On 01/25/2010 05:56 AM, martinprowe wrote:

    > [B]CAT /VAR/LOG/WARN | GREP IFUP


    In this case, /var/log/warn exists as a file, thus a simple

    grep ifup /var/log/warn

    would do.

    For the case where a file does not exist, then you need to first create a file,
    grep that file, and then delete the temp file. For example to grep the output of
    lsmod for xxxx:

    cat lsmod > tmp_lsmod ; grep xxxx tmp_lsmod ; rm tmp_lsmod


  4. #4

    Default Re: The Pipe Symbol "|" in XRDP?

    Hi (again) iwfinger,

    I'm sorry. I don't think I expressed my problem very well. The task I was trying to achieve was to "compose" a pipe symbol on the command line.

    If I can't input the "|" from the keyboard while in an XRDP session, how can run commands like this:

    {cmd/file} pipe to {cmd/file}?

    While I understand that I can rewrite the cat/grep duo to avoid using the pipe symbol, that was not the objective.

    If you can shed any light on why bash does not evaluate the echo -e "x7c" and provide a | when wanted, that would be illuminating.

    Many, many thanks for you help though, Martin

  5. #5

    Default Re: The Pipe Symbol "|" in XRDP?

    If you have a key you can spare:

    Find what keymap you're using, probably in /usr/share/kbd/keymaps/i386. It's either a text file or a gzipped text file. Modify it to make some key be "Compose". (To find the keycode run showkey in a console [not a console app]). Add "loadkeys [yourfile]" to your .bash_profile (might have to do that with a setuid root script, you might not be able to run loadkeys as user), or the profile for your logon shell. Compose, /, ^ (in seqence) or ^, /, or v, l (for vertical line), or, V, L should make a pipe.

    If you only need it under X, just map something to Compose in you .Xmodmap (these use different keycodes, use xev from a terminal program to find it).

  6. #6

    Default Re: The Pipe Symbol "|" in XRDP?

    Hi David, thanks for the suggestion.

    Quote Originally Posted by david_b_0 View Post
    Find what keymap you're using ...
    As you can see, I'm stumped at the first sentence! How? There are, oh..., dozens of files in and around that area!

    I think I have sorta been using this technique?
    In Konsole, I have edited Settings | Edit Profile | Input | Linux Console | Edit. I then defined the Shift+Space = \x7c.

    That works in Konsole, but it would be nice to get this key mapping system wide? I would be keen to follow your advice, but being a complete numpty, I can't keep up with you.

  7. #7

    Default Re: The Pipe Symbol "|" in XRDP?

    Belay that last posting! I think that this is the info I was looking for?

    Code:
    supermicro:~ # /etc/init.d/kbd restart
    Loading console font lat9w-16.psfu  -m trivial G0:loadable  done
    Loading keymap i386/qwerty/uk.map.gz                        done
    Start Unicode mode                                          done
    supermicro:~ # ߀
    So I tried looking at uk.map.gz. Why can't I open it? Is it locked? Is it not a ziped file?

    Regards, Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •