Results 1 to 4 of 4

Thread: Annoying sounds Click, Click, Buzz - a Virus in the House?

  1. #1
    CosmoM NNTP User

    Default Annoying sounds Click, Click, Buzz - a Virus in the House?

    I really like OpenSuse 11.1 and use it as my main workstation at work. But recently, perhaps after a maintenance update (I can't remember when it started) I am hearing repeated clicks and buzzes.

    When I open up the Application Browser from slug I hear a click. When I open up Firefox I hear several clicks as a web page loads.

    As a video or other media file loads in firefox, it starts with a loud buzz.

    I am willing to go deep and modify the kernel if that is required to solve the problem - It's that annoying.

    Has anyone experienced this problem and have a solution?


    Thanks in advance,


    Cosmo

  2. #2
    CosmoM NNTP User

    Default Re: Annoying sounds Click, Click, Buzz - a Virus in the Hous

    Found a solution that worked via search:

    created an /etc/asound.conf file with the following:

    pcm.pulse {
    type pulse
    }
    ctl.pulse {
    type pulse
    }
    pcm.!default {
    type pulse
    }
    ctl.!default {
    type pulse
    }

  3. #3
    CosmoM NNTP User

    Default Re: Annoying sounds Click, Click, Buzz - a Virus in the Hous

    I spoke too soon. The clicking is back - It clicks during bootup, and launch and load of firefox.

    Cosmo

  4. #4

    Default Re: Annoying sounds Click, Click, Buzz - a Virus in the Hous

    I bet it's the fault of pulseaudio. I had mysterious thuds as I closed a window in Gnome, even after disabling sound effects, and the file starting with a buzz problem too.

    If you know what you're doing, get rid of pulseaudio. I did and I'm happy again.

    0) Read anything and everything by oldcpu about sound problems.
    then
    1) Disable pulseaudio in YaST|Sound
    2) Uninstall pulseaudio and anything that uses it except the libpulse* libraries which some applications insist on having (but don't need to use).
    3) See my thread on this forum "Pulseaudio must die!" about annoying enviroment variables that break MPlayer.
    4) Preferably outside of Gnome, on the command-line-only-no-windows Linux console, use YaST to setup your sound card again and check that the "trumpets" test sound works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •