Results 1 to 7 of 7

Thread: Screen resolution

  1. #1

    Default Screen resolution

    I am running SUSE 11.1 64 bit

    My SaX2 XII configuration in Yast shows the Card as an Intel G33 with LCD 1280 x 1024 monitor @ 60 Hz (The monitor is an I- inc CY199D 19")
    The Resolution is shown as 1280x1024 SXGA with 24 bit colours.

    This is the way the screen displays in Vista (dual booted) however in SUSE the display is not so clear and in Display system settings - size and orientation - VGA connected is shown together with the size as 1024 x 768 and the only options are disabled or lower resolutions.


    How do I achieve the same screen resolution as is available with Vista ie 1280 x 1024?


    Many thanks in anticipation,

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Screen resolution

    See if the advice in this thread helps. Try selecting a generic LCD monitor of correct resolution first (via YaST), then if that doesn't work for you it may be necessary to set the desired resolution manually.

    If you need further assistance or advice, please post your /etc/X11/xorg.conf file contents.

  3. #3

    Default Re: Screen resolution

    Thanks for that deano

    Tried running the su -c 'init' command in the last post on the thread but this stopped at reaching level three and twice did not progress any further.
    Have also tried the generic LCD monitors with no success, unfortunately though I've been using SUSE / Linux a while I don't know the ins and outs of the terminal too well.

    However I have included the .etc/X11/xorg file below.

    One other peice of info with UBUNTU running the same machine the screen resolution was 1100 and something x 867, not quite what it should be but clearer than SUSE.

    Hope this means something to you

    Mant thanks for your your help.

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-09-22T01:43:42+0100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Disable "dri"
    Load "extmod"
    Load "glx"
    Load "freetype"
    Load "dbe"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "gb"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "8"
    Option "Device" "/dev/input/mice"
    Option "Name" "TrackMan Optical"
    Option "Protocol" "ExplorerPS/2"
    Option "Vendor" "Logitech"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    DisplaySize 375 300
    HorizSync 31-70
    Identifier "Monitor[0]"
    ModelName "1280X1024@75HZ"
    Option "PreferredMode" "1280x1024"
    VendorName "--> VESA"
    VertRefresh 50-75
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 16
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 2048 1200
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 2048 1200
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 2048 1200
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 2048 1200
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "G33"
    Driver "intel"
    Identifier "Device[0]"
    Option "XaaNoMono8x8PatternFillTrap"
    Option "XaaNoCPUToScreenColorExpandFill"
    Option "XaaNoMono8x8PatternFillRect"
    Option "XaaNoDashedBresenhamLine"
    Option "XaaNoSolidTwoPointLine"
    Option "XVideo"
    Option "XaaNoScanlineImageWriteRect"
    Option "XaaNoScanlineCPUToScreenColorExpandFill"
    Option "XaaNoColor8x8PatternFillTrap"
    Option "XaaNoColor8x8PatternFillRect"
    Option "PageFlip"
    Option "XaaNoSolidHorVertLine"
    Option "XaaNoSolidBresenhamLine"
    Option "XaaNoImageWriteRect"
    Option "XaaNoDashedTwoPointLine"
    Option "XaaNoScreenToScreenColorExpandFill"
    Option "XaaNoScreenToScreenCopy"
    Option "XaaNoSolidFillTrap"
    Option "XaaNoPixmapCache"
    Option "XaaNoOffscreenPixmaps"
    Option "XaaNoSolidFillRect"
    Screen 0
    VendorName "Intel"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection

  4. #4

    Default Re: Screen resolution

    Has anyone got any more advice on this one please.

    Its strange that Windows and Ubuntu can both do a better job of the graphics, surely Intel chips aren't that difficult to set up with SUSE ??

    Many thanks

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Screen resolution

    Its strange that Windows and Ubuntu can both do a better job of the graphics, surely Intel chips aren't that difficult to set up with SUSE ??
    Intel drivers and hardware have been problematic to some extent with all linux distros, depending on the versions concerned. Based on others experiences (search this forum), openSUSE 11 Xorg/intel drivers seemed less troublesome than openSUSE 11.1 for example.

    This command will show what display modes are available including current display mode:

    xrandr -q
    In particular, EDID does not always work well with X, so monitor display modes are not always reported correctly. You may need to add a modeline to xorg.conf to coax X into providing the preferred display mode. The gtf command (via terminal) can be used to generate a modeline for 1280x1024@75Hz:

    linux:/home/dean # gtf 1280 1024 75

    # 1280x1024 @ 75.00 Hz (GTF) hsync: 80.17 kHz; pclk: 138.54 MHz
    Modeline "1280x1024_75.00" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync
    Now, you need to edit (carefully as root) your xorg.conf with

    kdesu kwrite /etc/X11/xorg.conf (KDE user)

    or

    gnomesu gedit /etc/X11/xorg.conf (Gnome user)

    Find the modes section, and add the required modeline. (Note the description edited to "1280x1024" to match your xorg entries):

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync
    EndSection
    You may also need to disable EDID and DDC (monitor mode detection) by adding the following options to your device section:

    Section "Device"
    BoardName "G33"
    Driver "intel"
    Identifier "Device[0]"
    Option "IgnoreEDID" "on"
    Option "NoDDC" "on"
    .
    .
    EndSection
    When finished, restart your X-server with CTRL-ALT-Backspace, and log back in. See how that goes.

  6. #6

    Default Re: Screen resolution

    Thanks Deano

    However!!!

    Did all as you said including the two options
    as below

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 138.54 1280 1368 1504 1024 1025 1028 1069 -HSync +Vsync
    EndSection

    and

    Option "IgnoreEDID" "on"
    Option "NoDDC" "on"

    and restarted but the X server ? wouldn't start and I received the massage ...

    98 (the number of the line I modified) Modeline VTotal expected
    (EE) problem parsing the config file
    (EE) error parsing the config file

    log at /var/log/xorg.0.log

    This log file is very long but have copied the only EE entry I can find

    (EE) intel(0): [dri] I830CheckDRIAvailable failed: dri not loaded.

    Sorry if a bit disjointed but I have just had my first real experience using bash without the graphics, scary!

    Steve

  7. #7

    Default Re: Screen resolution

    One of my pc has the intel G33 which is the one I'm using right now and work perfectly.

    Just a suggestion:
    1. Did it correctly identified your monitor before? If not, did you saw the monitor model in sax2 or yast2?
    If not on the list try to add it using the monitors cd.

    2. Right now in one of your post it is detecting and using vesa.
    Try to boot again in runlevel 3 (init 3) login as your user and su and try using the command sax2 -r -m 0=intel (note 0 is zero not letter o). When sax2 is done at the next command prompt type init 5 and see if it will give you the gui. If you are fortunate to have the gui go to yast2/sax2 and configure your monitor and try using the procedure in #1.

    3. In yast2/sax2 also it will help if you can supply the specs of your monitor in the appropriate sections, e.g:, refreshrate, x and y screen dimension, etc.
    People who do not break things first will never learn to create anything

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •