Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Final Attempt asking for help

  1. #1

    Default Final Attempt asking for help

    I have finally given up. After some time, I have decided to ask for help. Basically, here is the environment and the problem. I should caveat this all works fine in Windows.

    I have one router, and one access point. I am connecting to the AP. The AP is not a DHCP server. Nor does it provide DNS information. It is only the connection point. The IP for the router is .1 and the WAP is .2. My box is connecting using WPA2. I did obfuscate some of the information in the below content.

    I am using a fresh install of SLED 11. I am also using NET MANAGER. When I boot, and put in the proper information, I get an IP address (.26) and can see the DNS servers (obtained from the router) and the netstat command shows that .1 is the default gateway. So this tells me I am clearly connecting to the WAP (as the below files also indicate). When I take this thing home and connect to my un-protected router directly, access is fine. I can surf all day. But at work, I am not working.

    Below is the out put from the IWCONFIG command:

    wlan0 IEEE 802.11bg ESSID:"WIFI_AP"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:21:29:E4X:F0
    Bit Rate=54 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Power Managementff
    Link Quality=48/100 Signal level:-47 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    And now the output from the IFCONFIG:

    eth0 Link encap:Ethernet HWaddr 00:A01:83:38:67
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:220 Base address:0x8000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:22 errors:0 dropped:0 overruns:0 frame:0
    TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4852 (4.7 Kb) TX bytes:4852 (4.7 Kb)

    wlan0 Link encap:Ethernet HWaddr 00:16:44:18:09:5D
    inet addr:192.168.1.26 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::216:44ff:fe18:95d/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4089 errors:0 dropped:0 overruns:0 frame:0
    TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:394523 (385.2 Kb) TX bytes:13989 (13.6 Kb)

    wmaster0 Link encap:UNSPEC HWaddr 00-16-44-18-09-5D-39-35-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Clearly, the hardware is working (went down this avenue already). I have also tried adding a network route to .2 as the first hop to no avail.

    The PROBLEM: Once I boot up, all networks are unreachable. All pings result in no returned packets.

    I appreciate any help anyone can offer. I am actually trying to move my org to a linux based environment, but can't really take that up without getting my architecture to work. So please help.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Final Attempt asking for help

    You know this is the openSUSE forum? And SLED comes with support and has it's own forum: SUSE Linux Enterprise Desktop (SLED) - NOVELL FORUMS

    Your issue seems to be (sorry if I'm just stating the obvious) related to whatever access control is employed at work. It's not clear to me if Network Manager is actually making the connection or Not. ie; When you select the access point to connect to, does it try but then break off? Are you entering a key/passphrase as requested.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Final Attempt asking for help

    It is connecting. I am prompted for the passphrase, which I provide. It is accepted, and then runs through the connection protocol. I get assigned an IP, and receive gateway data and DNS information (which is not resident on the WAP, but only on the router). So I am connecting on to the WAP. But is there an issue with routing through the wap?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Final Attempt asking for help

    It sounds as if you are describing a remote wireless access point as opposed to one being part of the router, is that correct?
    WAP are normally assigned by MAC address in the router interface, each MAC can connect to a range of defined LAN IP's by DHCP or perhaps better is assign a specific IP to each MAC (address reservation).

    Does that make sense?

    I'm not sure what your problem is, I can't seem to get my head around your circumstances.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Final Attempt asking for help

    I think you are getting close to the circumstances. I apologize if my wording is making it difficult to understand.

    I have a router (with an IP of .1). This router is acting as the DHCP server and provides the DNS information for all connected resources.

    Some distance away from the router (we are a large org) we have a WAP 2000. This has no DHCP server. Nor does it have any DNS configuration. It is just a pass through. The one thing the WAP is providing is encryption (WPA2). So the fact I get an IP and DNS information means I am connecting to the WAP and getting data passed from the router to my PC.

    [router]------------------[WAP2000]+-----------PC1

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Final Attempt asking for help

    For me, with just a router, I access the router directly via the usual web interface. Is it possible for you to access the router this way?

    There is something you could try: Disable IPv6 - openSUSE Forums
    It may help.

    But presumably access via this WAP is possible for others? For yourself with a different PC? If you think you are connecting to the router and you can access the router by a web interface (any pc could do this just to check) you should be able to see a list of connected devices.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Final Attempt asking for help

    Yes, other PCs connect this way (to include mine when I boot windows). When I boot Suse, I get connection information. When I pull information from the config commands, you can see an IP address has been issued. Also, there are other systems connecting via the WAP (Windows and MAC). I can either go wired or wireless; but since this is a laptop, and I want to be able to use Linux and move around, I really need the wireless option.

    Again, when at home connecting straight to a router, works fine. Is there something about using an AP that is not a router?

    Thanks for any assist on this.
    Last edited by caf4926; 22-Sep-2009 at 10:29. Reason: Double Post

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Final Attempt asking for help

    Is there something about using an AP that is not a router?
    I don't know. Never worked in that situation.

    My guess is the WAP should be your main concern here, because (I think) the AP will be configured to the router and if a device can successfully connect to the AP it should have access to the router. I can't imagine the router plays a secondary role in monitoring individual access of devices via the AP.

    Check the NM settings in the Panel: Mine uses WPA2 Personal / Infrastructure
    You need the AP to be the same. (I'm assuming this is where the security is, rather than the router side??)
    Sometimes folks disable security temporarily just to see if the problem is there.
    But as you say you are connecting, it doesn't seem to be that is the issue.

    Did you try the IPv6 thing?

    Can you browse the AP and or the router?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Final Attempt asking for help

    I am going to try the IPV6 turn off as soon as I can. I am using the computer to connect to the internet with Windows

    I can't ping the WAP or the router. All pings result in unreachable hosts. I can ping myself (which doesn't prove much). I have tried changing the route table to add .2 as the default gateway. That did not solve anything.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Final Attempt asking for help

    Code:
    wlan0     Link encap:Ethernet  HWaddr 00:16:44:18:09:5D  
              inet addr:192.168.1.26  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::216:44ff:fe18:95d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:4089 errors:0 dropped:0 overruns:0 frame:0
              TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:394523 (385.2 Kb)  TX bytes:13989 (13.6 Kb)
    Is that LAN IP address reservation or does it change?

    Is this MAC used to set trusted stations and to set address reservation?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •