Results 1 to 10 of 10

Thread: qtconfig fails to configure yast

  1. #1
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default qtconfig fails to configure yast

    Hello this all started when I opened yast though a terminal, some of my colors and fonts got messed up for the gui so I open qtconfig and change them except they don't effect yast at all and I am using the qt version of yast so I don't know what the problem would be. also don't know if this would effect it but qtconfig is not accessible through a terminal, the terminal just hangs I have to get to it through beagle.

  2. #2
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: qtconfig fails to configure yast

    Sorry that was worded absolutely horrible what I meant was after I ran yast through a terminal the colors and look of all qt apps changed, opened up the config and the gui style is oxygen but it's not the same oxygen for kde (menu bars are diferent and highlighted text and loading bars are a very dark blue not the light blue of kde oxygen). also the menu states "Any GUI Style plugins in your plugin path will automatically be added to the list of built-in Qt styles. (See the Library Paths tab for information on adding new plugin paths.)" well there's no Library paths tab in the configuration so how do I go about that? Also one more thing, it states to use KDE Control center for the build palette though I've found that doing that works only on currently opened qt apps as soon as others are opened it's back to the old "qt oxygen" look so any ideas? Thanks

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: qtconfig fails to configure yast

    I don't pretend to have a good understanding of this (so forgive me if I'm missing something here), but I assume you have these packages installed?

    yast2-qt
    yast2-theme-openSUSE-Oxygen

    My desktop theme seems reasonably well integrated...

  4. #4
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: qtconfig fails to configure yast

    yes both of those themes are installed and still what I mentioned before.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: qtconfig fails to configure yast

    Which version of KDE4 are you using? Similar discussion here:

    opensuse 11 + kde 3.5, font size for kde4 apps - openSUSE Forums

  6. #6
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: qtconfig fails to configure yast

    I'm using 4.1.3

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: qtconfig fails to configure yast

    I don't know the definitive answer, but I strongly recommend upgrading to KDE 4.2 or even 4.3 as outlined here:

    KDE/KDE4 - openSUSE

    Howto install KDE 4.2 on openSUSE The Blog is Hot

  8. #8
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: qtconfig fails to configure yast

    I updated but still the same problem (at least the new visuals don't make it look as tacky)

  9. #9
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: qtconfig fails to configure yast

    also I've noticed now I'm required to set up a kwallet account with knetworkmanger any way to bypass this?

  10. #10

    Default Re: qtconfig fails to configure yast

    Just go into desktop settings, somewhere you'll find configuration for the wallet and you can delete it. Don't quite know what you're supposed to do if you use it for something else - maybe delete it, and readd it how you want it...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •