Results 1 to 5 of 5

Thread: question about wireless drivers

  1. #1

    Default question about wireless drivers

    Hello,

    Recently i bought a new laptop from dell (vostro 1320) with wlan chip: broadcom corp BCM4312 802.11b/g.

    I had a run in with the first one where the lan chip was broken, so i just got the replacement.

    Anyways, ive installed win XP (planning on dual booting suse and xp), and the wired and wireless connections work well. I downloaded and and booted from the opensuse 11.1 kde4 livecd, and i cant get either to work. Honestly, i dont know if this kind of thing is supposed to work on the live CD, but i just want to make sure that the hardware is supported. Anyways, the lspci command doesnt seem to be supported in the live cd (so the one way i knew how to look at the hardware isnt available). I am curious if anyone knows if the drivers for the internet are supported for this laptops hardware in opensuse(hope it isnt too new, or something). I know that in ubuntu, it has to use some not-open-source proprietary drivers, but there are no video drivers for this laptop in ubuntu (which suse seems to be handling very nicely).

    Any guidance is greatly appreciated!

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: question about wireless drivers

    korvirlol wrote:

    For that chip you need to use the compat-wireless package with a date
    later than 1 Sep 2009.

  3. #3

    Default Re: question about wireless drivers

    Thank you for the reply, but sorry about my ignorance... ive spent some time researching how to install the compat-wireless package that you mentioned, and this is the closest ive found:

    Download - Linux Wireless (mentioned in another thread made by you).

    Anyways... it says i need a specific kernel version (or better) and kernel headers. If i install opensuse 11.1, will this be compatible with the above specifications? Is there any risk to doing this(i.e worst case scenario is to reformat and start over)?

    I think im reasonably comfortable following the steps on that site but id REALLY appreciate a little bit more help of the steps i need to take. I realize this is a public forum, so i dont mean to sound rude or anything, im just not really an experienced linux user (yet).

  4. #4

    Default Re: question about wireless drivers

    small update.

    Ive been going through the steps in the sticky to try to get the wireless working. here is the results:

    lspci: 0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

    the line matched from lspci -n: 0e:00.0 0280: 14e4:4315 (rev 01)

    i went through dmesg 3 times and couldnt find ANYTHING remotely similar to missing firmware for any device (i think that if the wireless works in windows that the firmware is installed and working, correct me if im wrong here).

    the output of iwconfig:
    lo no wireless extensions.

    eth0 no wireless extensions.

    it doesnt seem to be finding any wireless device...

    iwlist scan:
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    So, im not sure whats happening at this point. I noticed that the next part of that thread is some specific instructions for installing a similar wireless card, so i was following the steps.

    I got to the section about:
    Code:
    SPROM=$(find /sys -name ssb_sprom)
    echo $SPROM
    sudo cat $SPROM > sprom.old
    without any errors, when i echo $SPROM, there is no output, just blank. i tried the 3rd command, but it just hangs and does nothing (probly because $SPROM is blank).
    The little wlan switch is enabled on the PC itself, but the light signifying that the wlan is active is off. I am not sure if this is even remotely related, but i thought i would mention it.

    thanks for any further help.

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: question about wireless drivers

    That card is _NOT_ supported by the driver in anything before 2.6.31,
    thus it will _NOT_ work with your standard kernel!!!

    You need to download and build the compat-wireless sources, switch to
    a 2.6.31 kernel, or install the Broadcom wl package. The first two
    choices will also require installing firmware.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •