Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ALSA from OBS causing hangups

  1. #1

    Default ALSA from OBS causing hangups

    Bon appetit folks,

    I wasn’t entirely sure where to post this, but this section seemed to be the most fitting place. Plus I haven’t reported a bug on this matter yet because I first wanted to find out whether I’m alone with my issue or whether others have observed similar behaviour.

    So this is what I get (or, better, got until about 1 hour ago; read on for reasoning):

    After starting up X any running or newly started (audio) player app would stop responding, even to a signal 9; SMPlayer just keeps running as a process, mpd shows as a defunct process that cannot be removed. Subsequently X doesn’t cleanly shut down, a process for ~/.xsession-errors keeps existing; this can be killed for X to shut down completely. Then, when trying to shut down or reboot the machine, the shutdown process stops after shutting down HAL. Result: I need to hard-reset the machine to continue.

    Now I suspected a problem with one or more of the ALSA packages I had installed from the BuildService, so I downgraded ALSA to system default and the problem disappeared.

    Relevant system specs:

    a) Hardware:
    - AMD Sempron 2800+ @ 2,000 MHz
    - 1,024 MB DDRAM (PC3200)
    - ASUS A7N8X-E Deluxe mainboard
    - nVidia nForce2 sound system (on-board; using snd_intel8x0)
    - TerraTec DMX Xfire 1024 soundcard (PCI; using snd_cs46xx)

    b) Software:
    - openSUSE 11.1
    - ALSA packages from openSUSE BuildServe Multimedia:Audio and Multimedia:Audio:KMP repos (in the meantime uninstalled or resp. replaced by their counterparts from the OSS repo)
    - X.org X Server packages from openSUSE BuildService X11org repo

    My question is now whether there are others using ALSA from OBS experiencing similar problems, so it might be worthwhile to report a bug. Please don’t hesitate to ask for any additional info I could provide to make a case.

    Greetings

    vzduch a.k.a. szal

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: ALSA from OBS causing hangups

    Quote Originally Posted by vzduch View Post
    b) Software:
    - openSUSE 11.1
    - ALSA packages from openSUSE BuildServe Multimedia:Audio and Multimedia:Audio:KMP repos (in the meantime uninstalled or resp. replaced by their counterparts from the OSS repo)
    - X.org X Server packages from openSUSE BuildService X11org repo
    I've never seen such behavior with the OBS packaged rpms. Exactly what rpms did you install ? ie what is the output of
    rpm -qa | grep alsa
    What happens if instead you just restart alsa with a simple:
    su -c 'rcalsasound restart'

  3. #3

    Default Re: ALSA from OBS causing hangups

    Quote Originally Posted by oldcpu View Post
    I've never seen such behavior with the OBS packaged rpms. Exactly what rpms did you install ? ie what is the output of
    rpm -qa | grep alsa
    I reinstalled the OBS pkgs, and the above mentioned behaviour is back. Here’s the package list:

    zalle:~ # rpm -qa | grep -i alsa
    alsa-oss-1.0.17-1.37
    kalsatools-1.5.0-499.130
    alsa-firmware-1.0.17-1.42
    alsa-1.0.18-8.12.1
    alsa-plugins-samplerate-1.0.18-6.12
    alsa-driver-kmp-pae-1.0.21.20090921_2.6.27.29_0.1-1.1
    alsa-utils-1.0.18-6.4
    alsa-plugins-1.0.18-6.12
    alsa-plugins-pulse-1.0.18-6.12


    In addition, here’s my Zypper output when searching for 'alsa':

    zalle:~ # zypper se -s alsa
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    --+----------------------------------+------------+-----------------------------------+--------+---------------------------------------------
    | FA_clalsadrv | package | 1.2.2-0.pm.3 | i586 | Packman Repository
    | FA_clalsadrv | package | 1.1.0-2.111 | i586 | openSUSE-11.1-Oss
    | FA_clalsadrv | srcpackage | 1.2.2-0.pm.3 | noarch | Packman Repository
    | FA_clalsadrv-debuginfo | package | 1.2.2-0.pm.3 | i586 | Packman Repository
    | FA_clalsadrv-debugsource | package | 1.2.2-0.pm.3 | i586 | Packman Repository
    | FA_clalsadrv-devel | package | 1.2.2-0.pm.3 | i586 | Packman Repository
    i | alsa | package | 1.0.18-8.12.1 | i586 | openSUSE-11.1-Update
    v | alsa | package | 1.0.18-8.7 | i586 | openSUSE-11.1-Oss
    v | alsa | package | 1.0.18-8.7 | i586 | openSUSE 11.1-0
    | alsa | srcpackage | 1.0.18-8.12.1 | noarch | openSUSE-11.1-Update
    i | alsa | patch | 1234 | noarch | openSUSE-11.1-Update
    | alsa-devel | package | 1.0.18-8.12.1 | i586 | openSUSE-11.1-Update
    | alsa-devel | package | 1.0.18-8.7 | i586 | openSUSE-11.1-Oss
    | alsa-devel | package | 1.0.18-8.7 | i586 | openSUSE 11.1-0
    | alsa-docs | package | 1.0.18-8.12.1 | i586 | openSUSE-11.1-Update
    | alsa-docs | package | 1.0.18-8.7 | i586 | openSUSE-11.1-Oss
    | alsa-driver-doc | package | 1.0.21.20090921-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp | srcpackage | 1.0.21.20090921-3.1 | noarch | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp | srcpackage | 1.0.21.20090921-1.1 | noarch | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp-debug | package | 1.0.21.20090921_2.6.27.29_0.1-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp-default | package | 1.0.21.20090921_2.6.27.29_0.1-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp-ec2 | package | 1.0.21.20090921_2.6.27.29_0.1-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    i | alsa-driver-kmp-pae | package | 1.0.21.20090921_2.6.27.29_0.1-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp-trace | package | 1.0.21.20090921_2.6.27.29_0.1-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-kmp-vmi | package | 1.0.21.20090921_2.6.27.29_0.1-1.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-doc | package | 1.0.21.20090917-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp | srcpackage | 1.0.21.20090921-3.1 | noarch | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp | srcpackage | 1.0.21.20090917-2.1 | noarch | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp-debug | package | 1.0.21.20090917_2.6.27.29_0.1-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp-default | package | 1.0.21.20090917_2.6.27.29_0.1-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp-ec2 | package | 1.0.21.20090917_2.6.27.29_0.1-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp-pae | package | 1.0.21.20090917_2.6.27.29_0.1-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp-trace | package | 1.0.21.20090917_2.6.27.29_0.1-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    | alsa-driver-unstable-kmp-vmi | package | 1.0.21.20090917_2.6.27.29_0.1-2.1 | i586 | openSUSE BuildService - Multimedia:Audio:KMP
    i | alsa-firmware | package | 1.0.17-1.42 | noarch | openSUSE-11.1-Oss
    i | alsa-firmware | package | 1.0.17-1.42 | noarch | openSUSE 11.1-0
    i | alsa-oss | package | 1.0.17-1.37 | i586 | openSUSE-11.1-Oss
    i | alsa-oss | package | 1.0.17-1.37 | i586 | openSUSE 11.1-0
    i | alsa-plugins | package | 1.0.18-6.12 | i586 | openSUSE-11.1-Oss
    i | alsa-plugins | package | 1.0.18-6.12 | i586 | openSUSE 11.1-0
    | alsa-plugins-jack | package | 1.0.18-6.12 | i586 | openSUSE-11.1-Oss
    | alsa-plugins-maemo | package | 1.0.18-6.12 | i586 | openSUSE-11.1-Oss
    i | alsa-plugins-pulse | package | 1.0.18-6.12 | i586 | openSUSE-11.1-Oss
    i | alsa-plugins-pulse | package | 1.0.18-6.12 | i586 | openSUSE 11.1-0
    i | alsa-plugins-samplerate | package | 1.0.18-6.12 | i586 | openSUSE-11.1-Oss
    | alsa-tools | package | 1.0.18-1.13 | i586 | openSUSE-11.1-Oss
    | alsa-tools | package | 1.0.18-1.13 | i586 | openSUSE 11.1-0
    | alsa-tools-devel | package | 1.0.18-1.13 | i586 | openSUSE-11.1-Oss
    | alsa-tools-gui | package | 1.0.18-1.13 | i586 | openSUSE-11.1-Oss
    i | alsa-utils | package | 1.0.18-6.4 | i586 | openSUSE-11.1-Oss
    i | alsa-utils | package | 1.0.18-6.4 | i586 | openSUSE 11.1-0
    | alsamixergui | package | 0.9.0rc1-584.132 | i586 | openSUSE-11.1-Oss
    | alsaplayer | package | 0.99.80-1.pm.13.6 | i586 | Packman Repository
    | alsaplayer | srcpackage | 0.99.80-1.pm.13.6 | noarch | Packman Repository
    | alsaplayer | srcpackage | 0.99.80-1.pm.13.5 | noarch | Packman Repository
    | balsa | package | 2.4.1-13.3 | i586 | openSUSE BuildService - GNOME:Factory
    | balsa | package | 2.3.26-1.37 | i586 | openSUSE-11.1-Oss
    | balsa | srcpackage | 2.4.1-13.3 | noarch | openSUSE BuildService - GNOME:Factory
    | balsa-debuginfo | package | 2.4.1-13.3 | i586 | openSUSE BuildService - GNOME:Factory
    | balsa-debugsource | package | 2.4.1-13.3 | i586 | openSUSE BuildService - GNOME:Factory
    | balsa-lang | package | 2.4.1-13.3 | i586 | openSUSE BuildService - GNOME:Factory
    | balsa-lang | package | 2.3.26-1.37 | i586 | openSUSE-11.1-Oss
    | bluez-alsa | package | 4.22-6.1.10 | i586 | openSUSE-11.1-Update
    | bluez-alsa | package | 4.22-6.1.1 | i586 | openSUSE-11.1-Update
    | bluez-alsa | package | 4.19-1.5 | i586 | openSUSE-11.1-Oss
    | gmerlin-alsa | package | 0.4.0-0.pm.1 | i586 | Packman Repository
    | gmerlin-alsamixer | package | 0.4.0-0.pm.1 | i586 | Packman Repository
    | java-1_5_0-sun-alsa | package | 1.5.0_update20-0.1.1 | i586 | openSUSE-11.1-Update
    | java-1_5_0-sun-alsa | package | 1.5.0_update19-0.1.1 | i586 | openSUSE-11.1-Update
    | java-1_5_0-sun-alsa | package | 1.5.0_update18-0.1.1 | i586 | openSUSE-11.1-Update
    | java-1_5_0-sun-alsa | package | 1.5.0_update17-1.1 | i586 | openSUSE-11.1-Update
    | java-1_5_0-sun-alsa | package | 1.5.0_update16-21.4 | i586 | openSUSE-11.1-Non-Oss
    | java-1_6_0-sun-alsa | package | 1.6.0.u15-0.1.1 | i586 | openSUSE-11.1-Update
    | java-1_6_0-sun-alsa | package | 1.6.0.u14-0.2.1 | i586 | openSUSE-11.1-Update
    | java-1_6_0-sun-alsa | package | 1.6.0.u13-0.1.1 | i586 | openSUSE-11.1-Update
    | java-1_6_0-sun-alsa | package | 1.6.0.u12-1.2.1 | i586 | openSUSE-11.1-Update
    | java-1_6_0-sun-alsa | package | 1.6.0.u11-1.4.1 | i586 | openSUSE-11.1-Update
    | java-1_6_0-sun-alsa | package | 1.6.0.u11-1.1 | i586 | openSUSE-11.1-Update
    | java-1_6_0-sun-alsa | package | 1.6.0.u7-20.4 | i586 | openSUSE-11.1-Non-Oss
    i | kalsatools | package | 1.5.0-499.130 | i586 | openSUSE-11.1-Oss
    | python-alsaaudio | package | 0.5-0.pm.1 | i586 | Packman Repository
    | python-alsaaudio | srcpackage | 0.5-0.pm.1 | noarch | Packman Repository
    | python-alsaaudio-debuginfo | package | 0.5-0.pm.1 | i586 | Packman Repository
    | python-alsaaudio-debugsource | package | 0.5-0.pm.1 | i586 | Packman Repository
    | tritonus-alsa | package | 0.3.7-3.pm.cvs20090319 | i586 | Packman Repository
    | tsalsa | package | 20080914-0.pm.1 | noarch | Packman Repository
    | tsalsa | srcpackage | 20080914-0.pm.1 | noarch | Packman Repository


    Quote Originally Posted by oldcpu View Post
    What happens if instead you just restart alsa with a simple:
    su -c 'rcalsasound restart'
    When executed while X is running it just sits there and does nothing. There is also no reaction to hitting Ctrl+C.

  4. #4

    Default Re: ALSA from OBS causing hangups

    Quote Originally Posted by vzduch View Post
    When executed while X is running it just sits there and does nothing. There is also no reaction to hitting Ctrl+C.
    As I don’t see a way to edit my own post, I have to put this in as a reply.
    Edit: Strange, now there is an ‘Edit’ button; why wasn’t it there before?

    When trying to shut down X, it hung again; ‘ps aux’ threw out this line, among others:

    szal 15229 0.0 0.0 3024 604 tty6 S+ 09:45 0:00 tee /home/szal/.xsession-errors

    I was able to kill this process, then X terminated, and I was later able to bring X up again. Then I tried ‘rcalsasound restart’ again from a proper root shell, with the same result as posted above.

    Several processes showed being stuck or still appeared to be running → excerpt from ‘ps aux’:

    szal 15335 0.2 0.0 0 0 ? Zl 09:46 0:07 [knotify4] <defunct>
    szal 15389 0.0 2.1 67340 21924 ? D 09:47 0:00 /usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao oss -nokeepaspect -frame
    szal 15390 0.0 0.0 0 0 ? Z 09:47 0:00 [mplayer] <defunct>
    root 15408 0.0 0.1 3212 1444 pts/4 S+ 09:49 0:00 /bin/sh /usr/sbin/rcalsasound restart
    root 15415 0.0 0.1 3140 1080 pts/4 D+ 09:49 0:00 /usr/sbin/alsactl -g -f /etc/asound.state store
    root 15737 0.0 0.1 4664 1992 tty2 Ss 10:10 0:00 -bash
    root 15770 0.0 0.1 3212 1444 tty2 S+ 10:10 0:00 /bin/sh /usr/sbin/rcalsasound restart
    root 15777 0.0 0.1 3140 1080 tty2 D+ 10:10 0:00 /usr/sbin/alsactl -g -f /etc/asound.state store


    I also noticed that, when bringing up X again, the KDE sound system was nowhere to be seen (no ‘speaker’ icon in the tray), and no error message came up asking me whether to permanently forget about recently removed sound devices. Then I wanted to fire up Konqueror to post this, but it took a long time to start up (>1 min), then froze after entering one character in the address line, so I had to kill it. (I’m now posting this using Seamonkey.)

    Please let me know if I can do anything else to troubleshoot this.
    Last edited by vzduch; 22-Sep-2009 at 01:42. Reason: see in the text

  5. #5

    Default Re: ALSA from OBS causing hangups

    As an addendum to my installed pkgs list: I remember previously using an alsa-firmware 1.0.19 SVN package which I dont remember where I got it from. Though I see no difference with this here alsa-firmware 1.0.17.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: ALSA from OBS causing hangups

    Quote Originally Posted by vzduch View Post
    I reinstalled the OBS pkgs, and the above mentioned behaviour is back. Heres the package list:

    zalle:~ # rpm -qa | grep -i alsa
    alsa-oss-1.0.17-1.37
    kalsatools-1.5.0-499.130
    alsa-firmware-1.0.17-1.42
    alsa-1.0.18-8.12.1
    alsa-plugins-samplerate-1.0.18-6.12
    alsa-driver-kmp-pae-1.0.21.20090921_2.6.27.29_0.1-1.1
    alsa-utils-1.0.18-6.4
    alsa-plugins-1.0.18-6.12
    alsa-plugins-pulse-1.0.18-6.12
    IMHO this does not look correct. You have the alsa-driver-kmp-pae with out the other appropriate alsa packages being updated. That is NOT the way one is supposed to update from the OBS and that could explain the weird behaviour you are experiencing.

    There is a guide here explaining how to update from the OBS: Alsa-update - openSUSE

  7. #7

    Default Re: ALSA from OBS causing hangups

    Yes, you might be correct here. Just pulled in the Multimedia:Libs repo and upgraded all packages available from there -- with the notable exception of alsa-plugins-pulse, which requires Pulseaudio to be installed... do I really have to? Edit: Unfortunately, without alsa-plugins-pulse, my sound devices aren’t recognized correctly.

    The reason for me not having had these packages might be that the Multimedia:Libs repo, to my knowledge, didn’t yet exist when I started using ALSA from OBS, or I just overlooked it because the repo’s name isn’t really descriptive.

    Anyway, thank you very much. I’ll reboot and see whether it got any better now.

  8. #8

    Default Re: ALSA from OBS causing hangups

    Just as I suspected... I removed alsa-plugins-pulse in the process, and now my sound devices aren’t recognized correctly: KMix shows a Cirrus Logic CS4294 rev. 5 and a Realtek ALC650F. But only after I started X, because before mpd played fine.

    Admins: If you deem it better you can detach this post from this thread and put it in a new topic.

  9. #9

    Default Re: ALSA from OBS causing hangups

    OK, things didn’t get much better... I resorted to even installing Pulse because the newer version of alsa-plugins-pulse needs it. Now I get system sounds on first startup of X and the sound devices are shown correctly in KMix. But... I still can’t play any audio from player (e.g. mpd); I get the same hangups as before, also when shutting down X and the machine. In addition, YaST hangs at reading volume settings when trying to access the sound settings -- I wanted to re-check the Pulse settings.

    These are the respective pkgs I now have installed:

    szal@zalle:~> rpm -qa | grep -i alsa
    alsa-firmware-1.0.20-2.1
    kalsatools-1.5.0-499.130
    alsa-driver-kmp-pae-1.0.21.20090921_2.6.27.29_0.1-1.1
    alsa-1.0.21-43.1
    alsa-oss-1.0.17-25.11
    alsa-plugins-1.0.21-17.2
    alsa-plugins-samplerate-1.0.21-17.2
    alsa-utils-1.0.21-13.3
    alsa-plugins-pulse-1.0.21-17.2
    szal@zalle:~> rpm -qa | grep -i pulse
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.21-17.2


    What else can I do?

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: ALSA from OBS causing hangups

    Quote Originally Posted by vzduch View Post
    OK, things didn’t get much better... I resorted to even installing Pulse because the newer version of alsa-plugins-pulse needs it. Now I get system sounds on first startup of X and the sound devices are shown correctly in KMix. But... I still can’t play any audio from player (e.g. mpd); I get the same hangups as before, also when shutting down X and the machine. In addition, YaST hangs at reading volume settings when trying to access the sound settings -- I wanted to re-check the Pulse settings.

    These are the respective pkgs I now have installed:

    szal@zalle:~> rpm -qa | grep -i alsa
    alsa-firmware-1.0.20-2.1
    kalsatools-1.5.0-499.130
    alsa-driver-kmp-pae-1.0.21.20090921_2.6.27.29_0.1-1.1
    alsa-1.0.21-43.1
    alsa-oss-1.0.17-25.11
    alsa-plugins-1.0.21-17.2
    alsa-plugins-samplerate-1.0.21-17.2
    alsa-utils-1.0.21-13.3
    alsa-plugins-pulse-1.0.21-17.2
    szal@zalle:~> rpm -qa | grep -i pulse
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.21-17.2


    What else can I do?
    The ONLY way I can check your settings, is IF you give me the output of the script:
    /usr/sbin/alsa-info.sh
    That script is NOT the be-all and end-all, and if there are other things (such as your 11.1 having had pulse removed) that you have done, then that make a big difference in understanding what is happening. I'm now highly suspicious you have tried all sorts of things, and not undone them, making it very difficult to guess what is happening on your PC. ... Hopefully my suspicion is wrong.

    If your system sound works, then your sound probably works, and your problem is likely a codec problem. I hope you don't have many repositories added to your software package manager, as I have lost count of the dozens (yes dozens) of users who added many repositories and then had problems that they could not sort. I always recommend 4 and ONLY 4 repositories, and many users ignore that advice believing it does not apply to them, and they end up in trouble such that no one can bail them out of.

    What is the output of:
    zypper lr -d

    Please read post#5 in this stickie: NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums
    ie ONLY OSS, Non-OSS, Update and Packman. NO OTHERS ! None! Only add others (such as multimedia/obs) briefly and then remove afterward!

    Please also read this guide prepared by caf4926: Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Follow that advice if you can.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •