Results 1 to 8 of 8

Thread: Build Kopete Plugin skype

  1. #1

    Default Build Kopete Plugin skype

    Hi there. I found out a very nice plugin for kopete, but it requires that i have kde 4.3.1, so i want to build from source to a OpenSuSE 11.1 x64. Already download the file from here, decompressed it and followed the README file. But when execute cmake ..
    cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefi
    x` ..
    -- The C compiler identification is GNU
    -- The CXX compiler identification is unknown
    -- Check for working C compiler: /usr/bin/gcc
    -- Check for working C compiler: /usr/bin/gcc -- broken
    CMake Error at /usr/share/cmake/Modules/CMakeTestCCompiler.cmake:32 (MESSAGE):
    The C compiler "/usr/bin/gcc" is not able to compile a simple test program.

    It fails with the following output:

    Change Dir: /tmp/kde4-kopete-protocol-skype-svn936483-1.61/kde4-kopete-protocol-skype-svn936483-1.61.src/kde4-kopete-protocol-skype-svn936483-1.61/skype/build/CMakeFiles/CMakeTmp



    Run Build Command:/usr/bin/gmake "cmTryCompileExec/fast"

    /usr/bin/gmake -f CMakeFiles/cmTryCompileExec.dir/build.make
    CMakeFiles/cmTryCompileExec.dir/build

    gmake[1]: Entering directory
    `/tmp/kde4-kopete-protocol-skype-svn936483-1.61/kde4-kopete-protocol-skype-svn936483-1.61.src/kde4-kopete-protocol-skype-svn936483-1.61/skype/build/CMakeFiles/CMakeTmp'


    /usr/bin/cmake -E cmake_progress_report
    /tmp/kde4-kopete-protocol-skype-svn936483-1.61/kde4-kopete-protocol-skype-svn936483-1.61.src/kde4-kopete-protocol-skype-svn936483-1.61/skype/build/CMakeFiles/CMakeTmp/CMakeFiles
    1

    Building C object CMakeFiles/cmTryCompileExec.dir/testCCompiler.c.o

    /usr/bin/gcc -o CMakeFiles/cmTryCompileExec.dir/testCCompiler.c.o -c
    /tmp/kde4-kopete-protocol-skype-svn936483-1.61/kde4-kopete-protocol-skype-svn936483-1.61.src/kde4-kopete-protocol-skype-svn936483-1.61/skype/build/CMakeFiles/CMakeTmp/testCCompiler.c


    Linking C executable cmTryCompileExec

    /usr/bin/cmake -E cmake_link_script
    CMakeFiles/cmTryCompileExec.dir/link.txt --verbose=1

    /usr/bin/gcc -fPIC CMakeFiles/cmTryCompileExec.dir/testCCompiler.c.o -o
    cmTryCompileExec -rdynamic

    /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld:
    skipping incompatible /usr/lib/libc.so when searching for -lc

    /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld:
    skipping incompatible /usr/lib/libc.a when searching for -lc

    /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld:
    cannot find -lc

    collect2: ld returned 1 exit status

    gmake[1]: Leaving directory
    `/tmp/kde4-kopete-protocol-skype-svn936483-1.61/kde4-kopete-protocol-skype-svn936483-1.61.src/kde4-kopete-protocol-skype-svn936483-1.61/skype/build/CMakeFiles/CMakeTmp'


    gmake[1]: *** [cmTryCompileExec] Error 1

    gmake: *** [cmTryCompileExec/fast] Error 2





    CMake will not be able to correctly generate this project.
    Call Stack (most recent call first):
    CMakeLists.txt:1 (project)


    CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
    CMake Warning (dev) in CMakeLists.txt:
    No cmake_minimum_required command is present. A line of code such as

    cmake_minimum_required(VERSION 2.6)

    should be added at the top of the file. The version specified may be lower
    if you wish to support older CMake versions for this project. For more
    information run "cmake --help-policy CMP0000".
    This warning is for project developers. Use -Wno-dev to suppress it.

    -- Configuring incomplete, errors occurred!
    What should i do?
    Thanks in advance
    AMD64 Powered by

  2. #2

    Default Re: Build Kopete Plugin skype

    Code:
    -- The CXX compiler identification is unknown 
    -- Check for working C compiler: /usr/bin/gcc 
    -- Check for working C compiler: /usr/bin/gcc -- broken
    Looks like you are missing something very basic here.

    You will most likely not only need gcc but also g++.

  3. #3
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Build Kopete Plugin skype

    Where did you find this plugin?

    It's very interesting because Skype is totally closed source and I'm surprised to hear that someone has been able to hack their codecs and actually get it working!

    It would be interesting to see it working .
    HP dv6645, Nvidia 8400m-gs, KDE 4.

  4. #4

    Default Re: Build Kopete Plugin skype

    Code:
    zypper se -s kde4-kopete-protocol-skype
    Loading repository data...
    Reading installed packages...
    
    S | Name                       | Type       | Version        | Arch   | Repository                                                                              
    --+----------------------------+------------+----------------+--------+-----------------------------------------------------------------------------------------
      | kde4-kopete-protocol-skype | package    | svn936483-1.61 | x86_64 | KDE4 community maintained KDE 4.x / Qt 4.x packages (openSUSE_11.1_KDE4_Factory_Desktop)
      | kde4-kopete-protocol-skype | package    | svn936483-1.61 | i586   | KDE4 community maintained KDE 4.x / Qt 4.x packages (openSUSE_11.1_KDE4_Factory_Desktop)
      | kde4-kopete-protocol-skype | srcpackage | svn936483-1.61 | noarch | KDE4 community maintained KDE 4.x / Qt 4.x packages (openSUSE_11.1_KDE4_Factory_Desktop)
    Which makes the first post a little senseless:

    a) Why building it yourself when ready made packages exist?

    b) Why building it yourself by uncompressing the src.rpm instead of trying to _rebuild_ it?

    Maybe that was both just too easy, and linux _must_ be complicated, otherwise it is not "the real thing".

    :-)

  5. #5

    Default Re: Build Kopete Plugin skype

    Quote Originally Posted by AndreAPL View Post
    Hi there. I found out a very nice plugin for kopete, but it requires that i have kde 4.3.1
    I don't think so:

    Webpin - kde4-kopete-protocol-skype

    And if you really want to have that plugin and don't have KDE >= 4.2.4, then updating KDE4 would be the best way.

  6. #6
    Join Date
    Apr 2009
    Location
    Stuttgart, Germany
    Posts
    114

    Default Re: Build Kopete Plugin skype

    Quote Originally Posted by growbag View Post
    Where did you find this plugin?

    It's very interesting because Skype is totally closed source and I'm surprised to hear that someone has been able to hack their codecs and actually get it working!

    It would be interesting to see it working .
    It's not a hack. AFAIK the kopete plugin requires you to have skype running, and communicates with it using dbus.

  7. #7
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Build Kopete Plugin skype

    Yeah, after reading Alhoehl's post I searched in Yast, and it's just a wrapper!

    I was interested because I thought someone had managed to hack the whole thing .
    HP dv6645, Nvidia 8400m-gs, KDE 4.

  8. #8

    Default Re: Build Kopete Plugin skype

    Hi there.
    Yes, it's a wrapper and integrates contacts from skype in Kopete.

    Now, the suggesting for a single program upgrading a whole system (4.2.x)+, no thanks. I had opensuse + kde4.2 repo, and some bugs made me got back to "original" kde 4.1.x...

    Akoellh, as you will see, that build requires kde4.2.x +, i've already seen that. But still so, rebuild can be done?

    Haven't having many spare time, will try.
    AMD64 Powered by

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •