Results 1 to 8 of 8

Thread: how to deactivate system logging?

  1. #1

    Default how to deactivate system logging?

    My system is flooded sometimes with a lot of these messages:

    Code:
    [  511.855350] CPU1: Temperature above threshold, cpu clock throttled (total events = 50517)
    [  511.856133] CPU1: Temperature/speed normal
    I think that the flooding itself is the cause for the rise of the temperature. My theory is that goes like this:

    temperature high -> message is written on the screen -> cpu clock throttles -> temperature slightly below the threshold -> message is written to disk -> temperature rises again -> loop forever


    The flooding is so extreme that sometimes prevents the boot process (actually only delays it considerably and computer gets hot as hell, but my patience is not limitless and I have to power off the comp).

    The file /var/log/messages sometimes gets up to 46MB in size.



    So, to test my theory...
    • how can I make the kernel not to output these messages to the screen?
    • how can I make these messages not to write in /var/log/messages?


    Note: booting with "noacpi" or "acpi=off" or the openSuSE failsafe option doesn't work.



    PS: When this happens, the only solution I know so far is to let the comp cool or boot Windows, which doesn't have this problem.

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: how to deactivate system logging?

    the kernel message is there for a good reason and it seems intead of you trying to fix the real problem of severe heating that can damage your CPU, you want to ignore it and continue use it which honestly is (a bit) silly

    To disable logging: Disable logging to console

    Note, I will not assist if you disable and ignore the warnings, then your system gets damaged at some point and you come back crying for help or blame it on Linux

  3. #3

    Default Re: how to deactivate system logging?

    Are you using lm_sensors? I used to, until one day my machine started shutting down immediately after booting. Having the system log saved the day. It told me that the CPU temp was 122 degrees C (which is crazy). I did some Googling, and found out that my mobo chipset had issues with lm_sensors, so disabled it, no more annoying messages.

    Try disabling lm_sensors. Don't ever disable /var/log/messages.

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: how to deactivate system logging?

    Quote Originally Posted by KJ44 View Post
    Are you using lm_sensors? I used to, until one day my machine started shutting down immediately after booting. Having the system log saved the day. It told me that the CPU temp was 122 degrees C (which is crazy). I did some Googling, and found out that my mobo chipset had issues with lm_sensors, so disabled it, no more annoying messages.

    Try disabling lm_sensors. Don't ever disable /var/log/messages.
    What were those "issues" that the chipset would have with lm-sensors? Keep in mind that sometimes sensor chips need to be tweaked in lm-sensors configuration in order to report correct values. For example, on one of my older mobos with an on-board IT8705F sensor chip, lm-sensors assumed and was configured to use thermistors to measure the temperature while it actuality had to use thermal diodes, resulting in bogus high temperature reporting so I had to modify the config in order to fix it.

  5. #5

    Default Re: how to deactivate system logging?

    No, I'm not using lm_sensors at all.


    The annoying part is that when the computer gets crazy and begins to output thousands of these messages, powertop reports a lot of "sata_via" interrupts and the hard disk led blinks constantly.
    So the kernel logging is actually making things worse.

    I don't need thousands (>46MB) of these kernel messages to know when my comp heats. One is enough. And usually I know when the temperature rises just by hearing the fan spinning fast.


    It never happened on previous kernel versions (the ones that I tried) and never happened on Windows.


    And if you just read the messages it's really very silly:
    • first temperature rises
    • then instantly decreases
    • then rises again instantly
    • then decreases again instantly


    repeat a thousand times



    This is my dmesg now:
    Code:
    [ 7691.655076] CPU1: Temperature above threshold, cpu clock throttled (total events = 108702)
    [ 7691.655865] CPU1: Temperature/speed normal
    total events = 108702, this is crazy!

    And why only CPU1 and not CPU0 ?

  6. #6
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: how to deactivate system logging?

    this could be a bug somewhere but I'm not really sure. Wrt HD spinning a lot, are you sure you don't have a crawler installed? Like beagle or some such?

  7. #7

    Default Re: how to deactivate system logging?

    No.
    When this happens I don't see any program using the CPU above 1%.
    And it also happens on boot, just after "doing fast boot" message.
    Last edited by Cymerio; 20-Sep-2009 at 12:45. Reason: before->after

  8. #8
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: how to deactivate system logging?

    well, the only thing i can think of is to just disable logging to console and maybe even the acpid daemon in YaST -> System -> Services, which I won't recommend...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •