Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: sis191 not working

  1. #1

    Unhappy sis191 not working

    Having installed Suse 11.1 amd64, everything went well. The only problem is, the eth0 is not working, however, it is being recognized !! When i try to ping another pc, the error is network unreachable In the network setup, the MAC is recognized, everything looks fine. The router has been adjusted to accept the gigabyte Ethernet card. If i use Windowzz OS, it works fine. Any help greatly appreciated

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: sis191 not working

    Hello SteffJay and welcome to the forum

    "Not working" makes it difficult to debug your problem. We need some information, to guess what went wrong. Can you please post the output of the following commands entered in a console (su to root first):

    Code:
    prompt> ifconfig
    
    prompt> route -n
    
    prompt> lspci -nn | grep Ethernet
    
    prompt> lsmod | grep sis

  3. #3

    Unhappy Re: sis191 not working

    Hello Vodoo. Thank you very much for your speedy reply. Ok,

    response from = ipconfig: bash: ipconfig: command not found

    response from route -n = Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth1

    Response from lspci -nn | grep Ethernet = 00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter [1039:0191] (rev 01)

    and response from lsmod | grep sis = sis190 19788 0
    mii 6024 3 asix,usbnet,sis190
    sata_sis 6524 3
    pata_sis 14012 1 sata_sis
    libata 183376 5 ata_generic,pata_marvell,sata_sis,pata_sis,ahci

    I hope this helps

  4. #4
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: sis191 not working

    Hello again

    That was ifconfig (not ipconfig). Can you please try that one again?

  5. #5

    Unhappy Re: sis191 not working

    Ok... Here you go:

    eth0 Link encap:Ethernet HWaddr 00:0A:E4:86:7D:52
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:18 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1685 (1.6 Kb) TX bytes:0 (0.0 b)
    Interrupt:19 Base address:0xdead

    eth1 Link encap:Ethernet HWaddr 00:80:C8:3B:16:90
    inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::280:c8ff:fe3b:1690/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
    RX packets:2761054 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2834341 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:170930538 (163.0 Mb) TX bytes:1530370016 (1459.4 Mb)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:72 errors:0 dropped:0 overruns:0 frame:0
    TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:5048 (4.9 Kb) TX bytes:5048 (4.9 Kb)

    pan0 Link encap:Ethernet HWaddr C6:FC:38:48:FB:08
    inet6 addr: fe80::c4fc:38ff:fe48:fb08/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:532 (532.0 b)

  6. #6
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: sis191 not working

    How strange!

    It appears that you have 2 ethernet cards. eth1 seems to work (is that a sis191 too? ). eth0 is not configured. It has not even been assigned an IP number and there is no routing for eth0. So far eth0 cannot work. What happens when you go to Yast --> Network Devices and configure eth0 ? Are you using DHCP or fixed IP numbers? What's connected to eth0? Is this pointing to the internal or external network?

  7. #7

    Unhappy Re: sis191 not working

    I am having to use a D-Link USB Ethernet device (eth1) to get on the net. However, this is not mine (i borrowed it) LOL. As for Yast / network devices; =

    191 Gigabit Ethernet Adapter (Not connected)
    MAC : 00:0a:e4:86:7d:52
    Device Name: eth0
    Started automatically at boot
    IP address assigned using DHCP

  8. #8
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: sis191 not working

    Got it!

    Your USB Ethernet device is connected to your Modem/Router and gets an IP address via DHCP. As long as eth1 is connected you can't configure eth0 for the same network. I suggest you try the following:

    1. Disconnect eth1 (temporarily) and connect eth0 to the modem/router.

    2. Try to configure eth0 again with yast. There is a slight chance it will work, but probably not. But it's worth a try. If it does not work, then

    3. Reboot with eth0 connected. Then become root in a console and type:

    Code:
    prompt> dmesg | grep -i "00:04.0"
    
    prompt> lspci -nn | grep -i bridge
    
    prompt> uname -r
    
    prompt> modprobe sis190
    4. Save the output of the above commands, re-install eth1 and post what you saw.

    Reason: There have been some bugs in the sis190 driver. We want to see any error messages there might be from the kernel.

  9. #9

    Unhappy Re: sis191 not working

    Hi Vodoo. I tried every which way i could, still no go. Here is the readout you have requested:

    linux-ufm3:/home/server # dmesg | grep -i "00:04.0"

    PCI: 0000:00:04.0 reg 10 32bit mmio: [fbffc000, fbffc07f]
    PCI: 0000:00:04.0 reg 14 io port: [ff00, ff7f]
    pci 0000:00:04.0: supports D1
    pci 0000:00:04.0: supports D2
    pci 0000:00:04.0: PME# supported from D0 D1 D2 D3hot D3cold
    pci 0000:00:04.0: PME# disabled
    sis190 0000:00:04.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    sis190 0000:00:04.0: setting latency timer to 64
    0000:00:04.0: Read MAC address from EEPROM
    0000:00:04.0: Unknown PHY transceiver at address 0.
    0000:00:04.0: Using transceiver at address 1 as default.
    0000:00:04.0: SiS 191 PCI Gigabit Ethernet adapter at ffffc2000033e000 (IRQ: 19), 00:0a:e4:86:7d:52

    linux-ufm3:/home/server # lspci -nn | grep -i bridge

    00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 761/M761 Host [1039:0761] (rev 02)
    00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] SG86C202 [1039:0002]
    00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS966 [MuTIOL Media IO] [1039:0966] (rev 59)
    00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
    00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
    00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
    00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
    00:1f.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:0004]

    linux-ufm3:/home/server # uname -r

    2.6.27.7-9-default

    linux-ufm3:/home/server # modprobe sis190

    (nothing returned)

    I hope this helps....

  10. #10
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: sis191 not working

    Possibly the sis190 driver is (still) broken in kernel 2.6.27.7

    Have a look at these:

    Bug 10994 - sis191 unknown PHY (004d:d021)
    Bug 11073 - SiS 190/191 on ASUS P5SD2-VM dont detect link status / dont send traffic
    http://bugzilla.kernel.org/attachment.cgi?id=16963

    Your kernel (2.6.27.7) has NOT yet the patch required to make it work. The difference between yours and the latest kernel 2.6.27.29 is:

    Code:
    me@host:~> diff sis190.c /usr/src/linux/drivers/net/sis190.c
    319a320
    >       { "Atheros PHY AR8012",   { 0x004d, 0xd020 }, LAN, 0 },
    Probably you have to upgrade your kernel from the update repo and try again. There will still remain a bug that disconnecting the cable is not detected. Sorry, but at this point the end of my wisdom is reached.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •