Results 1 to 2 of 2

Thread: Internal microphone issue (and others)

  1. #1
    Shaikailash NNTP User

    Default Internal microphone issue (and others)

    Hi all, I'm a new user of Opensuse after some years of Kubuntu. In the last month with kubuntu I started to have a problem with my internal microphone, with a low, very low, level of voice recoded. I had to use windows for skype.

    Now the issue is the same on the freshly installed Opensuse 11.1 (KDe4) 64bit. My laptop is a Dell xps M1530.

    A minor issue is that, sometimes, when I listen to music with amarok, if I increase the volume the sound is distorted, as if the output power were too high.

    I post here all the useful information as usually asked.
    Thank you in advance for the help.
    Here the result of the script:

    http://www.alsa-project.org/db/?f=00...6f01bcfa6c115c

    Code:
    rpm -qa | grep alsa
    alsa-utils-1.0.18-6.4
    alsa-plugins-1.0.18-6.13
    alsa-oss-32bit-1.0.17-1.37
    alsa-firmware-1.0.17-1.51
    alsa-plugins-pulse-1.0.18-6.13
    alsa-1.0.18-8.12.1
    alsa-oss-1.0.17-1.43
    Code:
    rpm -qa | grep pulse
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-esound-compat-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    Code:
    rpm -q libasound2
    libasound2-1.0.18-8.12.1
    Code:
    uname -a
    Linux linux 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux
    Code:
    doc@linux:~> cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    # u1Nb._3vRJ7r6oP9:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-3stack (I added this line to try, but nothing changed.)

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Internal microphone issue (and others)

    Quote Originally Posted by Shaikailash View Post
    Hi all, I'm a new user of Opensuse after some years of Kubuntu. In the last month with kubuntu I started to have a problem with my internal microphone, with a low, very low, level of voice recoded. I had to use windows for skype.

    Now the issue is the same on the freshly installed Opensuse 11.1 (KDe4) 64bit. My laptop is a Dell xps M1530.
    Welcome to openSUSE. Nice laptop! I note a 64-bit openSUSE-11.1 with the 2.6.27.29 kernel and running a stac9228.

    Reference using KDE4, note you can add extra channels/controls to your mixer via a menu selection in the application kmix. (the kde4 mixer). Do not forget to do that.

    Some comments on your mixer settings:

    !!Amixer output
    !!-------------
    !!-------Mixer controls for card 0 [Intel]
    Card hw:0 'Intel'/'HDA Intel at 0xf6ffc000 irq 21'
    Mixer name : 'SigmaTel STAC9228'
    Simple mixer control 'Master',0
    Mono: Playback 64 [100%] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Front Left: Playback 255 [100%] [0.00dB]
    Front Right: Playback 255 [100%] [0.00dB]
    Simple mixer control 'Front Mic Jack Mode',0
    Items: 'Mic In' 'Line In'
    Item0: 'Mic In'
    Simple mixer control 'Center',0
    Mono: Playback 64 [100%] [0.00dB] [off]
    Simple mixer control 'LFE',0
    Mono: Playback 64 [100%] [0.00dB] [off]
    Simple mixer control 'Mic Jack Mode',0
    Items: 'Mic In' 'Line In'
    Item0: 'Mic In'
    Simple mixer control 'Capture',0
    Front Left: Capture 14 [100%] [21.00dB] [on]
    Front Right: Capture 14 [100%] [21.00dB] [on]
    Simple mixer control 'Capture',1
    Front Left: Capture 14 [100%] [21.00dB] [off]
    Front Right: Capture 14 [100%] [21.00dB] [off]
    Simple mixer control 'Capture',2
    Capabilities: cvolume cswitch
    Front Left: Capture 14 [100%] [21.00dB] [off]
    Front Right: Capture 14 [100%] [21.00dB] [off]
    Simple mixer control 'Digital',0
    Front Left: Capture 120 [100%] [30.00dB]
    Front Right: Capture 120 [100%] [30.00dB]
    Simple mixer control 'Input Source',0
    Items: 'Mic' 'Front Mic' 'Line' 'Digital Mic 1' 'Digital Mic 2'
    Item0: 'Mic'
    Simple mixer control 'Input Source',1
    Items: 'Mic' 'Front Mic' 'Line' 'Digital Mic 1' 'Digital Mic 2'
    Item0: 'Mic'
    Simple mixer control 'Input Source',2
    Items: 'Mic' 'Front Mic' 'Line' 'Digital Mic 1' 'Digital Mic 2'
    Item0: 'Mic'
    Simple mixer control 'Mux',0
    Front Left: Capture 0 [0%] [0.00dB]
    Front Right: Capture 0 [0%] [0.00dB]
    Simple mixer control 'Mux',1
    Front Left: Capture 0 [0%] [0.00dB]
    Front Right: Capture 0 [0%] [0.00dB]
    Simple mixer control 'Mux',2
    Front Left: Capture 0 [0%] [0.00dB]
    Front Right: Capture 0 [0%] [0.00dB]
    Simple mixer control 'Speaker',0
    Front Left: Playback 64 [100%] [0.00dB] [on]
    Front Right: Playback 64 [100%] [0.00dB] [on]
    Simple mixer control 'Speaker',1
    Front Left: Playback 64 [100%] [0.00dB] [on]
    Front Right: Playback 64 [100%] [0.00dB] [on]
    Simple mixer control 'Speaker',3
    Front Left: Playback 64 [100%] [0.00dB] [on]
    Front Right: Playback 64 [100%] [0.00dB] [on] [off]

    I highlighted in "purple" controls at 100% that may be:
    • too high (in case of PCM, master, speaker) volume controls causing distortion in amarok. Also note the xine sound engine (as packaged by packman) purportedly causes less distortion than the yauap sound engine so you could try switching to xine (assuming you installed the packman packaged amarok, amarok-packman, amarok-xine, and libxine1). And then in amarok select the xine sound engine.
    • too high (in case of capture) can cause distortion in one's mic

    I highlighted in blue settings that may be wrong - I just don't know.

    I highlighted in red mixer settings that have your mic set to what I think might be an external mic and not the internal mic. ... At least that is my understanding based on a different Dell laptop (Studio 1537), where digital mic selection controls the internal microphone. But I could be wrong here.

    So if testing the internal mic, I suspect you may need to select the digital mic.

    If you believe (after a reboot) that adding that model option to the /etc/modprobe.d/sound file does not help, and adds nothing to your laptop's settings, then remove it, as it just adds a complicating factor that is not necessary IF YOU CONFIRMED it not necessary.

    I also noted an update to alsa to fix a sound problem with the stack9228 in 1.0.21 of alsa: Search results - AlsaProject but that may or may not be related to what you are experiencing. Fix your mixer settings first, and then we can look at updating alsa (I can provide help there if necessary).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •