Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Problem with 3D Graphics driver

  1. #1

    Default Problem with 3D Graphics driver

    I recently installed opensuse. I have a 64bit Acer Laptop Model 5535-5452 with Athlon X2 2.1 Ghz, 3gb ram and ATI Radeon HD 3200 Graphics card.

    The problem that I am having is with graphics. I tried to install the graphics driver from ATI repository at opensuse and then initiated SaX2 according to the easy guide. but that completely screwed up my display and I got a blank screen everytime I booted. The only thing that worked was when I downloaded the latest drivers .run file from ATI's own website. IN that case I am able to change my resolution and color depth. I can also view some videos as well but my 3d acceleration is greyed out in the SaX2 window. Whenever I want to enable the desktop effects it says that I have to check my X Configuration. Is there any way to enable the 3D feature and hardware acceleration. please help

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem with 3D Graphics driver

    Please open a terminal and post result of:

    Code:
    cat /etc/X11/xorg.conf
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Problem with 3D Graphics driver

    I got the following response



    # /.../
    # SaX generated X11 config file
    # Created on: 2009-09-19T12:57:27-0500.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "freetype"
    Load "extmod"
    Load "glx"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech USB Optical Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Driver "synaptics"
    Identifier "Mouse[3]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "on"
    Option "HorizScrollDelta" "0"
    Option "InputFashion" "Mouse"
    Option "Name" "Synaptics;Touchpad"
    Option "Protocol" "explorerps/2"
    Option "SHMConfig" "on"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    DisplaySize 344 194
    HorizSync 29-40
    Identifier "Monitor[0]"
    ModelName "Unknown"
    Option "DPMS"
    Option "PreferredMode" "1366x768"
    VendorName "Unknown"
    VertRefresh 48-75
    UseModes "Modes[0]"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1366x768" 69.92 1368 1424 1568 1768 768 769 772 791
    Modeline "1360x768" 69.61 1360 1416 1560 1760 768 769 772 791
    Modeline "1360x768" 58.50 1360 1408 1440 1520 768 771 776 786 +HSync -VSync
    Modeline "1280x768" 65.18 1280 1336 1464 1648 768 769 772 791
    Modeline "1280x768" 55.25 1280 1328 1360 1440 768 771 778 786 +HSync -VSync
    Modeline "1280x720" 64.90 1280 1336 1464 1648 720 721 724 743
    Modeline "1280x720" 55.25 1280 1328 1360 1440 720 723 728 738 +HSync -VSync
    Modeline "1024x768" 51.89 1024 1064 1168 1312 768 769 772 791
    Modeline "1024x768" 45.50 1024 1072 1104 1184 768 771 775 786 +HSync -VSync
    Modeline "1280x600" 65.71 1280 1336 1464 1648 600 601 604 623
    Modeline "1280x600" 56.00 1280 1328 1360 1440 600 603 613 619 +HSync -VSync
    Modeline "1024x600" 52.95 1024 1072 1176 1328 600 601 604 623
    Modeline "1024x600" 46.00 1024 1072 1104 1184 600 603 613 619 +HSync -VSync
    Modeline "800x600" 40.83 800 832 912 1024 600 601 604 623
    Modeline "800x600" 37.25 800 848 880 960 600 603 607 618 +HSync -VSync
    Modeline "768x576" 39.22 768 800 880 992 576 577 580 599
    Modeline "768x576" 35.75 768 816 848 928 576 579 583 594 +HSync -VSync
    Modeline "640x480" 30.72 640 664 728 816 480 481 484 502
    Modeline "640x480" 29.25 640 688 720 800 480 483 487 497 +HSync -VSync
    Modeline "640x480" 28.56 640 664 728 816 480 481 484 500
    Modeline "640x480" 25.95 640 656 720 800 480 481 484 499
    Modeline "1368x768" 69.92 1368 1424 1568 1768 768 769 772 791
    Modeline "640x480" 23.86 640 656 720 800 480 481 484 497
    EndSection

    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Section "Device"
    BoardName "ATI Radeon HD 3200 Graphics"
    Driver "radeonhd"
    Identifier "Device[0]"
    Option "monitor-PANEL" "Monitor[0]"
    VendorName "ATI"
    EndSection

    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem with 3D Graphics driver

    log out. When new login appear switch to the terminal by pressing Ctrl-Alt-F1, login as root user (you know your root password - right), and type:
    Code:
    init 3
    then
    Code:
    SaX2 -r -m 0=fglrx
    then
    reboot
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Problem with 3D Graphics driver

    Here is the output of the the command

    SaX: Initializing please wait
    SaX: Your current configuration will not be read in

    SaX: no x server is running
    SaX: will start own server if needed
    SPP: prepare device [0] profile: fireGL
    SPP: prepare device [0] profile: AIGLIX
    SPP: prepare device [0] profile: Composite
    SPP: prepare device [3] profile: Sunaptics

    SPP: including prepared profile(s)....
    SPP: prepare device [0] profile: nobus
    SPP: including prepared profile(s)....

    SaX: startup

    xc: sorry could not start configuration server
    xc: for details refer to the log file

    /var/log/SaX.log

    xc: abort

    I oped the Sax file. It is too long to paste here. Is there any part in the Sax file you want me to post here.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem with 3D Graphics driver

    Are you getting a display? Able to login?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Problem with 3D Graphics driver

    Everything is file. I am able to change resolution. Change the color depth but my 3D acceleration is disabled so I canot use dektop effects. Is there any way I can post a screep capture of my Sax 2 window?

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem with 3D Graphics driver

    Press print screen
    save as whatever.png
    upload to a site like imagebam

    post the BB code
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Problem with 3D Graphics driver


  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem with 3D Graphics driver

    Quote Originally Posted by umarfateh View Post
    try again mate
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •