Results 1 to 4 of 4

Thread: libssl.so.7

  1. #1

    Default libssl.so.7

    Hello everyone!


    could someone please tell me where to get libssl.so.7?
    It is required by nearly all multimedia applications on openSuse11.1 but "nothing provides libssl.so.7". E.g. I can't install xmms or any other mp3 player.

    On the internet I found some packages for it, but none for openSUSE 11.1, which I am running.

    Your help would be so great as I really want to listen to my music in Linux, too, not just in Windows...


    Flo

  2. #2
    platinum NNTP User

    Default Re: libssl.so.7

    > could someone please tell me where to get libssl.so.7?
    > It is required by nearly all multimedia applications on openSuse11.1
    > but "nothing provides libssl.so.7".
    > Your help would be so great as I really want to listen to my music in
    > Linux, too, not just in Windows...


    if you go to http://tinyurl.com/6jwtg9 post #5
    <http://forums.opensuse.org/install-boot-login/401696-newbies-suse-11-1-pre-installation-please-read.html#post1908012>

    and set up your repositories in accordance with the info there...and,
    then CONTINUE on that page by installing restricted formats and
    multimedia stuff....THEN, what on your system does not work without
    libssl.so.7 ??

    note, i don't have a libssl.so.7 on my machine but i can listen to
    music from CDs, DVDs, various web sites like youtube, facebook, etc
    etc etc via the mplayer plug in in firefox or Amarok, Banshee,
    Kaffeine, Totem, VLC, etc etc etc , but maybe i'd need one to run what
    you are wanting to run..

    sorry if this is not the help you needed..

    --
    platinum

  3. #3
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: libssl.so.7

    i'm also puzzled by this requirement. one of my machines runs 11.1, the other 11.2, and neither of them uses any "libssl.so.7" while playing mp3 in various applications, including kaffeine, amarok, and xmms.

    normally you'll find any libs at this address: Webpin, but this also doesn't show "libssl.so.7*" anywhere.

    if you're sure this isn't a typo, i'd like to see what repos you have enabled. you could post the output of "zypper lr -u", from a root terminal. (please post it as code, so that the URLs won't be mixed up.)

    or are you trying to install xmms from source, latest trunk perhaps?

  4. #4

    Wink Re: libssl.so.7

    Hi,

    thank you two. I still haven't installed libssl.so.7 but your hints helped to solve my problems anyway: After installing the codecs mentioned in your links, I can now play mp3 files using kaffeine (and by the way eventually videos - I always wondered what kaffeine is for if it can't play anything...). It can't read id3v2-tags and crashes a lot while playing music though (in case someone from the programming crew reads this: it seems to be connected with the cool graphic display while playing music).

    I also could install xmms meanwhile: the trick is not to choose the "xmms" package in Yast directly but just the other xmms-things, i.e. xmms-agent and suchlike. "xmms" is then selected automatically by Yast which means the error message about libssl.so.7 (no typo) doesn't appear. And the installed xmms works alright.

    Strange trick but works.


    So bye and thanks again, I'm going to listen to my favorites from Billy Joel and Sting now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •