Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to turn on better fonts antialiasing for KDE4

  1. #1

    Default How to turn on better fonts antialiasing for KDE4

    Hi All!

    I am using SUSE 11.1 and KDE4 4.3.1 from build service repositories. Also I recompiled FreeType2 (using srcrpm and build) to enable subpixel antialiasing. In KDE settings antialiasing is enabled, including subpixel. All menus and buttons looks great, but still KWrite's text area and KHTML rendering looks ugly when comparing to what I had with 11.0 with default KDE3 installation.

    Tell me please is there any way to enable something in fonts.conf or freetype1.spec or freetype2.spec to enable better antialiasing for MS fonts (like Arial and Consolas) and DejaVu Sans Mono in KWrite editing area.

    Links to build instructions and fonts.conf options are appreciated.

    PS: my Arial looks like antialiasing is completely off, but Consolas looks like File:Consolas-programming-2.png - Wikipedia, the free encyclopedia this one.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to turn on better fonts antialiasing for KDE4

    This is my setting:


    it rocks at this and FYI, is way better than in Vista
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: How to turn on better fonts antialiasing for KDE4

    caf, thanx for you reply.

    I have the same settings but Medium instead of "Full". I don't know why but "Full" on my system is almost the same as "Minimum", while "Medium" looks really great.

    Also, monospaced on your screenshot is a bit ugly as for me. And my fonts in all KDE parts (buttons, menus, labels, ...) are very pretty, but ugly in KWrite and KHTML.

  4. #4

    Default Re: How to turn on better fonts antialiasing for KDE4

    I hope you have got your solutions. But here is one link which made fonts look great in my openSUSE 11.2, KDE 4.3.5 system.. Font smoothing in OpenSUSE 11.2 | We love Linux !. Just in case someone comes searching to this thread like me
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  5. #5
    Join Date
    Mar 2010
    Location
    London, UK
    Posts
    75

    Default Re: How to turn on better fonts antialiasing for KDE4

    Nevermind, I didn't realize the date of the original post !
    Last edited by Raffles10; 29-Mar-2010 at 12:57. Reason: old thread
    Samsung RV510 + openSUSE 12.1 64bit + KDE 4.7.2

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,852
    Blog Entries
    14

    Default Re: How to turn on better fonts antialiasing for KDE4

    Quote Originally Posted by Raffles10 View Post
    Nevermind, I didn't realize the date of the original post !
    Nevertheless, thanks to your reply I saw Caf4926's post; I'm now looking at the nicest fonts I've ever had.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jan 2010
    Location
    Orlando, FL
    Posts
    212

    Default Re: How to turn on better fonts antialiasing for KDE4

    Quote Originally Posted by caf4926 View Post
    This is my setting:


    it rocks at this and FYI, is way better than in Vista
    Same here....one of the first things I do after a KDE install
    Cheers, Big Ears!

    DΞLL Precision M6500: i7-820QM w/USB 3.0, 8.0GB DDR3-1333, Intel x-25M 160 G2 + 500GB 7200.3, nVidia Quadro FX 3800M 1.0GB DDR3, RGBLED, Intel 6300//Win7Pro x64
    DΞLL Vostro 1220 //openSUSE 11.3 KDE/Win7Pro 32

  8. #8
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: How to turn on better fonts antialiasing for KDE4

    Font settings are very subjective, especially the anti-aliasing. I find Hinting: Full far too soft and blurry, and always choose "Slight".
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  9. #9

    Default Re: How to turn on better fonts antialiasing for KDE4

    Quote Originally Posted by gminnerup View Post
    Font settings are very subjective, especially the anti-aliasing. I find Hinting: Full far too soft and blurry, and always choose "Slight".
    Yes they are... I used to disable anti-aliasing before because I liked sharp fonts. But I have started loving anti-aliasing now.
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  10. #10

    Default Re: How to turn on better fonts antialiasing for KDE4

    I have some very specific subpixel patches in my OBS repo at :- Index of /repositories/home:/anshuljain/openSUSE_11.2. It will upgrade your fontconfig, cairo and freetype packages from the stock Opensuse-subpixel disabled ones to LCD/Ubuntu patched RPMs. I have managed to achieve a consistent look with Vista fonts (Calibri and Consolas) using the packages in the repo above.

    My ideal combination is Calibri fonts size 10 and consolas size 9. You may have to add a .Xresources file in your /home directory with the following contents:-

    Xft.lcdfilter: lcddefault
    Xft.hintstyle: hintslight

    A screenshot is at:-

    Hope this works for you.

    -Anshul

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •