Results 1 to 9 of 9

Thread: Sound settings not saved after reboot

  1. #1
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Sound settings not saved after reboot

    The sound itself always works fine on my wife's laptop, but it doesn't detect the usb mic, and in Kmix or Pulseaudio it lists a Null device. I found that if I go into YaST and reconfigure the sound card, it then displays correctly in Kmix and Pulseaudio volume control, and detects the usb mic correctly.

    Problem solved, except after a reboot the sound is again displayed as a null device until you reconfigure the sound card in YaST again. Is there a way to "save" this configuration so it doesn't need to be reconfigured every time she wants to use the USB mic?

    I went through a bunch of the audio troubleshooting guides, but couldn't find this problem. Any help would be appreciated.

    Sound card is listed as "82801G (ICH7 Family) High Definition Audio" is YaST, and she is running 11.1.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound settings not saved after reboot

    Quote Originally Posted by queequeg View Post
    The sound itself always works fine on my wife's laptop, but it doesn't detect the usb mic, and in Kmix or Pulseaudio it lists a Null device. I found that if I go into YaST and reconfigure the sound card, it then displays correctly in Kmix and Pulseaudio volume control, and detects the usb mic correctly.
    Its possible you need to apply an audio model to force the configuration at boot. Can you provide some more information?

    For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

    Note, I am on vacation, so it may be 3 to 4 days before I reply.

  3. #3
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Re: Sound settings not saved after reboot

    Thanks Oldcpu! The output link is : http://www.alsa-project.org/db/?f=b9...b17f426963a757

    Here are the other results:

    Code:
    Freya:/home/christina # rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    alsa-firmware-1.0.17-1.42
    alsa-plugins-pulse-1.0.18-6.12
    alsa-1.0.18-8.12.1
    alsa-tools-gui-1.0.18-1.13
    alsa-utils-1.0.18-6.4
    alsa-tools-1.0.18-1.13
    alsa-plugins-1.0.18-6.12
    alsamixergui-0.9.0rc1-584.132
    Code:
    Freya:/home/christina # rpm -qa | grep pulse
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    libxine1-pulse-1.1.16.3-2.pm.5.1
    pulseaudio-lang-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.12
    libpulse0-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    Code:
    Freya:/home/christina # rpm -q libasound2
    libasound2-1.0.18-8.12.1
    Code:
    Freya:/home/christina # uname -a
    Linux Freya 2.6.27.29-0.1-pae #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux
    Code:
    Freya:/home/christina # cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    # u1Nb.gRjQurT2Rl5:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    I don't know if it makes a difference, but I ran all these when things were "not working" (IE the sound had not been re-configured in YaST after rebooting.) If any of these commands need to be run after re-configuring, please let me know.

    Thanks again for responding, and I hope you enjoy your vacation.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound settings not saved after reboot

    Quote Originally Posted by queequeg View Post
    Thanks Oldcpu! The output link is : http://www.alsa-project.org/db/?f=b9...b17f426963a757
    Thanks!

    I note a 32-bit openSUSE-11.1 with the 2.6.27.29 pae kernel running on an HP Pavilion dv5000 with a CX20551(waikki) hardware audio codec. The CX20551 I believe used to be called the CX5047 before a name change.

    Searching the alsa web site for the CX20551 I obtained this hit: Search results - AlsaProject

    And searching for the 5047 I obtained this hit: Search results - AlsaProject

    Where the former in particular suggests there may be a fix for some headphone and master volume setting problem in the CX20551.

    Searching the alsa-configuratin.txt file, I note this for the CX5047:
    Code:
    	Conexant 5047
    	  laptop	Basic Laptop config 
    	  laptop-hp	Laptop config for some HP models (subdevice 30A5)
    	  laptop-eapd	Laptop config with EAPD support
    	  test		for testing/debugging purpose, almost all controls
    			can be adjusted.  Appearing only when compiled with
    			$CONFIG_SND_DEBUG=y
    which suggests there are some model options that can be forced if necessary for the CX5047, BUT you note that works fine, and it is only the USB mic that does not function, and hence I do not recommend any changes there.

    I do not see the USB mic in the script output. Was it plugged in when you ran the script? I needs to be plugged in when the script is run.

    I have read that some users require that the mic be plugged in when openSUSE is booted, in order for the mic to be recognized. Maybe you could try that.

  5. #5
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Re: Sound settings not saved after reboot

    Thanks! Here is the script result when the USB mic is plugged in. (FYI, the mic is part of a webcam.)

    http://www.alsa-project.org/db/?f=15...d4fbf566bdf529

    Upon further testing, I think it may be related to pulseaudio. Skype is the program we are trying to get the mic to work with, and I've found that the sound itself doesn't work in Skype unless I run the config in YaST first. (After running the sound config in YaST, skype works great with both sound and mic.) I've read that Skype uses pulseaudio, and since the sound works perfectly otherwise I figure maybe that's part of the issue?

    Is there a different way to "lock" pulseaudio settings once they're configured?

    I haven't tried plugging the usb mic in when booting yet because it's probably just as simple to run the sound config when needed. (The mic/webcam is shared between two computers.)

    Thanks again, I appreciate you getting back to me so quickly.

  6. #6
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Re: Sound settings not saved after reboot

    On a whim, I ran the script again after doing a sound re-config in Yast. Here's the result:

    http://www.alsa-project.org/db/?f=d9...52f2a0d3d0a746

    Thanks!

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound settings not saved after reboot

    Quote Originally Posted by queequeg View Post
    Here is the script result when the USB mic is plugged in. (FYI, the mic is part of a webcam.)

    http://www.alsa-project.org/db/?f=15...d4fbf566bdf529
    I can't help re: Skype, as I never user it.

    I do note this from the script, where your nominal audio hardware is card 0 and your USB device card 1:
    !!-------Mixer controls for card 1 [default]

    Card hw:1 'default'/'Camera at usb-0000:00:1d.0-1, full speed'
    Mixer name : 'USB Mixer'
    Components : 'USB046d:08a6'
    Controls : 3
    Simple ctrls : 2
    Simple mixer control 'Mic',0
    Capabilities: cvolume cvolume-joined cswitch cswitch-joined
    Capture channels: Mono
    Limits: Capture 0 - 3
    Mono: Capture 3 [100%] [60.00dB] [on]
    Simple mixer control 'Auto Gain Control',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [off]
    You could try switching on the "auto gain control". ...

    Please also take note of this URL (for headphones, NOT for a mic, but there may be something of value there): USB headphones - openSUSE

    Also, when testing your MIC, please note this URL:
    Microphone - openSUSE

    and in particular use this test from a terminal when talking into the mic:
    arecord -vv -fdat foo.wav
    where "foo.wav" is some arbitrary name/file that you pick to save the recording to a wav file.

    Quote Originally Posted by queequeg View Post
    I haven't tried plugging the usb mic in when booting yet because it's probably just as simple to run the sound config when needed. (The mic/webcam is shared between two computers.)
    OK, as long as that works, but I note in the script in your last post the USB device was NOT detected. I have a friend back in the continent where I used to live, who is struggling with his USB mic under openSUSE, and he advised me the openSUSE-11.1 automount for USB mics does not work well.

  8. #8
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Re: Sound settings not saved after reboot

    It looks like I need to re-plug in the camera/mic once the sound is re-configured in YaST for it to show up. Here's the result again after a re-config with the Camera/mic:
    http://www.alsa-project.org/db/?f=8d...7f4f4e1c3de8a5

    Where can I turn on the Auto Gain Control?

    Thanks for the links, and for all your help. I'll check them out.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound settings not saved after reboot

    Quote Originally Posted by queequeg View Post
    Where can I turn on the Auto Gain Control?
    It should be a control in your mixer. In kmix, for example, one can select which audio card one is trying to tune, and then add controls as appropriate (via a channel menu item) to provide the needed control. I'm not a gnome user so I can not say much about alsamixer.

    You can also use amixer. If you type "man amixer" you can learn more about its controls. For example, "amixer help" gives a good summary of the amixer syntax. "amixer scontrols" gives a good summary of the various controls that can be adjusted with amixer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •