Results 1 to 6 of 6

Thread: Xine doesn't work in Amarok

  1. #1

    Default Xine doesn't work in Amarok

    Hi,

    I use Amarok for playing music. The problem I have is that I cannot use the Xine engine. I have it installed, but whenever I select it as the engine, it gives me this notification when I want to play an mp3 file:
    "Amarok currently cannot play MP3 files."
    "Install MP3 Support"---"Continue".
    Following the link to Install support doesn't help either.
    So, how can I fix it?
    Thank you

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,857

    Default Re: Xine doesn't work in Amarok

    openSUSE version? Amarok version? .......
    Henk van Velden

  3. #3

    Default Re: Xine doesn't work in Amarok

    opensuse 11.1
    amarok 1.4.10(using KDE 3.5.10 "release 21.11" opensuse"

  4. #4
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: Xine doesn't work in Amarok

    On Fri, 2009-09-18 at 18:56 +0000, ipoloton wrote:
    > opensuse 11.1
    > amarok 1.4.10(using KDE 3.5.10 "release 21.11" opensuse"
    >
    >


    For xine to play mp3 (not gstreamer), I think you pretty much have to
    use the Packman version. That's what I do. Not sure if I ever tested
    this on 11.1 or not... but pretty sure that's what is required.

    It may also require something else for mp3 in addition to that, but the
    xine that comes with oS (I seem to remember) is permanently hampered
    from playing formats where there may be a legal issue.



  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Xine doesn't work in Amarok

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Xine doesn't work in Amarok

    cjcox wrote:

    > On Fri, 2009-09-18 at 18:56 +0000, ipoloton wrote:
    >> opensuse 11.1
    >> amarok 1.4.10(using KDE 3.5.10 "release 21.11" opensuse"
    >>
    >>

    >
    > For xine to play mp3 (not gstreamer), I think you pretty much have to
    > use the Packman version. That's what I do. Not sure if I ever tested
    > this on 11.1 or not... but pretty sure that's what is required.
    >
    > It may also require something else for mp3 in addition to that, but the
    > xine that comes with oS (I seem to remember) is permanently hampered
    > from playing formats where there may be a legal issue.

    This is my understanding too. You can get it going by doing the following:

    Adding the Packman Repo
    (Yast-->Software-->Software Repositories-->Community Repositories-->Packman)
    or if it doesn't appear in the list add an http repository with the
    Servername of ftp.skynet.be and the directory on the server
    of /pub/packman/suse/11.1/ for OpenSuse 11.1..

    Installing Xine and Amarok from the Packman Repo
    Yast-->Software-->Software Management. Search for amarok. Click on it to
    select it then on the tab marked 'Versions'. Pick the radio button to
    select the most recent version with 'pm' in it (if there's an i586 and an
    x86_64 version select the one that's appropriate for your architecture).

    When you click accept it will throw up messages about dependencies. Choose
    to continue (with vendor change) for them.

    Let the install run and try it out.

    If it's still not working you may need the w32codecs package again from the
    packman repo.

    Incidentally, you may want to run an online update and select to upgrade all
    packages after adding the repo.

    --
    kev.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •