Results 1 to 7 of 7

Thread: secondary SATA drive mount problem

  1. #1
    project722 NNTP User

    Default secondary SATA drive mount problem

    Got a box running 64bit opensuse 11.0. Just did a clean install and the secondary SATA drive does not mount automatically. Once booted, I can mount it manually, access the drive and it works fine, but whenever I log into another account or restart the machine it loses the mount point and I have to re-do everything. I've also got an external USB HD that does the same thing.

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: secondary SATA drive mount problem

    post your fstab

  3. #3
    project722 NNTP User

    Default Re: secondary SATA drive mount problem

    /dev/disk/by-id/scsi-SATA_ST3500320NS_9QM92YM3-part9 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_ST3500320NS_9QM92YM3-part6 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_ST3500320NS_9QM92YM3-part10 /home ext3 acl,user_xattr 1 2
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

  4. #4
    project722 NNTP User

    Default Re: secondary SATA drive mount problem

    forgot to add that /etc/dev sees it as /dev/sdb1 so should I just plug that into fstab and what would the new line look like if thats what i do?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: secondary SATA drive mount problem

    Code:
    /dev/sdb1 /<where-you-want-it> ext3 acl,user_xattr 1 2
    But you could use also /dev/disk-by-id/... for /dev/sdb1. Look in /dev/disk-by-id/ for the entry that links to /dev/sdb1 (or use any of the other /dev/disk-by-.../ entries that link to /dev/sdb1. There are PROs and CONs for using any of those. openSUSE choose the by-id ones because even when sda and sdb are exchanged for some reason (hardware detection) the correct partitions are mounted because they are recocnised by their id.

    I hope you understand that <where-you-want-it> is to be filled in by you, because you did not tell us where you want it mounted. The only thing being that that directory must exist (and the access bits must be set according to the use made of it).

    The whole task can also be done by using YaST > System > System partitioning. You will find sdb1 there and can fill in file system type, where you want to mount it and with by-id,etc. or not. Very important, UNCHECK the FORMAT box, else your data is gone.
    Henk van Velden

  6. #6
    project722 NNTP User

    Default Re: secondary SATA drive mount problem

    Thanks I have edited the fstab and its recognizing the HD on reboots now. I must have done it right.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: secondary SATA drive mount problem

    Congrats!

    But it did recognise the disk already, else there would not have been any device special file (/dev/sdb and /dev/sdb1 and consorts).

    It simply mounts the the partition now because you configured it. You are the boss (read system manager), not the system!

    I recommend reading through SDB:Basics of partitions, filesystems, mount points - openSUSE when you have some time left.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •